summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHans-Nikolai Viessmann2018-08-13 18:29:54 +0100
committerHans-Nikolai Viessmann2018-08-13 18:29:54 +0100
commite77dec20a510939c06e4508d76a9b5469155bb84 (patch)
tree1e82ff41490362a4e2629c185391e5faf503d921
downloadaur-e77dec20a510939c06e4508d76a9b5469155bb84.tar.gz
initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD23
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4522b292ac15
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python-spython
+ pkgdesc = Singularity Python is a Python API to work with the Singularity open source software
+ pkgver = 0.0.38
+ pkgrel = 1
+ url = https://singularityhub.github.io/singularity-cli/
+ arch = any
+ license = AGPL3
+ depends = python
+ optdepends = singularity-container: to use and manipulate Singularity Containers
+ source = https://files.pythonhosted.org/packages/source/s/spython/spython-0.0.38.tar.gz
+ sha256sums = 31f1f82b968195edfe43d5fa380034f88d66b29550a08ccc809df26190457346
+
+pkgname = python-spython
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..aef6331542e1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Hans-Nikolai Viessmann <hans AT viess.mn>
+pkgname=python-spython
+_pkgname=spython
+pkgver=0.0.38
+pkgrel=1
+pkgdesc="Singularity Python is a Python API to work with the Singularity open source software"
+arch=('any')
+url="https://singularityhub.github.io/singularity-cli/"
+license=('AGPL3')
+depends=('python')
+optdepends=('singularity-container: to use and manipulate Singularity Containers')
+source=("https://files.pythonhosted.org/packages/source/${_pkgname::1}/${_pkgname}/${_pkgname}-${pkgver}.tar.gz")
+sha256sums=('31f1f82b968195edfe43d5fa380034f88d66b29550a08ccc809df26190457346')
+
+build() {
+ cd "${_pkgname}-${pkgver}"
+ /usr/bin/python setup.py build
+}
+
+package() {
+ cd "${_pkgname}-${pkgver}"
+ /usr/bin/python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+}