summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRobin Baumgartner2016-02-25 02:07:39 +0100
committerRobin Baumgartner2016-02-25 02:16:57 +0100
commite7a25534544837bf2d340438a969fb5c9c7c3835 (patch)
tree92555934ed7e740458e0c4d32409ae04b5ffd0d3
parent19f0ab823427253ccc2941603dc6f8052d93a12a (diff)
downloadaur-e7a25534544837bf2d340438a969fb5c9c7c3835.tar.gz
Add default config file
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD12
-rw-r--r--trytond.conf44
-rw-r--r--trytond.install11
-rw-r--r--trytond.service2
5 files changed, 67 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ebaaca5c666c..85e189c5cc06 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Wed Feb 24 23:07:25 UTC 2016
+# Thu Feb 25 01:16:38 UTC 2016
pkgbase = trytond
pkgdesc = A three-tiers high-level general purpose application platform (server application)
pkgver = 3.8.3
- pkgrel = 1
+ pkgrel = 2
url = http://www.tryton.org/
install = trytond.install
arch = any
@@ -21,12 +21,15 @@ pkgbase = trytond
optdepends = pydot: support for displaying workflow graphs
optdepends = python-pytz: timezone support
optdepends = pyopenssl: support for SSL connection
+ backup = etc/trytond.conf
source = http://downloads.tryton.org/3.8/trytond-3.8.3.tar.gz
+ source = trytond.conf
source = trytond.install
source = trytond.service
md5sums = 5000aef75a016444eb082c906718f533
- md5sums = 768e68c01cb5913e36ea89c67fc98038
- md5sums = b1535a8528dfd8f655624bf6faea6985
+ md5sums = db21177e78e6983d85feb14436f5a7ba
+ md5sums = bc93f99ec68feea9f3e3e11e2cb2b735
+ md5sums = c3318e663c17194d71f6ef4ded16b293
pkgname = trytond
diff --git a/PKGBUILD b/PKGBUILD
index b0a5249f5c71..d49b219afb30 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=trytond
pkgver=3.8.3
_pkgdir=3.8
-pkgrel=1
+pkgrel=2
pkgdesc="A three-tiers high-level general purpose application platform (server application)"
arch=('any')
url="http://www.tryton.org/"
@@ -17,13 +17,16 @@ optdepends=('python2-psycopg2: support for PostgreSQL database'
'python-pytz: timezone support'
'pyopenssl: support for SSL connection')
makedepends=('python2-distribute')
+backup=('etc/trytond.conf')
install="trytond.install"
source=("http://downloads.tryton.org/$_pkgdir/$pkgname-$pkgver.tar.gz"
+ 'trytond.conf'
'trytond.install'
'trytond.service')
md5sums=('5000aef75a016444eb082c906718f533'
- '768e68c01cb5913e36ea89c67fc98038'
- 'b1535a8528dfd8f655624bf6faea6985')
+ 'db21177e78e6983d85feb14436f5a7ba'
+ 'bc93f99ec68feea9f3e3e11e2cb2b735'
+ 'c3318e663c17194d71f6ef4ded16b293')
build() {
cd $srcdir/$pkgname-$pkgver
@@ -33,5 +36,6 @@ build() {
package() {
cd $srcdir/$pkgname-$pkgver
python2 setup.py install --root=$pkgdir --optimize=1
- install -D -m755 $startdir/trytond.service $pkgdir/usr/lib/systemd/system/trytond.service
+ install -D -m640 "$srcdir/trytond.conf" "$pkgdir/etc/trytond.conf"
+ install -D -m755 "$srcdir/trytond.service" "$pkgdir/usr/lib/systemd/system/trytond.service"
}
diff --git a/trytond.conf b/trytond.conf
new file mode 100644
index 000000000000..d38be139d986
--- /dev/null
+++ b/trytond.conf
@@ -0,0 +1,44 @@
+# Configuration file for the Tryton server.
+#
+# See the Tryton documentation for a description of the options:
+# http://doc.tryton.org/3.8/trytond/doc/topics/configuration.html
+
+[jsonrpc]
+#listen = localhost:8000
+#hostname =
+#data = /var/www/localhost/tryton
+
+[xmlrpc]
+#listen =
+
+[webdav]
+#listen =
+
+[database]
+#uri = sqlite://
+#path = /var/lib/trytond/
+#list = True
+#retry = 5
+#language = en_US
+
+[cache]
+#model = 200
+#record = 2000
+#field = 100
+
+[table]
+
+[ssl]
+#privatekey =
+#certificate =
+
+[email]
+#uri =
+#from =
+
+[session]
+#timeout =
+#super_pwd =
+
+[report]
+#unoconv =
diff --git a/trytond.install b/trytond.install
index 46d6daabadd0..453bcac1dcc2 100644
--- a/trytond.install
+++ b/trytond.install
@@ -2,17 +2,20 @@ post_install() {
echo
echo "Adding tryton group... "
groupadd tryton
- echo
echo "Adding tryton user... "
useradd -c "Tryton Server Daemon" -g tryton -s /bin/false tryton
+ echo
echo "Note:"
- echo "==> Please don't forget to configure your PostgreSQL database for the program."
+ echo "- Tryton modules can be installed using pip2, e.g. 'pip2 install trytond-party'."
+ echo "- Configure Tryton using the config file /etc/trytond.conf."
+ echo "- See the Tryton documentation at http://doc.tryton.org for more information."
+ echo
}
post_remove() {
- echo "Removing tryton system user... "
- userdel tryton && echo "trytond [done]"
+ echo "Removing tryton user... "
+ userdel tryton
}
op=$1
diff --git a/trytond.service b/trytond.service
index 7d85691b366b..853d45fcf339 100644
--- a/trytond.service
+++ b/trytond.service
@@ -4,7 +4,7 @@ Description=Tryton Server Daemon
[Service]
Type=simple
User=tryton
-ExecStart=/usr/bin/trytond
+ExecStart=/usr/bin/trytond -c /etc/trytond.conf
[Install]
WantedBy=multi-user.target