summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYen Chi Hsuan2017-06-03 11:15:43 +0800
committerYen Chi Hsuan2017-06-03 11:15:43 +0800
commite7cf9bd691dd038a41f1d90ba5a39113321e750e (patch)
tree8f9d3167fca4572de4eab8df2c9aa7eb43818d07
parent3fb6431d6d7bd0c3fb1a955a521f3ad1966afd3a (diff)
downloadaur-e7cf9bd691dd038a41f1d90ba5a39113321e750e.tar.gz
Bump to 20170602.r363.b931596
My building fixes are merged
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD16
2 files changed, 6 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c2a2b3ad5751..b28318e41200 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = fb-adb-git
pkgdesc = A better shell to use in place of adb when connecting to Android devices
- pkgver = 20170417.r359.0cc0534
- pkgrel = 2
+ pkgver = 20170602.r363.b931596
+ pkgrel = 1
url = https://github.com/facebook/fb-adb
arch = x86_64
license = GPL3
@@ -13,9 +13,7 @@ pkgbase = fb-adb-git
options = !strip
options = !buildflags
source = git+https://github.com/facebook/fb-adb.git
- source = fix-build.patch::https://github.com/facebook/fb-adb/pull/59.patch
sha512sums = SKIP
- sha512sums = 9f18e251c864acd94d73357e2c8f48e29946498d46e04ac7d518844fea6f774ea066292f3068088bd46c1283d7a642abf52a270990d0fc0f909d10bd4c3053c3
pkgname = fb-adb-git
diff --git a/PKGBUILD b/PKGBUILD
index d8967be75b38..da867ab3c4ef 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,8 +5,8 @@ _TARGET_API=19
_pkgname=fb-adb
pkgname=$_pkgname-git
-pkgver=20170417.r359.0cc0534
-pkgrel=2
+pkgver=20170602.r363.b931596
+pkgrel=1
pkgdesc='A better shell to use in place of adb when connecting to Android devices'
url='https://github.com/facebook/fb-adb'
license=('GPL3')
@@ -14,22 +14,14 @@ arch=('x86_64')
depends=('android-tools')
makedepends=('git' 'vim' 'android-sdk-build-tools' "android-platform-$_TARGET_API")
options=('!strip' '!buildflags')
-source=("git+$url.git"
- "fix-build.patch"::"https://github.com/facebook/fb-adb/pull/59.patch")
-sha512sums=('SKIP'
- '9f18e251c864acd94d73357e2c8f48e29946498d46e04ac7d518844fea6f774ea066292f3068088bd46c1283d7a642abf52a270990d0fc0f909d10bd4c3053c3')
+source=("git+$url.git")
+sha512sums=('SKIP')
pkgver() {
cd $_pkgname
printf "%s.r%s.%s" "$(git show -s --format=%ci master | sed 's/\ .*//g;s/-//g')" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
-prepare() {
- cd $_pkgname
-
- patch -Np1 -i ../fix-build.patch
-}
-
build() {
# configure
cd $_pkgname