summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoraksr2015-06-29 07:31:43 +0200
committeraksr2015-06-29 07:31:43 +0200
commite7d80213e2fc78a3ce12a38288d9550f221d6975 (patch)
treee30f472d3690773eafa4c31f2c62a7bb3b5a642f
downloadaur-e7d80213e2fc78a3ce12a38288d9550f221d6975.tar.gz
Start.
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD30
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..390348a98532
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = inotail-git
+ pkgdesc = An inotify based implementation of tail.
+ pkgver = r270.a449425
+ pkgrel = 1
+ url = http://distanz.ch/inotail
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ provides = inotail
+ conflicts = inotail
+ source = inotail-git::git+https://gitorious.org/inotail/inotail.git
+ md5sums = SKIP
+
+pkgname = inotail-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f8f95a3dcaf6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Contributor: Dave Reisner <d@falconindy.com>
+# Maintainer: aksr <aksr at t-com dot me>
+pkgname=inotail-git
+pkgver=r270.a449425
+pkgrel=1
+pkgdesc="An inotify based implementation of tail."
+arch=('i686' 'x86_64')
+url="http://distanz.ch/inotail"
+license=('GPL')
+makedepends=('git')
+provides=('inotail')
+conflicts=('inotail')
+source=("$pkgname::git+https://gitorious.org/inotail/inotail.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$srcdir/$pkgname"
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname"
+ make prefix="$pkgdir/usr" install
+}
+