summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorxpt2017-09-21 14:28:56 -0300
committerxpt2017-09-21 14:28:56 -0300
commite7fbb96c48eff31b912492cf6e93abe7aadfb1df (patch)
tree137b20c91caa71b8991989dc71b589ee69a808fa
parentda09455fe433c396c941c95513bb18e31f00a9d3 (diff)
downloadaur-e7fbb96c48eff31b912492cf6e93abe7aadfb1df.tar.gz
Fix issues
-rw-r--r--.SRCINFO10
-rw-r--r--OpenStudio.desktop10
-rwxr-xr-xPKGBUILD16
-rwxr-xr-xpatch_desktop.patch4
4 files changed, 26 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 312e70f48836..c76383d1283f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,17 @@
# Generated by mksrcinfo v8
-# Sat Jul 15 17:33:53 UTC 2017
+# jue sep 21 17:28:26 UTC 2017
pkgbase = openstudio
pkgdesc = Supports whole building energy modeling using EnergyPlus
pkgver = 2.2.0
- pkgrel = 1
+ pkgrel = 2
url = https://www.openstudio.net
arch = x86_64
license = LGPL
depends = ruby
- source = https://github.com/NREL/OpenStudio/releases/download/2.2.0/OpenStudio-2.2.0.0a5e9cec3f-Linux.deb
- source = patch_desktop.patch
+ source = https://github.com/NREL/OpenStudio/releases/download/v2.2.0/OpenStudio-2.2.0.0a5e9cec3f-Linux.deb
+ source = OpenStudio.desktop
md5sums = 29928e772f125d48005d6a563424088a
- md5sums = 5afef8d61b5af033c69a26daa5959508
+ md5sums = 98bb96765a138f978e3cd780d571757a
pkgname = openstudio
diff --git a/OpenStudio.desktop b/OpenStudio.desktop
new file mode 100644
index 000000000000..4a0766350072
--- /dev/null
+++ b/OpenStudio.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Version=2.2.0
+Name=OpenStudio
+Comment=Supports whole building energy modeling using EnergyPlus
+Exec=LD_LIBRARY_PATH=/opt/openstudio/bin/:$LD_LIBRARY_PATH /opt/openstudio/bin/OpenStudioApp %f
+Terminal=false
+Type=Application
+Icon=OpenStudio
+Categories=Science;Engineering;
+MimeType=application/openstudio.osm;
diff --git a/PKGBUILD b/PKGBUILD
index 79451d4ed7e3..be54e27f52af 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: xpt <user.xpt@gmail.com>
pkgname=openstudio
pkgver=2.2.0
-pkgrel=1
+pkgrel=2
_relvar='0a5e9cec3f'
pkgdesc="Supports whole building energy modeling using EnergyPlus"
arch=('x86_64')
@@ -9,15 +9,17 @@ url="https://www.openstudio.net"
depends=('ruby')
# optdep=('energyplus')
license=('LGPL')
-source=("https://github.com/NREL/OpenStudio/releases/download/$pkgver/OpenStudio-$pkgver.$_relvar-Linux.deb" 'patch_desktop.patch')
-md5sums=('29928e772f125d48005d6a563424088a' '5afef8d61b5af033c69a26daa5959508')
+source=("https://github.com/NREL/OpenStudio/releases/download/v$pkgver/OpenStudio-$pkgver.$_relvar-Linux.deb" 'OpenStudio.desktop')
+md5sums=('29928e772f125d48005d6a563424088a' '98bb96765a138f978e3cd780d571757a')
package() {
cd "${srcdir}/"
-tar Jxvf data.tar.xz -C .
-cp -r usr ${pkgdir}
-
-patch -uNp1 ${pkgdir}/usr/share/applications/OpenStudio.desktop ${srcdir}/patch_desktop.patch
+tar -zxvf data.tar.gz -C .
+mkdir -p ${pkgdir}/opt/openstudio/
+mkdir -p ${pkgdir}/usr/share/applications
+cp -r usr/* ${pkgdir}/opt/openstudio/
+cp OpenStudio.desktop ${pkgdir}/usr/share/applications
}
+
diff --git a/patch_desktop.patch b/patch_desktop.patch
index 8707536a7d31..c18ca7880ea7 100755
--- a/patch_desktop.patch
+++ b/patch_desktop.patch
@@ -3,11 +3,11 @@
@@ -1,8 +1,8 @@
[Desktop Entry]
-Version=1.0
-+Version=1.8
++Version=2.2.0
Name=OpenStudio
Comment=Supports whole building energy modeling using EnergyPlus
-Exec=/usr/local/bin/OpenStudio %f
-+Exec=LD_LIBRARY_PATH=/usr/local/share/openstudio-1.8.0/lib/:$LD_LIBRARY_PATH /usr/local/bin/OpenStudio %f
++Exec=LD_LIBRARY_PATH=/usr/local/share/openstudio-2.2.0/lib/:$LD_LIBRARY_PATH /usr/local/bin/OpenStudio %f
Terminal=false
Type=Application
Icon=OpenStudio