summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorZhirui Dai2024-04-28 14:58:20 -0700
committerZhirui Dai2024-04-28 14:58:20 -0700
commite83a9acaf465a7f2dea7b4141397aab1287c6e04 (patch)
tree2ba60cc2f3c5e59a888361ce61924db36929869a
parentc32d82701cdc8f41609749323965916e3ea7a793 (diff)
downloadaur-e83a9acaf465a7f2dea7b4141397aab1287c6e04.tar.gz
update package to 0.4.0
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD24
2 files changed, 24 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4b218a54249f..ff2d4770d76f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,16 @@
pkgbase = python-colcon-package-information
pkgdesc = An extension for colcon-core to provide information about the packages.
- pkgver = 0.3.3
+ pkgver = 0.4.0
pkgrel = 1
url = https://pypi.org/project/colcon-package-information/
arch = any
license = Apache
makedepends = python-setuptools
+ makedepends = flake8
depends = python-colcon-core
- source = https://files.pythonhosted.org/packages/source/c/colcon-package-information/colcon-package-information-0.3.3.tar.gz
- sha256sums = db0b1200bfec91fcf396d9d7671eb410f0eb5a18a0819f778f335ebac82e0b9e
+ source = https://github.com/colcon/colcon-package-information/archive/refs/tags/0.4.0.tar.gz
+ source = https://github.com/myint/scspell/archive/refs/tags/v2.2.tar.gz
+ sha256sums = 1ea7d25cb0ccafc8f7c7ab56e49aad27cf67c15091c3fad6418808c4d3ab6cd8
+ sha256sums = 04c6a795a9e0ef4571678eb9fc503bcf39106a975691336af778f31a01027082
pkgname = python-colcon-package-information
-
diff --git a/PKGBUILD b/PKGBUILD
index 069554ca73d2..809e2346baf3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,21 +2,33 @@
# Contributor: Tong Chunli<t.cunly at 163 dot com>
pkgname=python-colcon-package-information
_name=${pkgname:7}
-pkgver=0.3.3
+pkgver=0.4.0
pkgrel=1
pkgdesc="An extension for colcon-core to provide information about the packages."
arch=(any)
url="https://pypi.org/project/colcon-package-information/"
license=('Apache')
depends=('python-colcon-core')
-makedepends=('python-setuptools')
-source=(https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz)
-sha256sums=('db0b1200bfec91fcf396d9d7671eb410f0eb5a18a0819f778f335ebac82e0b9e')
+makedepends=('python-setuptools' 'flake8')
+source=(
+ https://github.com/colcon/colcon-package-information/archive/refs/tags/${pkgver}.tar.gz
+ https://github.com/myint/scspell/archive/refs/tags/v2.2.tar.gz)
+sha256sums=('1ea7d25cb0ccafc8f7c7ab56e49aad27cf67c15091c3fad6418808c4d3ab6cd8'
+ '04c6a795a9e0ef4571678eb9fc503bcf39106a975691336af778f31a01027082')
+build() {
+ cd ${srcdir}/${_name}-${pkgver}
+ python -m build --wheel --no-isolation
+}
+
+check() {
+ cd ${srcdir}/${_name}-${pkgver}/test
+ export PYTHONPATH="${srcdir}/scspell-2.2:${srcdir}/${_name}-${pkgver}"
+ ls test*.py | xargs -I {} pytest {}
+}
package() {
cd ${srcdir}/${_name}-${pkgver}
-
- python setup.py install --root=${pkgdir} --prefix=/usr --optimize=1
+ python -m installer --destdir="${pkgdir}" dist/*.whl
install -D -m644 README.rst -t "${pkgdir}/usr/share/doc/${pkgname}"
}