summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgbr2020-05-31 23:45:16 -0300
committergbr2020-05-31 23:45:16 -0300
commite85efcc0bf46486faf7d6b5eb011f8979b615512 (patch)
treef55dbdb34c566c37a007f50e69faddf61d4378df
parent4fad8102a2ae50b9f2514474d5816da1014d0ccb (diff)
downloadaur-e85efcc0bf46486faf7d6b5eb011f8979b615512.tar.gz
add workaround for building
some upstream changes were made to the build process, e.g. icons with different dimensions were removed; only one icon is installed to /usr/share/icons; the desktop file is installed as "application.desktop" this commit work around these issues for now.
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD20
2 files changed, 13 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index efe1e7990f8c..e48ac3dd95ac 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,17 @@
pkgbase = vibrantlinux-git
pkgdesc = vibranceGUI replacement for Linux
- pkgver = 2.1.1.r0.g59b8045
+ pkgver = 2.1.1.r7.g1dc6b43
pkgrel = 1
url = https://github.com/zee-mzha/vibrantlinux
arch = x86_64
license = MIT
makedepends = git
+ makedepends = imagemagick
depends = qt5-base
depends = libvibrant
provides = vibrantlinux
conflicts = vibrantlinux
source = vibrantlinux::git+https://github.com/zee-mzha/vibrantLinux.git
- source = vibrantLinux.desktop
- sha256sums = SKIP
sha256sums = SKIP
pkgname = vibrantlinux-git
diff --git a/PKGBUILD b/PKGBUILD
index dbcc57466ceb..94627558eb55 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,12 +7,12 @@ arch=('x86_64')
url='https://github.com/zee-mzha/vibrantlinux'
license=('MIT')
depends=('qt5-base' 'libvibrant')
-makedepends=('git')
+makedepends=('git' 'imagemagick')
conflicts=('vibrantlinux')
provides=('vibrantlinux')
-source=("${_pkgname}::git+https://github.com/zee-mzha/vibrantLinux.git" 'vibrantLinux.desktop')
-sha256sums=('SKIP' 'SKIP')
-pkgver=2.1.1.r0.g59b8045
+source=("${_pkgname}::git+https://github.com/zee-mzha/vibrantLinux.git")
+sha256sums=('SKIP')
+pkgver=2.1.1.r7.g1dc6b43
pkgver() {
cd "${_pkgname}"
@@ -24,7 +24,7 @@ build() {
cd "${_pkgname}"
qmake
- make ${MAKEFLAGS}
+ make
}
package() {
@@ -32,9 +32,11 @@ package() {
make INSTALL_ROOT="${pkgdir}" install
- for res in 16 32 64 128 256 512
- do
- install -Dm664 "assets/icon${res}.png" "${pkgdir}/usr/share/icons/hicolor/${res}x${res}/apps/vibrantLinux.png"
+ for res in 16 32 64 128 256 512; do
+ convert "${srcdir}/vibrantlinux/assets/icon.png" -resize "${res}x${res}" "${srcdir}/vibrantlinux/assets/icon-${res}.png"
+ install -Dm644 "${srcdir}/vibrantlinux/assets/icon-${res}.png" "${pkgdir}/usr/share/icons/hicolor/${res}x${res}/apps/vibrantLinux.png"
done
- install -Dm644 "${srcdir}/vibrantLinux.desktop" "${pkgdir}/usr/share/applications/vibrantLinux.desktop"
+
+ rm "${pkgdir}/usr/share/icons/icon.png"
+ mv "${pkgdir}/usr/share/applications/application.desktop" "${pkgdir}/usr/share/applications/vibrantLinux.desktop"
}