summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartino Pilia2023-10-14 10:20:08 +0200
committerMartino Pilia2023-10-14 10:20:08 +0200
commite883ee64bf582738362f3921a91950560eb9f205 (patch)
tree9d9bdff2c74bf2c9064b7f4e950f3ca42ec9b3e7
parent088cf03c4008b19af79c526a968338776395ceb7 (diff)
downloadaur-e883ee64bf582738362f3921a91950560eb9f205.tar.gz
Disable pip config
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD11
2 files changed, 8 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9982c74b8bef..e3b120bc2e3a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = simpleitk
pkgdesc = A simplified layer built on top of ITK
pkgver = 2.3.0
- pkgrel = 2
+ pkgrel = 3
url = http://www.simpleitk.org/
arch = x86_64
license = Apache
diff --git a/PKGBUILD b/PKGBUILD
index 7df29a71f538..d540661e1f59 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,4 @@
-# Maintainer of this PKGBUILD file: Martino Pilia <martino.pilia@gmail.com>
+# Maintainer: Martino Pilia <martino.pilia@gmail.com>
# Contributor: Yen Chi Hsuan <yan12125 at gmail.com>
# shellcheck disable=SC2010
_pkgname=SimpleITK
@@ -14,14 +14,17 @@ pkgname=(
'tcl-simpleitk'
)
pkgver=2.3.0
-pkgrel=2
+pkgrel=3
pkgdesc="A simplified layer built on top of ITK"
arch=('x86_64')
url="http://www.simpleitk.org/"
license=('Apache')
provides=()
conflicts=()
-depends=('gcc-libs' 'insight-toolkit')
+depends=(
+ 'gcc-libs'
+ 'insight-toolkit'
+)
makedepends=(
'cmake'
'eigen'
@@ -90,7 +93,7 @@ build() {
make all
- LD_LIBRARY_PATH="${srcdir}/${_pkgname}/build/lib" make PythonVirtualEnv dist
+ PIP_CONFIG_FILE=/dev/null LD_LIBRARY_PATH="${srcdir}/${_pkgname}/build/lib" make PythonVirtualEnv dist
}
package_simpleitk() {