summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristoph Fink2018-10-29 10:54:44 +0200
committerChristoph Fink2018-10-29 10:54:44 +0200
commite8888978222401309f50e55c27be8b36820dc1b2 (patch)
treeb078b117768965c0b37def2be4bb51e2c0706c39
downloadaur-e8888978222401309f50e55c27be8b36820dc1b2.tar.gz
v0.1.0
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD26
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2fd6e6e151b8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = fasttext
+ pkgdesc = Library for fast text representation and classification
+ pkgver = 0.1.0
+ pkgrel = 0
+ url = https://github.com/facebookresearch/fastText
+ arch = any
+ license = BSD
+ makedepends = python-setuptools
+ makedepends = python2-setuptools
+ depends = python-numpy
+ depends = python-scipy
+ source = https://github.com/facebookresearch/fastText/archive/v0.1.0.tar.gz
+ sha256sums = d6b4932b18d2c8b3d50905028671aadcd212b7aa31cbc6dd6cac66db2eff1397
+
+pkgname = fasttext
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fec543c07f7f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: peippo <christoph.fink@gmail.com>
+
+pkgname='fasttext'
+pkgdesc="Library for fast text representation and classification"
+url="https://github.com/facebookresearch/fastText"
+
+pkgver=0.1.0
+pkgrel=0
+
+arch=('any')
+license=('BSD')
+
+makedepends=('python-setuptools' 'python2-setuptools')
+depends=('python-numpy' 'python-scipy')
+
+source=("https://github.com/facebookresearch/fastText/archive/v${pkgver}.tar.gz")
+sha256sums=('d6b4932b18d2c8b3d50905028671aadcd212b7aa31cbc6dd6cac66db2eff1397')
+
+build() {
+ cd "${srcdir}/fastText-${pkgver}"
+ make
+}
+
+package() {
+ install -Dm0755 "${srcdir}/fastText-${pkgver}/fasttext" "${pkgdir}/usr/bin/fasttext"
+}