summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhoton892018-03-12 19:42:20 +0100
committerPhoton892018-03-12 19:42:20 +0100
commite888ff4e900cbbfd5dd3c357d90e291f8da7aa19 (patch)
tree05c6a7ae86cb5d63d18c269a23982d4c65668d31
parentef5c075357864558521c32256d53ae074c9d6432 (diff)
downloadaur-e888ff4e900cbbfd5dd3c357d90e291f8da7aa19.tar.gz
Update to 1.3.1
-rw-r--r--.SRCINFO32
-rw-r--r--PKGBUILD32
-rw-r--r--boost.patch11
-rw-r--r--python27.patch11
4 files changed, 41 insertions, 45 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9f157309bdcb..3df44b3e6f98 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,28 +1,22 @@
pkgbase = jngl
pkgdesc = One of the easiest 2D game libraries for C++ and Python
- pkgver = 0.9.2
- pkgrel = 3
- url = http://jngl.watteimdocht.de/
+ pkgver = 1.3.1
+ pkgrel = 1
+ url = https://bixense.com/jngl/
arch = i686
arch = x86_64
- license = GPL3
- makedepends = scons
- makedepends = git
- depends = boost
- depends = freetype2
+ license = ZLIB
+ makedepends = meson
+ makedepends = ninja
+ depends = sdl2
depends = fontconfig
- depends = glib2
- depends = libjpeg6
- depends = libpng12
- depends = libvorbis
- depends = libxext
- depends = libxxf86vm
- depends = mesa
+ depends = glew
+ depends = libwebp
depends = openal
- depends = python2
- source = python27.patch
- md5sums = 58ec66f99186c5e491a4657559f203d1
- sha1sums = 61c55403238c7c7d95de87bb720230f47fd75a62
+ depends = libvorbis
+ depends = boost
+ source = https://github.com/jhasse/jngl/archive/v1.3.1.tar.gz
+ md5sums = 9dcbcde797ae92b61c7fd0fdaf044e47
pkgname = jngl
diff --git a/PKGBUILD b/PKGBUILD
index f4ab000fd429..a1417aabad92 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,25 @@
# Maintainer: Michael Kogan <michael dot kogan at gmx dot net>
pkgname=jngl
-pkgver=0.9.2
-pkgrel=3
+pkgver=1.3.1
+pkgrel=1
pkgdesc="One of the easiest 2D game libraries for C++ and Python"
arch=('i686' 'x86_64')
-url="http://jngl.watteimdocht.de/"
-license=('GPL3')
-depends=('boost' 'freetype2' 'fontconfig' 'glib2' 'libjpeg6' 'libpng12' 'libvorbis' 'libxext' 'libxxf86vm' 'mesa' 'openal' 'python2')
-makedepends=('scons' 'git')
-source=('python27.patch')
-md5sums=('58ec66f99186c5e491a4657559f203d1')
-sha1sums=('61c55403238c7c7d95de87bb720230f47fd75a62')
+url="https://bixense.com/jngl/"
+license=('ZLIB')
+depends=('sdl2' 'fontconfig' 'glew' 'libwebp' 'openal' 'libvorbis' 'boost')
+
+makedepends=('meson' 'ninja')
+source=("https://github.com/jhasse/jngl/archive/v$pkgver.tar.gz")
+md5sums=('9dcbcde797ae92b61c7fd0fdaf044e47')
build() {
- git clone https://github.com/jhasse/JNGL.git
- patch $srcdir/JNGL/SConstruct < python27.patch
- cd $srcdir/JNGL
- scons python=1|| return 1
- ./install.sh $pkgdir/usr || return 1
- install -D -m644 "$srcdir/JNGL/python/libjngl.so" "${pkgdir}/usr/lib/python2.7/site-packages/jngl.so" || return 1
+ cd $srcdir/jngl-$pkgver
+ mkdir build
+ cd build
+ meson .. --prefix=${pkgdir}/usr
+}
+package() {
+ cd $srcdir/jngl-$pkgver/build
+ ninja install
}
diff --git a/boost.patch b/boost.patch
new file mode 100644
index 000000000000..140e2dc0c3c9
--- /dev/null
+++ b/boost.patch
@@ -0,0 +1,11 @@
+--- SConstruct_old 2017-04-11 15:55:16.649483915 +0200
++++ SConstruct 2017-04-11 15:55:58.427721847 +0200
+@@ -107,7 +107,7 @@
+ env = env.Clone()
+ env.ParseConfig("pkg-config --cflags --libs jngl.pc python3")
+ env.Append(LIBPATH = ["src", "./python"])
+- if conf.CheckLib(["boost_python3"]):
++ if conf.CheckLib(["boost_python3"]) or True:
+ env.Append(LIBS=["boost_python3"])
+ else:
+ import re
diff --git a/python27.patch b/python27.patch
deleted file mode 100644
index 347058f545d4..000000000000
--- a/python27.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- SConstruct_old 2011-05-16 20:49:44.192374630 +0200
-+++ SConstruct 2011-05-16 20:48:34.254626319 +0200
-@@ -110,7 +110,7 @@
- env.ParseConfig("pkg-config --cflags --libs jngl.pc")
- env.Append(CPPPATH="/usr/include/python2.7",
- LIBPATH=Split(". ./lib ./python"),
-- LIBS=Split("python2.7 boost_python-py27"))
-+ LIBS=Split("python2.7 boost_python"))
- env.SharedLibrary(target="python/jngl.so",
- source="python/main.cpp")
-