summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorrazer2017-03-17 16:18:30 +0100
committerrazer2017-03-17 16:18:30 +0100
commite8bb1ae39e10a4c71d24b2bae5ada64b6edd8200 (patch)
treed8e5d41856443772b31e17d9a963f8024b8edeb4
downloadaur-e8bb1ae39e10a4c71d24b2bae5ada64b6edd8200.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD23
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a42e8138a7b9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = python-pyserial-asyncio
+ pkgdesc = Asyncio extension package for pyserial
+ pkgver = 0.3
+ pkgrel = 1
+ url = https://github.com/pyserial/pyserial-asyncio
+ arch = i686
+ arch = x86_64
+ arch = armv6h
+ arch = armv7h
+ arch = armv8h
+ license = BSD
+ depends = python-pyserial
+ source = https://pypi.python.org/packages/66/74/83c3ea7d6d8779bde526e0049eb8ff7e77d4233808b878db21ede27ee8f3/pyserial-asyncio-0.3.tar.gz
+ md5sums = b190b42a4849674cccbf5aefa58db545
+
+pkgname = python-pyserial-asyncio
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d0be7e0234c8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Razer <razer@neuf.fr>
+
+pkgname=python-pyserial-asyncio
+pkgver=0.3
+pkgrel=1
+pkgdesc="Asyncio extension package for pyserial "
+arch=('i686' 'x86_64' 'armv6h' 'armv7h' 'armv8h')
+url="https://github.com/pyserial/pyserial-asyncio"
+license=('BSD')
+depends=('python-pyserial')
+source=('https://pypi.python.org/packages/66/74/83c3ea7d6d8779bde526e0049eb8ff7e77d4233808b878db21ede27ee8f3/pyserial-asyncio-0.3.tar.gz')
+md5sums=('b190b42a4849674cccbf5aefa58db545')
+
+build() {
+ cd "$srcdir/pyserial-asyncio-$pkgver"
+ python setup.py build
+}
+
+package() {
+ cd "$srcdir/pyserial-asyncio-$pkgver"
+ python setup.py install --root="$pkgdir/" --optimize=1
+}
+