summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGrey Christoforo2018-03-04 12:57:25 +0000
committerGrey Christoforo2018-03-04 12:57:25 +0000
commite8e847db4db03710e4da69e93464045a1ad913ee (patch)
tree5d3ca086b690eb1b116d13a45a976cb66acb4514
downloadaur-e8e847db4db03710e4da69e93464045a1ad913ee.tar.gz
initial commit
-rw-r--r--.SRCINFO39
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD46
3 files changed, 91 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..035379874256
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,39 @@
+pkgbase = python-h5py-git
+ pkgdesc = General-purpose Python bindings for the HDF5 library -- latest commit, with mpi
+ pkgver = r968.3d1edda
+ pkgrel = 1
+ url = http://www.h5py.org/
+ arch = x86_64
+ license = BSD
+ makedepends = hdf5-openmpi
+ makedepends = cython
+ makedepends = cython2
+ makedepends = python-numpy
+ makedepends = python2-numpy
+ makedepends = python-six
+ makedepends = python2-six
+ makedepends = python-pkgconfig
+ makedepends = python2-pkgconfig
+ makedepends = python-mpi4py
+ makedepends = python2-mpi4py
+ provides = python-h5py
+ provides = python2-h5py
+ source = h5py::git+https://github.com/h5py/h5py.git#branch=master
+ md5sums = SKIP
+
+pkgname = python-h5py-git
+ depends = hdf5-openmpi
+ depends = cython
+ depends = python-numpy
+ depends = python-six
+ depends = python-pkgconfig
+ depends = python-mpi4py
+
+pkgname = python2-h5py-git
+ depends = hdf5-openmpi
+ depends = cython2
+ depends = python2-numpy
+ depends = python2-six
+ depends = python2-pkgconfig
+ depends = python2-mpi4py
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..ff1b5e74e79f
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+pkg/
+src/
+*.tgz
+*.tar.gz
+*.tar.xz
+h5py/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0efe172798ea
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# $Id$
+# Maintainer: Grey Christoforo <first name at last name dot net>
+
+_pkg=h5py
+pkgbase=python-${_pkg}-git
+pkgname=(python-${_pkg}-git python2-${_pkg}-git)
+pkgver=r968.3d1edda
+pkgrel=1
+pkgdesc="General-purpose Python bindings for the HDF5 library -- latest commit, with mpi"
+url="http://www.h5py.org/"
+arch=('x86_64')
+license=('BSD')
+makedepends=("hdf5-openmpi" 'cython' 'cython2' 'python-numpy' 'python2-numpy' 'python-six' 'python2-six'
+ 'python-pkgconfig' 'python2-pkgconfig' 'python-mpi4py' 'python2-mpi4py')
+provides=(python-${_pkg} python2-${_pkg})
+conflics=${provides}
+
+source=("${_pkg}"'::git+https://github.com/h5py/h5py.git#branch=master')
+md5sums=('SKIP')
+
+pkgver() {
+ cd "${_pkg}"
+ printf "r%s.%s" "$(git rev-list HEAD --count --first-parent)" "$(git rev-parse --short HEAD)"
+}
+
+package_python2-h5py-git() {
+ depends=('hdf5-openmpi' 'cython2' 'python2-numpy' 'python2-six' 'python2-pkgconfig' 'python2-mpi4py')
+ cd "${_pkg}"
+ python2 setup.py configure --mpi
+ python2 setup.py install --root="${pkgdir}" --optimize 1
+ #install -d644 "${pkgdir}/usr/share/licenses/${pkgname}"
+ #install -Dm644 "./licenses/*" "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -D licenses/license.txt "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+}
+
+
+package_python-h5py-git() {
+ depends=('hdf5-openmpi' 'cython' 'python-numpy' 'python-six' 'python-pkgconfig' 'python-mpi4py')
+ cd "${_pkg}"
+ python2 setup.py configure --mpi
+ python setup.py install --root="${pkgdir}" --optimize 1
+ #install -d644 "${pkgdir}/usr/share/licenses/${pkgname}"
+ #install -Dm644 "./licenses/*" "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -D licenses/license.txt "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+}
+