summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Martinez2021-09-04 12:54:07 -0500
committerLuis Martinez2021-09-05 00:30:49 -0500
commite8fe9f88d712e61f0d3e9fb9ea095ee2998d8292 (patch)
treef40d6bbb62949b6a6c0dc2b9cbbf968ef0bb18aa
downloadaur-e8fe9f88d712e61f0d3e9fb9ea095ee2998d8292.tar.gz
initial commit
-rw-r--r--.SRCINFO21
-rw-r--r--CHANGELOG74
-rw-r--r--PKGBUILD44
-rw-r--r--dkms.conf7
4 files changed, 146 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f151380a341b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = spy
+ pkgdesc = Linux kernel mode debugfs keylogger
+ pkgver = 1.8
+ pkgrel = 1
+ url = https://github.com/jarun/spy
+ changelog = CHANGELOG
+ arch = x86_64
+ license = GPL
+ makedepends = linux-headers
+ source = spy-1.8.tar.gz::https://github.com/jarun/spy/archive/v1.8.tar.gz
+ source = dkms.conf
+ sha256sums = d9c31d3df9a1b7974327796b505d77d04045a72a5d40a52ba24a065fdeb9c11a
+ sha256sums = e38cea0298e505875e2f9049ae7bbdfbff0e897f4e1f767bdf3f7a5675c77a75
+
+pkgname = spy
+
+pkgname = spy-dkms
+ pkgdesc = Linux kernel mode debugfs keylogger -- DKMS version
+ depends = dkms
+ provides = spy
+ conflicts = spy
diff --git a/CHANGELOG b/CHANGELOG
new file mode 100644
index 000000000000..034a51ebb354
--- /dev/null
+++ b/CHANGELOG
@@ -0,0 +1,74 @@
+keysniffer v1.8
+2020-10-12
+
+- project renamed
+- maintenance release
+
+-------------------------------------------------------------------------------
+
+keysniffer v1.7
+2018-03-06
+
+What's in?
+- Completely commented code for kernel newbies
+- Defensive (and redundant) code removal
+
+-------------------------------------------------------------------------------
+
+keysniffer v1.6
+2017-12-12
+
+What's in?
+- DKMS support
+- Prepend Left (`L`) or Right (`R`) for Ctrl, Shift and Alt keys
+- Replace `_ENTER_` with `\n`
+- Append newline to keycodes (for param codes=1/2)
+- Add targets install, load, unload, uninstall to Makefile
+
+-------------------------------------------------------------------------------
+
+keysniffer v1.5
+2017-03-28
+
+Modifications
+- Add module param `codes` to support hex and decimal keycodes in output
+
+-------------------------------------------------------------------------------
+
+keysniffer v1.4
+2016-10-03
+
+Modifications
+- Coding style and readability improvements
+
+-------------------------------------------------------------------------------
+
+keysniffer v1.2
+2015-10-30
+
+Modifications
+- Added version information to module
+- Better module description
+- Changed the source file name to project name
+- Fixed license issues, make GPL v2 (thanks @gregkh)
+- Added output example to README.txt
+
+-------------------------------------------------------------------------------
+
+keysniffer v1.1
+2015-10-12
+
+Modifications
+- Using a 16KB buffer to log keys in debugfs
+- Using stricter permissions for debugfs log file (readable only by root)
+
+-------------------------------------------------------------------------------
+
+keysniffer v1.0
+2015-10-11
+
+Modifications
+- Implement US keyboard grab support
+- Share the keypress log via debugfs
+
+-------------------------------------------------------------------------------
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..94b051748b6c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: Luis Martinez <luis dot martinez at disroot dot org>
+
+pkgname=('spy' 'spy-dkms')
+pkgbase=spy
+pkgver=1.8
+pkgrel=1
+pkgdesc="Linux kernel mode debugfs keylogger"
+arch=('x86_64')
+url="https://github.com/jarun/spy"
+license=('GPL')
+makedepends=('linux-headers')
+changelog=CHANGELOG
+source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz"
+ 'dkms.conf')
+sha256sums=('d9c31d3df9a1b7974327796b505d77d04045a72a5d40a52ba24a065fdeb9c11a'
+ 'e38cea0298e505875e2f9049ae7bbdfbff0e897f4e1f767bdf3f7a5675c77a75')
+
+prepare() {
+ sed -e "s/@PKGBASE@/$pkgbase/" -e "s/@PKGVER@/$pkgver/" -i dkms.conf
+}
+
+build() {
+ cd "$pkgbase-$pkgver"
+ make
+}
+
+package_spy() {
+ local _kver="$(uname -r)"
+ local _modname=kisni
+
+ cd "$pkgbase-$pkgver"
+ install -Dm755 "$_modname.ko" -t "$pkgdir/usr/lib/modules/$_kver/misc/$_modname/"
+}
+
+package_spy-dkms() {
+ # options and directives overrides
+ pkgdesc+=' -- DKMS version'
+ depends=('dkms')
+ provides=('spy')
+ conflicts=('spy')
+
+ cd "$pkgbase-$pkgver"
+ install -Dm 644 -t "$pkgdir/usr/src/$pkgbase-$pkgver" Makefile spy.c "$srcdir/dkms.conf"
+}
diff --git a/dkms.conf b/dkms.conf
new file mode 100644
index 000000000000..b63efdae9604
--- /dev/null
+++ b/dkms.conf
@@ -0,0 +1,7 @@
+PACKAGE_NAME="@PKGBASE@"
+PACKAGE_VERSION="@PKGVER@"
+MAKE[0]="make KVERSION=$kernelver"
+CLEAN="make clean"
+BUILT_MODULE_NAME[0]="kisni"
+DEST_MODULE_LOCATION[0]="/kernel/drivers/misc"
+AUTOINSTALL="yes"