summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJames An2016-04-29 22:40:20 -0400
committerJames An2016-04-29 22:40:20 -0400
commite9401f63bf584c0e6ae808257579727384f5ce2a (patch)
treece182a8bf870662e9a77d2b614852a94fae4780c
parent21c674ce7174cfb8bec7e1e70e650f6ecc844eca (diff)
downloadaur-e9401f63bf584c0e6ae808257579727384f5ce2a.tar.gz
Added compatibility patch to enable functionality with ruby 2.3.x.
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD14
-rw-r--r--ruby-2.3.x.patch13
3 files changed, 27 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e8fcc130c39e..8fcb6dbae7da 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ruby-tuple
pkgdesc = Tuple serialization functions.
pkgver = 0.1.2
- pkgrel = 1
+ pkgrel = 2
url = http://github.com/topac/tuple
arch = i686
arch = x86_64
@@ -9,7 +9,9 @@ pkgbase = ruby-tuple
depends = ruby
options = !emptydirs
source = tuple::git+https://github.com/topac/tuple.git
+ source = ruby-2.3.x.patch
md5sums = SKIP
+ md5sums = 02ccd33d02bedc16612ef5be9aec4c44
pkgname = ruby-tuple
diff --git a/PKGBUILD b/PKGBUILD
index 37c60d8bafa4..60c89d510c81 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,15 +4,23 @@
_pkgname=tuple
pkgname=ruby-$_pkgname
pkgver=0.1.2
-pkgrel=1
+pkgrel=2
pkgdesc='Tuple serialization functions.'
arch=(i686 x86_64)
url="http://github.com/topac/$_pkgname"
license=(MIT)
depends=(ruby)
options=(!emptydirs)
-source=("$_pkgname"::"git+https://github.com/topac/$_pkgname.git")
-md5sums=('SKIP')
+source=("$_pkgname"::"git+https://github.com/topac/$_pkgname.git"
+ ruby-2.3.x.patch)
+md5sums=('SKIP'
+ '02ccd33d02bedc16612ef5be9aec4c44')
+
+prepare() {
+ cd "$_pkgname"
+
+ patch -p1 -i ../ruby-2.3.x.patch
+}
build () {
cd $_pkgname
diff --git a/ruby-2.3.x.patch b/ruby-2.3.x.patch
new file mode 100644
index 000000000000..fde38dbc40bb
--- /dev/null
+++ b/ruby-2.3.x.patch
@@ -0,0 +1,13 @@
+diff --git a/ext/tuple/extconf.rb b/ext/tuple/extconf.rb
+index ce4e688..3b2b1ac 100644
+--- a/ext/tuple/extconf.rb
++++ b/ext/tuple/extconf.rb
+@@ -8,7 +8,7 @@ when /\A1\.9/
+ when /\A2\.(0|1)/
+ $CFLAGS += ' -DRUBY_2_x_x'
+ $CFLAGS += ' -DRUBY_2_1_x'
+-when /\A2\.2/
++when /\A2\.2/, /\A2\.3/
+ $CFLAGS += ' -DRUBY_2_x_x'
+ $CFLAGS += ' -DRUBY_2_2_x'
+ else