summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorElaina Martineau2019-03-10 01:59:51 -0700
committerElaina Martineau2019-03-10 01:59:51 -0700
commite95130c8d14cb551fd5274f5a89478a5a46e3ce4 (patch)
tree15772746bc684892157d72907bcd3e0e74d97d1b
parente271bcdb86f26fe5540361fc9bd951c96418741c (diff)
downloadaur-e95130c8d14cb551fd5274f5a89478a5a46e3ce4.tar.gz
Patch like in higan package
-rw-r--r--.SRCINFO4
-rwxr-xr-xPKGBUILD4
-rw-r--r--package.patch39
3 files changed, 21 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0c7ba9235128..e4c08e94aaef 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = bsnes
pkgdesc = Super Nintendo emulator focusing on performance, features, and ease of use.
pkgver = 107
- pkgrel = 3
+ pkgrel = 4
url = https://byuu.org/emulation/bsnes/
arch = x86_64
license = GPL3
@@ -16,7 +16,7 @@ pkgbase = bsnes
source = https://download.byuu.org/bsnes_v107-source.7z
source = package.patch
sha256sums = 7b7fa745ce593f9912ce116bdf009cd2e70eb034cd7186264c4abedb87a5da36
- sha256sums = 7fd8edb835667363a77cb9b2f58f5e5d2c87c32b249afe3edb26d5ae2eecbbd6
+ sha256sums = b578fba0dd5be5a93b0272704a60fa81c0bb524f9b9894b058c1223927d934d0
pkgname = bsnes
diff --git a/PKGBUILD b/PKGBUILD
index 91546f63fcf5..54df35ba5a45 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=bsnes
pkgver=107
-pkgrel=3
+pkgrel=4
pkgdesc='Super Nintendo emulator focusing on performance, features, and ease of use.'
arch=('x86_64')
url='https://byuu.org/emulation/bsnes/'
@@ -10,7 +10,7 @@ license=('GPL3')
depends=('libpulse' 'gtksourceview2' 'libxv' 'libao' 'openal' 'sdl2')
conflicts=('bsnes-classic' 'bsnes-plus')
source=("https://download.byuu.org/""$pkgname""_v""$pkgver""-source.7z" 'package.patch')
-sha256sums=('7b7fa745ce593f9912ce116bdf009cd2e70eb034cd7186264c4abedb87a5da36' '7fd8edb835667363a77cb9b2f58f5e5d2c87c32b249afe3edb26d5ae2eecbbd6')
+sha256sums=('7b7fa745ce593f9912ce116bdf009cd2e70eb034cd7186264c4abedb87a5da36' 'b578fba0dd5be5a93b0272704a60fa81c0bb524f9b9894b058c1223927d934d0')
prepare() {
cd "$pkgname""_v""$pkgver""-source"
diff --git a/package.patch b/package.patch
index dc9260184cde..234d8925bae3 100644
--- a/package.patch
+++ b/package.patch
@@ -1,26 +1,21 @@
-diff --unified --recursive --text package.orig/higan/GNUmakefile package.new/higan/GNUmakefile
---- package.orig/higan/GNUmakefile 2018-12-21 12:10:31.000000000 -0700
-+++ package.new/higan/GNUmakefile 2019-03-09 23:28:46.600329596 -0700
-@@ -23,7 +23,6 @@
- endif
- else ifneq ($(filter $(platform),linux bsd),)
- ifeq ($(binary),application)
-- flags += -march=native
- link += -Wl,-export-dynamic
- link += -lX11 -lXext
- else ifeq ($(binary),library)
-diff --unified --recursive --text package.orig/higan/target-bsnes/GNUmakefile package.new/higan/target-bsnes/GNUmakefile
---- package.orig/higan/target-bsnes/GNUmakefile 2018-12-20 03:55:21.000000000 -0700
-+++ package.new/higan/target-bsnes/GNUmakefile 2019-03-09 23:07:11.462473491 -0700
-@@ -21,7 +21,7 @@
+diff --unified --recursive bsnes_v107-source.orig/higan/GNUmakefile bsnes_v107-source.new/higan/GNUmakefile
+--- bsnes_v107-source.orig/higan/GNUmakefile 2019-03-10 01:42:30.163599022 -0700
++++ bsnes_v107-source.new/higan/GNUmakefile 2019-03-10 01:45:20.179375447 -0700
+@@ -1,6 +1,9 @@
++flags = $(CFLAGS)
++options = $(LDFLAGS)
++
+ target := bsnes
+ binary := application
+-build := performance
++build := release
+ openmp := true
+ flags += -I. -I..
- all: $(hiro.objects) $(ruby.objects) $(objects)
- $(info Linking out/$(name) ...)
-- +@$(compiler) -o out/$(name) $(hiro.objects) $(ruby.objects) $(objects) $(hiro.options) $(ruby.options) $(options)
-+ +@$(compiler) -o out/$(name) $(hiro.objects) $(ruby.objects) $(objects) $(hiro.options) $(ruby.options) $(options) $(LDFLAGS)
- ifeq ($(platform),macos)
- rm -rf out/$(name).app
- mkdir -p out/$(name).app/Contents/MacOS/
+
+diff --unified --recursive bsnes_v107-source.orig/higan/target-bsnes/GNUmakefile bsnes_v107-source.new/higan/target-bsnes/GNUmakefile
+--- bsnes_v107-source.orig/higan/target-bsnes/GNUmakefile 2019-03-10 01:51:07.601683406 -0700
++++ bsnes_v107-source.new/higan/target-bsnes/GNUmakefile 2019-03-10 01:52:00.013706440 -0700
@@ -34,9 +34,7 @@
verbose: hiro.verbose ruby.verbose nall.verbose all;