summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Parrish2016-09-25 22:31:15 -0400
committerDavid Parrish2016-09-25 22:39:40 -0400
commite95f803b4c94f9cf03cafa890083faae402811c7 (patch)
treef5546695988e0f6b6cfcf2b58efa227b5e530b6a
downloadaur-e95f803b4c94f9cf03cafa890083faae402811c7.tar.gz
Initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD32
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8f7cfe4c7431
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by mksrcinfo v8
+# Mon Sep 26 02:39:27 UTC 2016
+pkgbase = check_pacman-git
+ pkgdesc = Nagios monitoring plugin for checking for available Pacman package updates
+ pkgver = 1.1.0.r0.g5f20592
+ pkgrel = 1
+ url = https://github.com/dmp1ce/check_pacman
+ arch = i686
+ arch = x86_64
+ license = custom:Unlicense
+ makedepends = git
+ makedepends = stack
+ options = strip
+ source = git+https://github.com/dmp1ce/check_pacman.git
+ sha256sums = SKIP
+
+pkgname = check_pacman-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2ec84e94c774
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: David Parrish <daveparrish@tutanota.com>
+
+pkgname=check_pacman-git
+pkgver=1.1.0.r0.g5f20592
+pkgrel=1
+pkgdesc="Nagios monitoring plugin for checking for available Pacman package updates"
+arch=('i686' 'x86_64')
+makedepends=('git' 'stack')
+url="https://github.com/dmp1ce/check_pacman"
+license=('custom:Unlicense')
+options=('strip')
+source=(git+https://github.com/dmp1ce/check_pacman.git)
+sha256sums=('SKIP')
+
+pkgver() {
+ cd ${pkgname%-git}
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+package() {
+ cd ${pkgname%-git}
+
+ msg2 'Installing license...'
+ install -Dm 644 LICENSE -t "$pkgdir/usr/share/licenses/check_pacman"
+
+ msg2 'Installing...'
+ mkdir -p "$pkgdir/usr/bin"
+ stack --local-bin-path "$pkgdir/usr/bin" install
+
+ msg2 'Cleaning up pkgdir...'
+ find "$pkgdir" -type f -name .gitignore -exec rm -r '{}' +
+}