summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfrealgagu2018-11-08 16:14:18 -0500
committerfrealgagu2018-11-08 16:14:18 -0500
commite97a97cbd96fd1d9015b9c5eafe67fd2074054c5 (patch)
tree5eba9dea0aeb835bd2cea4396a5e8ad719cf8253
parent14115e061982c04df410b58648ed8f19f929d187 (diff)
downloadaur-e97a97cbd96fd1d9015b9c5eafe67fd2074054c5.tar.gz
Compiling in chroot.
-rw-r--r--.SRCINFO3
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD20
3 files changed, 11 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 97042ff46fe9..638c74f331e4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -5,12 +5,11 @@ pkgbase = welle.io
url = https://www.welle.io
arch = x86_64
license = GPL2
- makedepends = gcc
makedepends = cmake
+ makedepends = gcc
depends = faad2
depends = fftw
depends = qt5-charts
- depends = qt5-declarative
depends = qt5-quickcontrols
depends = qt5-quickcontrols2
depends = qt5-multimedia
diff --git a/.gitignore b/.gitignore
index cd44cc0a3206..ef2b67d442d9 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,4 +1,6 @@
welle.io-*.pkg.tar.xz
welle.io-*.tar.gz
+welle.io-*.log
+PKGBUILD-namcap.log
pkg/
src/
diff --git a/PKGBUILD b/PKGBUILD
index 74bc66c12ff6..32c487d7942d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,31 +7,27 @@ pkgdesc="An open source DAB and DAB+ software defined radio (SDR) with support f
arch=("x86_64")
url="https://www.${pkgname}"
license=("GPL2")
-depends=("faad2" "fftw" "qt5-charts" "qt5-declarative" "qt5-quickcontrols" "qt5-quickcontrols2" "qt5-multimedia" "rtl-sdr")
+depends=("faad2" "fftw" "qt5-charts" "qt5-quickcontrols" "qt5-quickcontrols2" "qt5-multimedia" "rtl-sdr")
optdepends=("airspy")
-makedepends=("gcc" "cmake")
+makedepends=("cmake" "gcc")
source=("${pkgname}-${pkgver}.tar.gz::https://github.com/AlbrechtL/${pkgname}/archive/V${pkgver}.tar.gz")
sha256sums=("669ae5d471f723c32622cbf6ee37b66c3aefd8e02d6334b55d1fb60b3c22a883")
build() {
- mkdir -p "${pkgname}-${pkgver}/build"
- cd "${pkgname}-${pkgver}/build"
+ mkdir -p "${srcdir}/${pkgname}-${pkgver}/build"
+ cd "${srcdir}/${pkgname}-${pkgver}/build"
cmake .. -DRTLSDR=1
make
}
package() {
- msg2 "Installing desktop file into /usr/share/applications/"
install -D -m 0644 "${srcdir}/${pkgname}-${pkgver}/${pkgname/./-}.desktop" "${pkgdir}/usr/share/applications/${pkgname/./-}.desktop"
-
- msg2 "Installing icon into /usr/share/pixmaps/"
+
install -D -m 0644 "${srcdir}/${pkgname}-${pkgver}/icon.png" "${pkgdir}/usr/share/pixmaps/${pkgname/./-}.png"
-
- msg2 "Installing application"
- cd "${pkgname}-${pkgver}/build"
+
+ cd "${srcdir}/${pkgname}-${pkgver}/build"
make DESTDIR=${pkgdir} install
-
- msg2 "Moving from /usr/local/bin to /usr/bin to match Arch packaging standards"
+
mv "${pkgdir}/usr/local/"* "${pkgdir}/usr/"
rm -r "${pkgdir}/usr/local"
}