summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGrey Christoforo2021-11-13 13:35:18 +0100
committerGrey Christoforo2021-11-13 13:35:18 +0100
commite988161ea324e1a1e1e9cdb0ec989cfe7219a020 (patch)
tree741fdd256c7204ec6d9aafc908d31f8fb583acf5
parent967841e5a822397b40315b00fe37549016777517 (diff)
downloadaur-e988161ea324e1a1e1e9cdb0ec989cfe7219a020.tar.gz
bump version
-rw-r--r--.SRCINFO7
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD9
3 files changed, 12 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 45465a3392d6..be9466581f72 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = r-s4vectors
pkgdesc = Foundation of vector-like and list-like containers in Bioconductor
- pkgver = 0.32.0
+ pkgver = 0.32.2
pkgrel = 1
url = https://bioconductor.org/packages/release/bioc/html/S4Vectors.html
arch = i686
@@ -16,7 +16,8 @@ pkgbase = r-s4vectors
optdepends = r-data.table
optdepends = r-runit
optdepends = r-biocstyle
- source = https://bioconductor.org/packages/release/bioc/src/contrib/S4Vectors_0.32.0.tar.gz
- sha256sums = 09b00dd57bd291f4018163ea1f0fe65e8d87ce15320e1990eac9059c31eda1fe
+ noextract = r-s4vectors-0.32.2.tar.gz
+ source = r-s4vectors-0.32.2.tar.gz::https://bioconductor.org/packages/release/bioc/src/contrib/S4Vectors_0.32.2.tar.gz
+ sha256sums = 404cef938b087ce70ace47e495004e73ddffe8a492f3d8e4b5d373db448c3577
pkgname = r-s4vectors
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..27fd112126d4
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+src/
+pkg/
+*.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
index 400b7315592a..1fe6f3b47d7b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Grey Christoforo <first name at last name dot net>
_bcname=S4Vectors
-_bcver=0.32.0
+_bcver=0.32.2
pkgname=r-${_bcname,,}
pkgver=${_bcver//[:-]/.}
pkgrel=1
@@ -12,13 +12,14 @@ url="https://bioconductor.org/packages/release/bioc/html/${_bcname}.html"
license=(Artistic-2.0)
depends=('r>=4.0.0' 'r-biocgenerics>=0.37.0')
optdepends=(r-iranges r-genomicranges r-summarizedexperiment r-delayedarray r-shortread r-data.table r-runit r-biocstyle)
-source=("https://bioconductor.org/packages/release/bioc/src/contrib/${_bcname}_${_bcver}.tar.gz")
-sha256sums=('09b00dd57bd291f4018163ea1f0fe65e8d87ce15320e1990eac9059c31eda1fe')
+source=("${pkgname}-${pkgver}.tar.gz::https://bioconductor.org/packages/release/bioc/src/contrib/${_bcname}_${_bcver}.tar.gz")
+noextract=(${pkgname}-${pkgver}.tar.gz)
+sha256sums=('404cef938b087ce70ace47e495004e73ddffe8a492f3d8e4b5d373db448c3577')
build() {
cd "${srcdir}"
- R CMD INSTALL ${_bcname}_${_bcver}.tar.gz -l ${srcdir}
+ R CMD INSTALL ${pkgname}-${pkgver}.tar.gz -l ${srcdir}
}
package() {