summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMario Finelli2015-07-06 20:35:33 -0400
committerMario Finelli2015-07-06 20:35:33 -0400
commite98b63161fcbe5e9b826d0e57dc5e0693fbd887d (patch)
tree4f973c52afbdcce25322be378a081e814c8ace00
downloadaur-e98b63161fcbe5e9b826d0e57dc5e0693fbd887d.tar.gz
Initial import
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD23
3 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9bcf54290f2c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = ruby-oauth
+ pkgdesc = OAuth Core Ruby implementation.
+ pkgver = 0.4.7
+ pkgrel = 3
+ url = https://rubygems.org/gems/oauth
+ arch = any
+ license = MIT
+ makedepends = rubygems
+ depends = ruby
+ noextract = oauth-0.4.7.gem
+ source = https://rubygems.org/downloads/oauth-0.4.7.gem
+ sha256sums = bca47d77c946af466872269e37e470837858b1305d5143e5a56c50356e02b2cc
+
+pkgname = ruby-oauth
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f71c635dafda
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!PKGBUILD
+!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4820133ab677
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Mario Finelli <mario dot finelli at yahoo dot com>
+# Contributor: eagletmt <eagletmt at gmail dot com>
+
+_gemname=oauth
+pkgname=ruby-$_gemname
+pkgver=0.4.7
+pkgrel=3
+pkgdesc='OAuth Core Ruby implementation.'
+arch=("any")
+url='https://rubygems.org/gems/oauth'
+license=('MIT')
+depends=('ruby')
+makedepends=('rubygems')
+source=(https://rubygems.org/downloads/$_gemname-$pkgver.gem)
+noextract=($_gemname-$pkgver.gem)
+sha256sums=('bca47d77c946af466872269e37e470837858b1305d5143e5a56c50356e02b2cc')
+
+package() {
+ cd "$srcdir"
+ local _gemdir="$(ruby -rubygems -e'puts Gem.default_dir')"
+
+ gem install --no-user-install --ignore-dependencies -i "$pkgdir$_gemdir" -n "$pkgdir/usr/bin" "$_gemname-$pkgver.gem"
+}