summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Schubert2023-11-01 22:00:36 +0100
committerMichael Schubert2023-11-01 22:00:36 +0100
commite9d372a82d6d5667658292f9809333c0618c998f (patch)
treec422d902fab5a220255ac77efa5578514133ef75
parentd251d23c07d4948a284ce7c6776b8116c064248b (diff)
downloadaur-e9d372a82d6d5667658292f9809333c0618c998f.tar.gz
include gnome45 PR
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD17
2 files changed, 18 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f8d8a2750d75..7f84662db154 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,19 @@
pkgbase = gnome-shell-extension-impatience-git
pkgdesc = speed up gnome-shell animations
- pkgver = 0.4.8.r2.g3123c74
- pkgrel = 1
+ pkgver = 0.4.8.r4.g0f961b8
+ pkgrel = 2
url = https://github.com/timbertson/gnome-shell-impatience
install = gschemas.install
arch = any
license = GPL3
makedepends = git
- depends = gnome-shell>=1:40
+ depends = gnome-shell>=1:45
+ depends = gnome-shell<1:46
provides = gnome-shell-extension-impatience
conflicts = gnome-shell-extension-impatience
source = git+https://github.com/timbertson/gnome-shell-impatience
+ source = https://patch-diff.githubusercontent.com/raw/timbertson/gnome-shell-impatience/pull/33.diff
sha256sums = SKIP
+ sha256sums = f604a5df06d1b215aa26858d268c1618accf70c05dc703296ab067502db6a7d7
pkgname = gnome-shell-extension-impatience-git
diff --git a/PKGBUILD b/PKGBUILD
index e602f848bbdb..35f41cbcd20c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,32 @@
# Maintainer: Michael Schubert <mschu.dev at gmail> github.com/mschubert/PKGBUILDs
pkgname=gnome-shell-extension-impatience-git
_pkgname=gnome-shell-impatience
-pkgver=0.4.8.r2.g3123c74
-pkgrel=1
+pkgver=0.4.8.r4.g0f961b8
+pkgrel=2
pkgdesc="speed up gnome-shell animations"
arch=('any')
url="https://github.com/timbertson/gnome-shell-impatience"
license=('GPL3')
-depends=('gnome-shell>=1:40')
+depends=('gnome-shell>=1:45' 'gnome-shell<1:46')
makedepends=('git')
conflicts=('gnome-shell-extension-impatience')
provides=('gnome-shell-extension-impatience')
install=gschemas.install
-source=(git+$url)
-sha256sums=('SKIP')
+source=(git+$url
+ https://patch-diff.githubusercontent.com/raw/timbertson/gnome-shell-impatience/pull/33.diff)
+sha256sums=('SKIP'
+ 'f604a5df06d1b215aa26858d268c1618accf70c05dc703296ab067502db6a7d7')
pkgver() {
cd "$srcdir/$_pkgname"
git describe --long --tags | sed -r 's/version-//;s/([^-]*-g)/r\1/;s/-/./g'
}
+prepare() {
+ cd "$srcdir/$_pkgname"
+ patch --forward --strip=1 --input="$srcdir"/33.diff
+}
+
package() {
cd "$srcdir/$_pkgname/impatience"