summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSteve Engledow2018-08-14 12:59:55 +0100
committerSteve Engledow2018-08-14 12:59:55 +0100
commite9e4722d2419db3527dbb1d056749832d8e8b8d0 (patch)
tree55d6b3e9182a8d7666f6b23f6b837d8abbc8ee4b
downloadaur-e9e4722d2419db3527dbb1d056749832d8e8b8d0.tar.gz
Initial working version
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD73
-rw-r--r--heroes-0.21.patch12
3 files changed, 108 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..28978575aac0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = heroes
+ pkgdesc = Heroes is similar to the Tron and Nibbles games of yore, but includes many graphical improvements and new game features.
+ pkgver = 0.21
+ pkgrel = 1
+ url = http://heroes.sourceforge.net
+ arch = x86_64
+ license = GPL
+ makedepends = autogen
+ source = http://prdownloads.sourceforge.net/heroes/heroes-0.21.tar.gz
+ source = http://prdownloads.sourceforge.net/heroes/heroes-data-1.5.tar.gz
+ source = http://prdownloads.sourceforge.net/heroes/heroes-sound-tracks-1.0.tar.gz
+ source = http://prdownloads.sourceforge.net/heroes/heroes-sound-effects-1.0.tar.gz
+ source = http://prdownloads.sourceforge.net/heroes/heroes-hq-sound-tracks-1.0.tar.gz
+ source = heroes-0.21.patch
+ md5sums = 3238290f219bc978894ba472fac95298
+ md5sums = 1a53e23b007f526a76df8bef97a41550
+ md5sums = bcde6137a4b21b7395fd3d84b42b7888
+ md5sums = f4defb80baf765fceac034a408f7ad2e
+ md5sums = dafb2ccfb08c132265262231d5655102
+ md5sums = 1181f3340ae8275aca8c92698fd7c13e
+
+pkgname = heroes
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..36d519887749
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,73 @@
+# Maintainer: Steve Engledow <steve@offend.me.uk>
+pkgname=heroes
+pkgver=0.21
+pkgrel=1
+pkgdesc="Heroes is similar to the Tron and Nibbles games of yore, but includes many graphical improvements and new game features."
+url="http://heroes.sourceforge.net"
+arch=(x86_64)
+license=('GPL')
+depends=()
+makedepends=(
+ autogen)
+source=("http://prdownloads.sourceforge.net/heroes/$pkgname-$pkgver.tar.gz"
+ "http://prdownloads.sourceforge.net/heroes/$pkgname-data-1.5.tar.gz"
+ "http://prdownloads.sourceforge.net/heroes/$pkgname-sound-tracks-1.0.tar.gz"
+ "http://prdownloads.sourceforge.net/heroes/$pkgname-sound-effects-1.0.tar.gz"
+ "http://prdownloads.sourceforge.net/heroes/$pkgname-hq-sound-tracks-1.0.tar.gz"
+ "heroes-0.21.patch")
+md5sums=('3238290f219bc978894ba472fac95298'
+ '1a53e23b007f526a76df8bef97a41550'
+ 'bcde6137a4b21b7395fd3d84b42b7888'
+ 'f4defb80baf765fceac034a408f7ad2e'
+ 'dafb2ccfb08c132265262231d5655102'
+ '1181f3340ae8275aca8c92698fd7c13e')
+
+build() {
+ cd "$pkgname-$pkgver"
+ patch -p0 <../heroes-0.21.patch
+ LDFLAGS=-lm ./configure --prefix=/usr
+ make
+ cd ..
+
+ cd "$pkgname-data-1.5"
+ ./configure --prefix=/usr
+ make
+ cd ..
+
+ cd "$pkgname-sound-tracks-1.0"
+ ./configure --prefix=/usr
+ make
+ cd ..
+
+ cd "$pkgname-sound-effects-1.0"
+ ./configure --prefix=/usr
+ make
+ cd ..
+
+ cd "$pkgname-hq-sound-tracks-1.0"
+ ./configure --prefix=/usr
+ make
+ cd ..
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ make DESTDIR="$pkgdir/" install
+ cd ..
+
+ cd "$pkgname-data-1.5"
+ make DESTDIR="$pkgdir/" install
+ cd ..
+
+ cd "$pkgname-sound-tracks-1.0"
+ make DESTDIR="$pkgdir/" install
+ cd ..
+
+ cd "$pkgname-sound-effects-1.0"
+ make DESTDIR="$pkgdir/" install
+ cd ..
+
+ cd "$pkgname-hq-sound-tracks-1.0"
+ make DESTDIR="$pkgdir/" install
+ cd ..
+}
diff --git a/heroes-0.21.patch b/heroes-0.21.patch
new file mode 100644
index 000000000000..7db6e310be87
--- /dev/null
+++ b/heroes-0.21.patch
@@ -0,0 +1,12 @@
+diff '--color=auto' -ruN ../heroes-0.21/src/hedlite.c ./src/hedlite.c
+--- ../heroes-0.21/src/hedlite.c 2002-02-06 21:49:44.000000000 +0000
++++ ./src/hedlite.c 2018-08-14 12:07:59.679814654 +0100
+@@ -45,7 +45,7 @@
+ #include "dirname.h"
+
+ static a_pcx_image heditrsc;
+-static a_pcx_image tile_set_img;
++//static a_pcx_image tile_set_img;
+
+ unsigned short int xdalles = 0;
+ unsigned short int ydalles = 0;