summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMin Xu2018-01-29 00:32:42 -0800
committerMin Xu2018-01-29 00:32:42 -0800
commite9ed881d70e42f3ec3d2689912c90318ca9d3337 (patch)
treeb4fd5e26c20f3a42c7c62087c7c6c0cae6f9377a
parent0f6adaa21d2b31f69831a196bc6d5e64a998cbd1 (diff)
downloadaur-e9ed881d70e42f3ec3d2689912c90318ca9d3337.tar.gz
updated to use the AMD staging branch
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD14
-rw-r--r--config.x86_6411
-rw-r--r--linux-hp-envy-x360-git.preset8
4 files changed, 18 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5aca5193054e..882d10dab249 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -13,7 +13,7 @@ pkgbase = linux-hp-envy-x360-git
makedepends = git
makedepends = libelf
options = !strip
- source = git+https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git
+ source = git+git://people.freedesktop.org/~agd5f/linux
source = config.x86_64
source = linux-hp-envy-x360-git.preset
source = https://raw.githubusercontent.com/graysky2/kernel_gcc_patch/master/enable_additional_cpu_optimizations_for_gcc_v4.9%2B_kernel_v4.13%2B.patch
diff --git a/PKGBUILD b/PKGBUILD
index aca4ada1c3a7..14df332b8e44 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,16 +6,16 @@
# Contributor: misc <tastky@gmail.com>
# Contributor: NextHendrix <cjones12 at sheffield.ac.uk>
-pkgbase=linux-ryzen-git
+pkgbase=linux-hp-envy-x360-git
_srcname=linux
-pkgver=4.15.r0.gd8a5b80568a9
+pkgver=4.15.staging
pkgrel=1
arch=('x86_64')
url="http://www.kernel.org/"
license=('GPL2')
makedepends=('xmlto' 'docbook-xsl' 'kmod' 'inetutils' 'bc' 'git' 'libelf')
options=('!strip')
-source=('git+https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git'
+source=('git+git://people.freedesktop.org/~agd5f/linux'
# the main kernel config files
'config.x86_64'
# standard config files for mkinitcpio ramdisk
@@ -25,7 +25,7 @@ source=('git+https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git'
)
sha256sums=('SKIP'
'SKIP'
- '6c4ab77d0be624799b9b8e12b228fe181577b298d73355b14618ebf1f5675fa7'
+ 'SKIP'
'8b00041911e67654b0bd9602125853a1a94f6155c5cac4f886507554c8324ee8'
)
@@ -34,11 +34,13 @@ _kernelname=${pkgbase#linux}
pkgver() {
cd "${_srcname}"
- git describe --long | sed -E 's/^v//;s/([^-]*-g)/r\1/;s/-/./g;s/\.rc/rc/'
+ #git describe --long | sed -E 's/^v//;s/([^-]*-g)/r\1/;s/-/./g;s/\.rc/rc/'
+ echo '4.15.staging'
}
prepare() {
cd "${_srcname}"
+ git reset --hard amd-staging-drm-next
patch -Np1 -i "${srcdir}/enable_additional_cpu_optimizations_for_gcc_v4.9%2B_kernel_v4.13%2B.patch"
@@ -56,10 +58,10 @@ prepare() {
# load configuration
# Configure the kernel. Replace the line below with one of your choice.
- #make menuconfig # CLI menu for configuration
#make nconfig # new CLI menu for configuration
#make xconfig # X-based configuration
make oldconfig # using old config from previous kernel version
+ #make menuconfig # CLI menu for configuration
#make olddefconfig # old config from previous kernel, defaults for new options
# ... or manually edit .config
}
diff --git a/config.x86_64 b/config.x86_64
index e26737e97a19..fa74f4e5a153 100644
--- a/config.x86_64
+++ b/config.x86_64
@@ -1,6 +1,6 @@
#
# Automatically generated file; DO NOT EDIT.
-# Linux/x86 4.15.0-rc8 Kernel Configuration
+# Linux/x86 4.15.0-rc4 Kernel Configuration
#
CONFIG_64BIT=y
CONFIG_X86_64=y
@@ -53,7 +53,7 @@ CONFIG_THREAD_INFO_IN_TASK=y
CONFIG_INIT_ENV_ARG_LIMIT=32
CONFIG_CROSS_COMPILE=""
# CONFIG_COMPILE_TEST is not set
-CONFIG_LOCALVERSION="-ge1915c8195b3"
+CONFIG_LOCALVERSION="-gd8a5b80568a9"
# CONFIG_LOCALVERSION_AUTO is not set
CONFIG_HAVE_KERNEL_GZIP=y
CONFIG_HAVE_KERNEL_BZIP2=y
@@ -237,7 +237,6 @@ CONFIG_KALLSYMS=y
CONFIG_KALLSYMS_ABSOLUTE_PERCPU=y
CONFIG_KALLSYMS_BASE_RELATIVE=y
CONFIG_BPF_SYSCALL=y
-CONFIG_BPF_JIT_ALWAYS_ON=y
CONFIG_USERFAULTFD=y
# CONFIG_EMBEDDED is not set
CONFIG_HAVE_PERF_EVENTS=y
@@ -456,7 +455,6 @@ CONFIG_X86_FAST_FEATURE_TESTS=y
CONFIG_X86_X2APIC=y
CONFIG_X86_MPPARSE=y
# CONFIG_GOLDFISH is not set
-# CONFIG_RETPOLINE is not set
# CONFIG_INTEL_RDT is not set
# CONFIG_X86_EXTENDED_PLATFORM is not set
CONFIG_X86_INTEL_LPSS=y
@@ -1868,7 +1866,6 @@ CONFIG_DEV_COREDUMP=y
CONFIG_SYS_HYPERVISOR=y
# CONFIG_GENERIC_CPU_DEVICES is not set
CONFIG_GENERIC_CPU_AUTOPROBE=y
-CONFIG_GENERIC_CPU_VULNERABILITIES=y
CONFIG_REGMAP=y
CONFIG_REGMAP_I2C=y
CONFIG_REGMAP_MMIO=y
@@ -5089,6 +5086,7 @@ CONFIG_VGA_ARB_MAX_GPUS=16
CONFIG_VGA_SWITCHEROO=y
CONFIG_DRM=m
CONFIG_DRM_MIPI_DSI=y
+CONFIG_DRM_PANEL_ORIENTATION_QUIRKS=y
CONFIG_DRM_DP_AUX_CHARDEV=y
# CONFIG_DRM_DEBUG_MM_SELFTEST is not set
CONFIG_DRM_KMS_HELPER=m
@@ -5098,6 +5096,7 @@ CONFIG_DRM_FBDEV_OVERALLOC=100
CONFIG_DRM_LOAD_EDID_FIRMWARE=y
CONFIG_DRM_TTM=m
CONFIG_DRM_VM=y
+CONFIG_DRM_SCHED=m
#
# I2C encoder or helper chips
@@ -5485,6 +5484,7 @@ CONFIG_SND_SOC_AC97_BUS=y
CONFIG_SND_SOC_GENERIC_DMAENGINE_PCM=y
CONFIG_SND_SOC_AMD_ACP=m
CONFIG_SND_SOC_AMD_CZ_RT5645_MACH=m
+CONFIG_SND_SOC_AMD_ACP3x=m
CONFIG_SND_ATMEL_SOC=m
CONFIG_SND_DESIGNWARE_I2S=m
CONFIG_SND_DESIGNWARE_PCM=y
@@ -7863,7 +7863,6 @@ CONFIG_SECURITY=y
# CONFIG_SECURITY_WRITABLE_HOOKS is not set
CONFIG_SECURITYFS=y
# CONFIG_SECURITY_NETWORK is not set
-CONFIG_PAGE_TABLE_ISOLATION=y
CONFIG_SECURITY_INFINIBAND=y
CONFIG_SECURITY_PATH=y
# CONFIG_INTEL_TXT is not set
diff --git a/linux-hp-envy-x360-git.preset b/linux-hp-envy-x360-git.preset
index 6b13fe96aa8b..ae37abde8f6e 100644
--- a/linux-hp-envy-x360-git.preset
+++ b/linux-hp-envy-x360-git.preset
@@ -1,14 +1,14 @@
-# mkinitcpio preset file for the 'linux-ryzen-git' package
+# mkinitcpio preset file for the 'linux-hp-envy-x360-git' package
ALL_config="/etc/mkinitcpio.conf"
-ALL_kver="/boot/vmlinuz-linux-ryzen-git"
+ALL_kver="/boot/vmlinuz-linux-hp-envy-x360-git"
PRESETS=('default' 'fallback')
#default_config="/etc/mkinitcpio.conf"
-default_image="/boot/initramfs-linux-ryzen-git.img"
+default_image="/boot/initramfs-linux-hp-envy-x360-git.img"
#default_options=""
#fallback_config="/etc/mkinitcpio.conf"
-fallback_image="/boot/initramfs-linux-ryzen-git-fallback.img"
+fallback_image="/boot/initramfs-linux-hp-envy-x360-git-fallback.img"
fallback_options="-S autodetect"