summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndy Kluger2020-11-09 22:21:06 -0500
committerAndy Kluger2020-11-09 22:21:06 -0500
commitea04239f10b689092cf63b8ffdde299c387aae09 (patch)
tree470ea46eeb412edf8f8c3c5b612d369a87bf6534
parentc14de4263a73038ba9f93c646189e9bd1473a9a7 (diff)
downloadaur-ea04239f10b689092cf63b8ffdde299c387aae09.tar.gz
version bump; explicit minimum nodejs; reformat to closely match templated pkgbuilds for custom build plans
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD23
2 files changed, 16 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1eae294205c1..5d6c048eb929 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,12 @@
pkgbase = ttf-iosevka-git
pkgdesc = A slender monospace sans-serif and slab-serif typeface inspired by Pragmata Pro, M+ and PF DIN Mono.
- pkgver = r2050.075dd6e4
+ pkgver = r2089.115f5b19
pkgrel = 1
url = https://be5invis.github.io/Iosevka/
arch = any
license = custom:OFL
makedepends = git
- makedepends = nodejs
+ makedepends = nodejs>=12.16.0
makedepends = npm
makedepends = ttfautohint
provides = ttf-iosevka
diff --git a/PKGBUILD b/PKGBUILD
index 4c78790cd370..33dc26942128 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,23 @@
-# Maintainer: Andy Kluger <AndyKluger@gmail.com>
+# Maintainer: Andy Kluger <https://t.me/andykluger>
# Contributor: Markus Weimar <mail@markusweimar.de>
-pkgname=ttf-iosevka-git
-pkgver=r2050.075dd6e4
+_pkgname=ttf-iosevka
+pkgname=${_pkgname}-git
+pkgver=r2089.115f5b19
pkgrel=1
pkgdesc='A slender monospace sans-serif and slab-serif typeface inspired by Pragmata Pro, M+ and PF DIN Mono.'
arch=('any')
url='https://be5invis.github.io/Iosevka/'
license=('custom:OFL')
-makedepends=('git' 'nodejs' 'npm' 'ttfautohint')
+makedepends=('git' 'nodejs>=12.16.0' 'npm' 'ttfautohint')
depends=()
-conflicts=('ttf-iosevka')
-provides=('ttf-iosevka')
-source=('git+https://github.com/be5invis/Iosevka')
-sha256sums=('SKIP')
+conflicts=(${_pkgname})
+provides=(${_pkgname})
+source=(
+ 'git+https://github.com/be5invis/Iosevka'
+)
+sha256sums=(
+ 'SKIP'
+)
pkgver() {
cd Iosevka
@@ -23,7 +28,7 @@ build() {
cd Iosevka
npm install
npm update
- npm run build -- ttf::iosevka
+ npm run build -- ttf::${_pkgname#*-}
}
package() {