summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorxiota2023-01-10 11:52:56 -0800
committerxiota2023-01-10 11:52:56 -0800
commitea1f299ec352b58b2453e0c47f3f8ef43b3304c3 (patch)
treeadcc70bcf71e1592b44e7e52ccd0589269b98cb6
parent31218abc6ebebb388a63584654b62926bc1b4148 (diff)
downloadaur-ea1f299ec352b58b2453e0c47f3f8ef43b3304c3.tar.gz
restore fftw
switch to another fork
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD20
-rw-r--r--makefile-ldflags.diff11
3 files changed, 10 insertions, 31 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e786ed167980..3b3692f4545d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,18 @@
pkgbase = lossywav-git
pkgdesc = lossy audio pre-processor
- pkgver = 1.4.2p.r1.r6.g8780b67
+ pkgver = 1.4.2p.r19.gdf1f75e
pkgrel = 1
- url = https://github.com/Sound-Linux-More/lossywav-for-linux
+ url = https://github.com/xiota/lossywav-for-posix
arch = i686
arch = x86_64
arch = armv6h
arch = armv7h
license = GPL
makedepends = git
- depends = gcc-libs
+ depends = fftw
provides = lossywav
conflicts = lossywav
- source = lossywav::git+https://github.com/Sound-Linux-More/lossywav-for-linux
- source = makefile-ldflags.diff
+ source = lossywav::git+https://github.com/xiota/lossywav-for-posix
md5sums = SKIP
- md5sums = 65713062cfd510acfcd06ce5ee4b503c
pkgname = lossywav-git
diff --git a/PKGBUILD b/PKGBUILD
index 363277c31fa9..46b1f2138d22 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,46 +1,38 @@
# Contributor: sekret, mail=$(echo c2VrcmV0QHBvc3Rlby5zZQo= | base64 -d)
_pkgname=lossywav
pkgname=$_pkgname-git
-pkgver=1.4.2p.r1.r6.g8780b67
+pkgver=1.4.2p.r19.gdf1f75e
pkgrel=1
pkgdesc="lossy audio pre-processor"
arch=('i686' 'x86_64' 'armv6h' 'armv7h')
_url_windows="https://sourceforge.net/projects/lossywav/"
_url_posix_old="https://github.com/MoSal/lossywav-for-posix"
-url="https://github.com/Sound-Linux-More/lossywav-for-linux"
+url="https://github.com/xiota/lossywav-for-posix"
license=('GPL')
-depends=(gcc-libs)
+depends=('fftw')
makedepends=('git')
provides=("$_pkgname")
conflicts=(${provides[@]})
source=(
"$_pkgname::git+$url"
- makefile-ldflags.diff
)
md5sums=(
'SKIP'
- '65713062cfd510acfcd06ce5ee4b503c'
)
pkgver() {
cd "$srcdir/$_pkgname"
- git describe --long | sed -r 's/([^-]*-g)/r\1/;s/-/./g'
-}
-
-prepare() {
- cd "$srcdir/$_pkgname"
- patch -Np1 -i "$srcdir/makefile-ldflags.diff"
+ git describe --tag --long | sed -r 's/([^-]*-g)/r\1/;s/-/./g'
}
build() {
cd "$srcdir/$_pkgname"
- make
+ make fftw-optimized
}
package() {
cd "$srcdir/$_pkgname"
- install -Dm0755 lossywav-static "$pkgdir/usr/bin/lossywav"
- install -Dm0644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname"
+ install -Dm0755 lossywav -t "$pkgdir/usr/bin"
}
# vim:set ts=2 sw=2 et:
diff --git a/makefile-ldflags.diff b/makefile-ldflags.diff
deleted file mode 100644
index d3596ad0f84e..000000000000
--- a/makefile-ldflags.diff
+++ /dev/null
@@ -1,11 +0,0 @@
---- old/Makefile
-+++ new/Makefile
-@@ -5,7 +5,7 @@
- COMMON_CXXFLAGS = -std=c++11 -O2 -pipe
- DEFINES = -DHAVE_STD_CHRONO_STEADY_CLOCK_NOW -DHAVE_SETPRIORITY -DHAVE_STAT -DHAVE_CHMOD -DHAVE_NANOSLEEP
- AR = ar
--LDFLAGS = -s
-+LDFLAGS += -s
-
- CXXFLAGS = ${COMMON_CXXFLAGS} ${DEFINES}
- ifneq ($(shell uname -m), i386)