summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKevin Del Castillo2021-06-07 10:39:20 -0500
committerKevin Del Castillo2021-06-07 10:39:20 -0500
commitea41558a80ecc50a7f7752037df917abc5a044c2 (patch)
tree2aee8538eb8579be54a7a608c51b6f8fcf1a7aac
parent65a4387d58c18172d3d03a6930ef08280cee7c0f (diff)
downloadaur-ea41558a80ecc50a7f7752037df917abc5a044c2.tar.gz
Add pkgver function
-rw-r--r--PKGBUILD5
1 files changed, 5 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 551e8fa6198d..c9129e58f28a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -21,6 +21,11 @@ source=("$_pkgname-$pkgver.tar.gz::https://github.com/neovim/neovim/releases/dow
sha512sums=(SKIP)
install=neovim.install
+pkgver() {
+ cd "${srcdir}/nvim-linux64"
+ ./bin/nvim --version | head -1 | awk '{ printf $2 }' | sed 's/-/+/g'
+}
+
check() {
cd "${srcdir}/nvim-linux64"
./bin/nvim --version