summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonathan Liu2016-09-01 16:36:12 +1000
committerJonathan Liu2016-09-01 16:36:12 +1000
commitea5f944adc79202d40e6a6af9e7eec8c102f9e42 (patch)
treea8e0dc41748501265ddbc5e088df79b2f374b967
parent62696243fb5a947452ae2d020cc36ecc5b5c3a76 (diff)
downloadaur-ea5f944adc79202d40e6a6af9e7eec8c102f9e42.tar.gz
Fix compiling with GCC 6
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD8
-rw-r--r--sharetray.cpp.patch22
-rw-r--r--sharetray.cpp.patch210
4 files changed, 31 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c69d6377ec15..2b763407b209 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,9 @@
+# Generated by mksrcinfo v8
+# Thu Sep 1 06:34:50 UTC 2016
pkgbase = x2godesktopsharing
pkgdesc = x2godesktopsharing is an X2Go add-on tool that allows a user to grant other X2go users access to the current session (shadow session support).
pkgver = 3.1.1.2
- pkgrel = 2
+ pkgrel = 3
url = http://www.x2go.org/
install = x2godesktopsharing.install
arch = i686
@@ -12,9 +14,9 @@ pkgbase = x2godesktopsharing
depends = x2goserver>=4.0.1
depends = qt4>=4.5
options = !strip
- source = sharetray.cpp.patch2
+ source = sharetray.cpp.patch
source = http://code.x2go.org/releases/source/x2godesktopsharing/x2godesktopsharing-3.1.1.2.tar.gz
- md5sums = 83c1d72798534d60a2fcc2d21713cd83
+ md5sums = 2efa3a30be77489dbc22188584a93690
md5sums = bd48394f5a4eaa55559622f21a5e0a79
pkgname = x2godesktopsharing
diff --git a/PKGBUILD b/PKGBUILD
index 40ab22146cbb..da58882a9e2a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=x2godesktopsharing
pkgver=3.1.1.2
-pkgrel=2
+pkgrel=3
pkgdesc="x2godesktopsharing is an X2Go add-on tool that allows a user to grant other X2go users access to the current session (shadow session support)."
arch=('i686' 'x86_64')
url="http://www.x2go.org/"
@@ -13,15 +13,15 @@ options=(emptydirs)
install=$pkgname.install
groups=('x2go' 'alts')
options=(!strip)
-source=('sharetray.cpp.patch2'
+source=('sharetray.cpp.patch'
"http://code.x2go.org/releases/source/${pkgname}/${pkgname}-${pkgver}.tar.gz")
-md5sums=('83c1d72798534d60a2fcc2d21713cd83'
+md5sums=('2efa3a30be77489dbc22188584a93690'
'bd48394f5a4eaa55559622f21a5e0a79')
build() {
cd "${srcdir}/${pkgname}-${pkgver}"
# echo "CONFIG = qt x11 dll debug" >> x2godesktopsharing.pro
- patch -p0 < ../sharetray.cpp.patch2
+ patch -Np1 -i "${srcdir}/sharetray.cpp.patch"
qmake-qt4 x2godesktopsharing.pro
# cp ../Makefiledbg Makefile
make
diff --git a/sharetray.cpp.patch b/sharetray.cpp.patch
new file mode 100644
index 000000000000..b85f2bdf4b13
--- /dev/null
+++ b/sharetray.cpp.patch
@@ -0,0 +1,22 @@
+diff -Nur x2godesktopsharing-3.1.1.2.orig/sharetray.cpp x2godesktopsharing-3.1.1.2/sharetray.cpp
+--- x2godesktopsharing-3.1.1.2.orig/sharetray.cpp 2015-03-06 15:11:16.000000000 +1100
++++ x2godesktopsharing-3.1.1.2/sharetray.cpp 2016-09-01 16:32:39.112356875 +1000
+@@ -93,8 +93,8 @@
+ {
+ QString line = in.readLine();
+ file.close();
+- if ( abs ( line.toUInt() -
+- QDateTime::currentDateTime().toTime_t() ) <5 )
++ if ( abs ( int(line.toUInt() -
++ QDateTime::currentDateTime().toTime_t()) ) <5 )
+ {
+
+ QString message=QString (
+@@ -174,6 +174,7 @@
+ SLOT ( slotStopSharing() ) );
+
+ actStop->setEnabled ( false );
++ slotStartSharing();
+
+ // unix signals (TERM, INT) are piped into a unix socket and will raise Qt events
+ if (::socketpair(AF_UNIX, SOCK_STREAM, 0, sigkeybintFd))
diff --git a/sharetray.cpp.patch2 b/sharetray.cpp.patch2
deleted file mode 100644
index ecc0b0c813e9..000000000000
--- a/sharetray.cpp.patch2
+++ /dev/null
@@ -1,10 +0,0 @@
---- sharetray.cpp 2012-02-19 20:18:22.055004155 +0100
-+++ sharetray.cpp_mod 2012-02-19 20:31:48.852666353 +0100
-@@ -171,6 +171,7 @@
-
-
- actStop->setEnabled ( false );
-+ slotStartSharing();
-
- // unix signals (TERM, INT) are piped into a unix socket and will raise Qt events
- if (::socketpair(AF_UNIX, SOCK_STREAM, 0, sigkeybintFd))