summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJulien Freyermuth2015-08-15 16:13:33 +0200
committerJulien Freyermuth2015-08-15 16:13:33 +0200
commiteac1f31bc019ec92c0b109708cbcbaea2670dbcc (patch)
tree72c6cc0f669c6b1a97b0ce81f0a31401ee2c90f8
parent8953ce117a598c62ecc94979f5edb35963ffc8f2 (diff)
downloadaur-eac1f31bc019ec92c0b109708cbcbaea2670dbcc.tar.gz
Adding some debug info and some change in pkgbuild
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD14
-rw-r--r--gonsupdate-0.0.1.tar.gzbin0 -> 2412 bytes
-rw-r--r--gonsupdate-0.1.tar.gzbin2025 -> 0 bytes
4 files changed, 15 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a27c12128f76..20059dce87a1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,16 @@
pkgbase = gonsupdate
pkgdesc = If necessary, update your ip for nsupdate
- pkgver = 0.1
- pkgrel = 1
+ pkgver = 0.0.1
+ pkgrel = 2
url = https://github.com/Chipsterjulien/gonsupdate
install = gonsupdate.install
arch = any
license = WTFPL
makedepends = go
options = !strip
- source = gonsupdate-0.1.tar.gz
- sha512sums = 1ed468fbcc41adb6510cb8f52b22104e3ea31139fb2c49d7e0b05456cc07b045de028e068193b44e254d6ad199102db1689e26cc9f757cf5ba0899b091dccccc
+ backup = etc/gonsupdate/gonsupdate.toml
+ source = gonsupdate-0.0.1.tar.gz
+ sha512sums = ec0afd88babe158add0fddf228c719f95e271e694b659ae0261c673a2da316806756e7d7c4e6a531a4a696c8190dd0f2e9f015ce175fee5330c8c2b7946fa00f
pkgname = gonsupdate
diff --git a/PKGBUILD b/PKGBUILD
index a2264815c67f..be5a017bceef 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,12 @@
# Maintainer: Chipster Julien <julien dot chipster @ archlinux dot fr>
pkgname=gonsupdate
url="https://github.com/Chipsterjulien/gonsupdate"
-pkgver=0.1
-pkgrel=1
+pkgver=0.0.1
+pkgrel=2
pkgdesc="If necessary, update your ip for nsupdate"
arch=('any')
license=('WTFPL')
+backup=('etc/gonsupdate/gonsupdate.toml')
makedepends=(go)
options=('!strip')
source=($pkgname-$pkgver.tar.gz)
@@ -32,13 +33,18 @@ build() {
cd "$_builddir"
go build || return 1
+
+ if [ $GOPATH_exist == 0 ]; then
+ rm -rf ~/.gopath
+ export GOPATH=
+ fi
}
package() {
cd "$_builddir"
# gonsupdate.toml
- install -Dm644 cfg/"$pkgname".toml \
+ install -Dm644 cfg/"$pkgname"_sample.toml \
"$pkgdir"/etc/$pkgname/gonsupdate_sample.toml || return 1
# Create log directory
@@ -58,4 +64,4 @@ package() {
"$pkgdir"/usr/bin/$pkgname || return 1
}
-sha512sums=('1ed468fbcc41adb6510cb8f52b22104e3ea31139fb2c49d7e0b05456cc07b045de028e068193b44e254d6ad199102db1689e26cc9f757cf5ba0899b091dccccc')
+sha512sums=('ec0afd88babe158add0fddf228c719f95e271e694b659ae0261c673a2da316806756e7d7c4e6a531a4a696c8190dd0f2e9f015ce175fee5330c8c2b7946fa00f')
diff --git a/gonsupdate-0.0.1.tar.gz b/gonsupdate-0.0.1.tar.gz
new file mode 100644
index 000000000000..6b46e5884d3f
--- /dev/null
+++ b/gonsupdate-0.0.1.tar.gz
Binary files differ
diff --git a/gonsupdate-0.1.tar.gz b/gonsupdate-0.1.tar.gz
deleted file mode 100644
index 769c445036f1..000000000000
--- a/gonsupdate-0.1.tar.gz
+++ /dev/null
Binary files differ