summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJustin Vreeland2020-03-14 04:45:05 +0000
committerJustin Vreeland2020-03-14 06:13:50 +0000
commiteacdcdfbc0729a757c58b724de76b632305886a6 (patch)
treef82b8bca34fed0cae8c3ad03b897127884d61b24
parentf1e08b5220266663eeb4d74be50d53e1fa593392 (diff)
downloadaur-eacdcdfbc0729a757c58b724de76b632305886a6.tar.gz
Udate to 3.3 and newer version of qt
-rw-r--r--.SRCINFO11
-rw-r--r--0001-Dont-install-thirdparty-libs.patch26
-rw-r--r--0003-Use-newer-qt-version.patch2
-rw-r--r--PKGBUILD20
4 files changed, 16 insertions, 43 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 113421f8e5f3..26f2b612cf1a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,23 +1,22 @@
pkgbase = sam-ba
pkgdesc = Atmel SAM Boot Assistant
- pkgver = 3.2.3
- pkgrel = 2
+ pkgver = 3.3
+ pkgrel = 1
url = https://github.com/atmelcorp/sam-ba
- arch = i686
arch = x86_64
license = GPL2
makedepends = qt5-tools
depends = qt5-base
depends = qt5-serialport
depends = qt5-declarative
- source = https://github.com/atmelcorp/sam-ba/archive/v3.2.3.tar.gz
+ source = https://github.com/atmelcorp/sam-ba/archive/v3.3.tar.gz
source = 0001-Dont-install-thirdparty-libs.patch
source = 0002-Dont-rely-on-applicationDirPath.patch
source = 0003-Use-newer-qt-version.patch
- md5sums = dc116aab099685b01653f00aa6a6ac00
+ md5sums = 480f70a38b783df1e599ccc7bf2090ef
md5sums = 6b29a65bbc96b608d7628e8a25ae1f50
md5sums = 1fd871ae02809fcbc3095c169f59ce01
- md5sums = d6cccea0c35eb4f5e0852e1ce0d816c6
+ md5sums = 93241311e7ce90508b0af8e91fb61559
pkgname = sam-ba
diff --git a/0001-Dont-install-thirdparty-libs.patch b/0001-Dont-install-thirdparty-libs.patch
index 93798952e0c6..e69de29bb2d1 100644
--- a/0001-Dont-install-thirdparty-libs.patch
+++ b/0001-Dont-install-thirdparty-libs.patch
@@ -1,26 +0,0 @@
-diff --git a/dist/dist.pro b/dist/dist.pro
-index da853b2..b7e4b32 100644
---- a/dist/dist.pro
-+++ b/dist/dist.pro
-@@ -33,18 +33,18 @@ unix:{
- $$[QT_INSTALL_LIBS]/libQt5Qml.so.5 \
- $$[QT_INSTALL_LIBS]/libQt5Quick.so.5 \
- $$[QT_INSTALL_LIBS]/libQt5SerialPort.so.5
-- INSTALLS += qtlibs
-+ #INSTALLS += qtlibs
-
- otherlibs.path = /lib
- otherlibs.files = \
- $$[QT_INSTALL_LIBS]/libicudata.so.$$ICU_VERSION \
- $$[QT_INSTALL_LIBS]/libicui18n.so.$$ICU_VERSION \
- $$[QT_INSTALL_LIBS]/libicuuc.so.$$ICU_VERSION
-- INSTALLS += otherlibs
-+ #INSTALLS += otherlibs
-
- qmlmodules.path = /qml
- qmlmodules.files = $$[QT_INSTALL_LIBS]/../qml/QtQuick.2
-- INSTALLS += qmlmodules
-+ #INSTALLS += qmlmodules
- }
- else:win32:{
- qtlibs.path = /
diff --git a/0003-Use-newer-qt-version.patch b/0003-Use-newer-qt-version.patch
index 4fe349ab640a..fd06f4c2400e 100644
--- a/0003-Use-newer-qt-version.patch
+++ b/0003-Use-newer-qt-version.patch
@@ -5,7 +5,7 @@
# map Qt version to ICU versions
equals(QT_MAJOR_VERSION, 5) {
- equals(QT_MINOR_VERSION, 9): ICU_VERSION = 56
-+ equals(QT_MINOR_VERSION, 12): ICU_VERSION = 56
++ equals(QT_MINOR_VERSION, 14): ICU_VERSION = 56
}
isEmpty(ICU_VERSION) {
error(Unknown QT version)
diff --git a/PKGBUILD b/PKGBUILD
index 60f04c70c6a6..bf0b5274d11c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,26 @@
# Maintainer: Justin Vreeland <vreeland.justin@gmail.com>
# Contributor: Streetwalrus <streetwalrus@codewalr.us>
pkgname=sam-ba
-pkgver=3.2.3
-pkgrel=2
+pkgver=3.3
+pkgrel=1
pkgdesc="Atmel SAM Boot Assistant"
-arch=('i686' 'x86_64')
+arch=('x86_64')
url="https://github.com/atmelcorp/sam-ba"
license=('GPL2')
depends=('qt5-base' 'qt5-serialport' 'qt5-declarative')
-makedepends=('qt5-tools')
-source=("https://github.com/atmelcorp/sam-ba/archive/v$pkgver.tar.gz"
+makedepends=('qt5-tools' 'clang')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/atmelcorp/sam-ba/archive/v$pkgver.tar.gz"
"0001-Dont-install-thirdparty-libs.patch"
"0002-Dont-rely-on-applicationDirPath.patch"
"0003-Use-newer-qt-version.patch"
)
-md5sums=('dc116aab099685b01653f00aa6a6ac00'
- '6b29a65bbc96b608d7628e8a25ae1f50'
+md5sums=('480f70a38b783df1e599ccc7bf2090ef'
+ 'd41d8cd98f00b204e9800998ecf8427e'
'1fd871ae02809fcbc3095c169f59ce01'
- 'd6cccea0c35eb4f5e0852e1ce0d816c6')
+ '93241311e7ce90508b0af8e91fb61559')
prepare() {
- cd "${srcdir}/sam-ba-$pkgver"
+ cd "${srcdir}/$pkgname-$pkgver"
patch -Np1 -i ../0001-Dont-install-thirdparty-libs.patch
patch -Np1 -i ../0002-Dont-rely-on-applicationDirPath.patch
@@ -35,7 +35,7 @@ build() {
cd build
qmake ../sam-ba.pro
- make -j1
+ make
}
package() {