summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNicola Murino2024-03-28 14:04:01 +0100
committerNicola Murino2024-03-28 14:04:01 +0100
commiteade704b8c89e21606cdbdc8cc604f71aece93f9 (patch)
treef55c9fc7094e2ed8594e6c22ad025c89538ceac9
parent3bd4e78718394d0c315d46471db1be7a7bd68272 (diff)
downloadaur-eade704b8c89e21606cdbdc8cc604f71aece93f9.tar.gz
1.24.1
-rw-r--r--.SRCINFO9
-rw-r--r--0001-fix-DirectXMath.h-include-path.patch132
-rw-r--r--PKGBUILD16
3 files changed, 150 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 24178300557a..b18793f6a8cb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,12 @@
pkgbase = mingw-w64-gst-plugins-bad
pkgdesc = GStreamer Multimedia Framework Bad Plugins (mingw-w64)
- pkgver = 1.22.10
+ pkgver = 1.24.1
pkgrel = 1
url = http://gstreamer.freedesktop.org/
arch = any
license = LGPL
makedepends = mingw-w64-meson
+ makedepends = mingw-w64-directxmath
makedepends = mingw-w64-openh264
makedepends = mingw-w64-nettle
makedepends = mingw-w64-opus
@@ -41,7 +42,9 @@ pkgbase = mingw-w64-gst-plugins-bad
options = !strip
options = !buildflags
options = staticlibs
- source = http://gstreamer.freedesktop.org/src/gst-plugins-bad/gst-plugins-bad-1.22.10.tar.xz
- sha256sums = dabcd60c762165bb043eba753d599212514c94684e4db9a2e25484cb6508ebbf
+ source = http://gstreamer.freedesktop.org/src/gst-plugins-bad/gst-plugins-bad-1.24.1.tar.xz
+ source = 0001-fix-DirectXMath.h-include-path.patch
+ sha256sums = f1a183966ea9136a00f159ee42db4d1d106abef022d1b49e63fba2fcbe50c8f8
+ sha256sums = 51f80198efeedd14424a2f2ea3d3395c0fec6c8c853017fd4fc459abd669f1ea
pkgname = mingw-w64-gst-plugins-bad
diff --git a/0001-fix-DirectXMath.h-include-path.patch b/0001-fix-DirectXMath.h-include-path.patch
new file mode 100644
index 000000000000..f05dfdc08f06
--- /dev/null
+++ b/0001-fix-DirectXMath.h-include-path.patch
@@ -0,0 +1,132 @@
+From 1408244202834f7cd7fd48fd271249555d14b17e Mon Sep 17 00:00:00 2001
+From: Nicola Murino <nicola.murino@gmail.com>
+Date: Thu, 28 Mar 2024 13:24:10 +0100
+Subject: [PATCH] fix DirectXMath.h include path
+
+---
+ gst-libs/gst/d3d11/gstd3d11converter.cpp | 2 +-
+ gst-libs/gst/d3d11/meson.build | 4 ++--
+ sys/d3d11/gstd3d11dxgicapture.cpp | 2 +-
+ sys/d3d11/gstd3d11pluginutils.cpp | 2 +-
+ sys/d3d12/gstd3d12converter.cpp | 2 +-
+ sys/d3d12/gstd3d12dxgicapture.cpp | 2 +-
+ sys/d3d12/gstd3d12pluginutils.cpp | 2 +-
+ sys/d3d12/meson.build | 2 +-
+ 8 files changed, 9 insertions(+), 9 deletions(-)
+
+diff --git a/gst-libs/gst/d3d11/gstd3d11converter.cpp b/gst-libs/gst/d3d11/gstd3d11converter.cpp
+index 813a0ff..65d1b34 100644
+--- a/gst-libs/gst/d3d11/gstd3d11converter.cpp
++++ b/gst-libs/gst/d3d11/gstd3d11converter.cpp
+@@ -43,7 +43,7 @@
+ #ifndef HAVE_DIRECTX_MATH_SIMD
+ #define _XM_NO_INTRINSICS_
+ #endif
+-#include <DirectXMath.h>
++#include <directxmath/DirectXMath.h>
+
+ /**
+ * SECTION:gstd3d11converter
+diff --git a/gst-libs/gst/d3d11/meson.build b/gst-libs/gst/d3d11/meson.build
+index 5abb136..2f129c7 100644
+--- a/gst-libs/gst/d3d11/meson.build
++++ b/gst-libs/gst/d3d11/meson.build
+@@ -183,7 +183,7 @@ endif
+
+ have_dx_math = cxx.compiles('''
+ #include <windows.h>
+- #include <DirectXMath.h>
++ #include <directxmath/DirectXMath.h>
+ using namespace DirectX;
+ int main(int argc, char ** argv) {
+ XMMATRIX matrix;
+@@ -207,7 +207,7 @@ endif
+ if host_machine.cpu_family() != 'x86'
+ have_dx_math_simd = cxx.compiles('''
+ #include <windows.h>
+- #include <DirectXMath.h>
++ #include <directxmath/DirectXMath.h>
+ using namespace DirectX;
+ int main(int argc, char ** argv) {
+ XMVerifyCPUSupport ();
+diff --git a/sys/d3d11/gstd3d11dxgicapture.cpp b/sys/d3d11/gstd3d11dxgicapture.cpp
+index aeb8d38..0403003 100644
+--- a/sys/d3d11/gstd3d11dxgicapture.cpp
++++ b/sys/d3d11/gstd3d11dxgicapture.cpp
+@@ -54,7 +54,7 @@
+ #include <wrl.h>
+
+ #define _XM_NO_INTRINSICS_
+-#include <DirectXMath.h>
++#include <directxmath/DirectXMath.h>
+
+ GST_DEBUG_CATEGORY_EXTERN (gst_d3d11_screen_capture_debug);
+ #define GST_CAT_DEFAULT gst_d3d11_screen_capture_debug
+diff --git a/sys/d3d11/gstd3d11pluginutils.cpp b/sys/d3d11/gstd3d11pluginutils.cpp
+index db64725..7770b93 100644
+--- a/sys/d3d11/gstd3d11pluginutils.cpp
++++ b/sys/d3d11/gstd3d11pluginutils.cpp
+@@ -32,7 +32,7 @@
+
+ /* Disable platform-specific intrinsics */
+ #define _XM_NO_INTRINSICS_
+-#include <DirectXMath.h>
++#include <directxmath/DirectXMath.h>
+
+ GST_DEBUG_CATEGORY_EXTERN (gst_d3d11_plugin_utils_debug);
+ #define GST_CAT_DEFAULT gst_d3d11_plugin_utils_debug
+diff --git a/sys/d3d12/gstd3d12converter.cpp b/sys/d3d12/gstd3d12converter.cpp
+index f89da10..0346599 100644
+--- a/sys/d3d12/gstd3d12converter.cpp
++++ b/sys/d3d12/gstd3d12converter.cpp
+@@ -35,7 +35,7 @@
+ #ifndef HAVE_DIRECTX_MATH_SIMD
+ #define _XM_NO_INTRINSICS_
+ #endif
+-#include <DirectXMath.h>
++#include <directxmath/DirectXMath.h>
+
+ GST_DEBUG_CATEGORY (gst_d3d12_converter_debug);
+ #define GST_CAT_DEFAULT gst_d3d12_converter_debug
+diff --git a/sys/d3d12/gstd3d12dxgicapture.cpp b/sys/d3d12/gstd3d12dxgicapture.cpp
+index 5f18305..b5608df 100644
+--- a/sys/d3d12/gstd3d12dxgicapture.cpp
++++ b/sys/d3d12/gstd3d12dxgicapture.cpp
+@@ -59,7 +59,7 @@
+ #include "VSMain_coord.h"
+
+ #define _XM_NO_INTRINSICS_
+-#include <DirectXMath.h>
++#include <directxmath/DirectXMath.h>
+
+ GST_DEBUG_CATEGORY_EXTERN (gst_d3d12_screen_capture_debug);
+ #define GST_CAT_DEFAULT gst_d3d12_screen_capture_debug
+diff --git a/sys/d3d12/gstd3d12pluginutils.cpp b/sys/d3d12/gstd3d12pluginutils.cpp
+index 41987af..3765546 100644
+--- a/sys/d3d12/gstd3d12pluginutils.cpp
++++ b/sys/d3d12/gstd3d12pluginutils.cpp
+@@ -24,7 +24,7 @@
+ #include "gstd3d12pluginutils.h"
+
+ #define _XM_NO_INTRINSICS_
+-#include <DirectXMath.h>
++#include <directxmath/DirectXMath.h>
+
+ /* *INDENT-OFF* */
+ using namespace DirectX;
+diff --git a/sys/d3d12/meson.build b/sys/d3d12/meson.build
+index 00db928..383a232 100644
+--- a/sys/d3d12/meson.build
++++ b/sys/d3d12/meson.build
+@@ -83,7 +83,7 @@ d3d12_headers = [
+ 'd3d11.h',
+ 'd3d11on12.h',
+ 'd2d1.h',
+- 'DirectXMath.h',
++ 'directxmath/DirectXMath.h',
+ ]
+
+ have_d3d12_headers = true
+--
+2.44.0
+
diff --git a/PKGBUILD b/PKGBUILD
index ddc95ef27bf5..9fc0e88ca7a6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,13 @@
# Maintainer: drakkan <nicola.murino at gmail dot com>
pkgname=mingw-w64-gst-plugins-bad
-pkgver=1.22.10
+pkgver=1.24.1
pkgrel=1
pkgdesc="GStreamer Multimedia Framework Bad Plugins (mingw-w64)"
arch=(any)
url="http://gstreamer.freedesktop.org/"
license=('LGPL')
depends=('mingw-w64-gst-plugins-base' 'mingw-w64-orc')
-makedepends=('mingw-w64-meson' 'mingw-w64-openh264' 'mingw-w64-nettle' 'mingw-w64-opus' 'mingw-w64-bzip2' 'mingw-w64-libsrtp' 'mingw-w64-vo-aacenc' 'mingw-w64-libkate' 'mingw-w64-librsvg' 'mingw-w64-openjpeg2' 'mingw-w64-opencv' 'mingw-w64-libfdk-aac' 'mingw-w64-librtmp0' 'mingw-w64-libwebp' 'mingw-w64-srt' 'mingw-w64-curl' 'mingw-w64-libnice')
+makedepends=('mingw-w64-meson' 'mingw-w64-directxmath' 'mingw-w64-openh264' 'mingw-w64-nettle' 'mingw-w64-opus' 'mingw-w64-bzip2' 'mingw-w64-libsrtp' 'mingw-w64-vo-aacenc' 'mingw-w64-libkate' 'mingw-w64-librsvg' 'mingw-w64-openjpeg2' 'mingw-w64-opencv' 'mingw-w64-libfdk-aac' 'mingw-w64-librtmp0' 'mingw-w64-libwebp' 'mingw-w64-srt' 'mingw-w64-curl' 'mingw-w64-libnice')
optdepends=(
"mingw-w64-openh264: H.264 video codec plugin"
"mingw-w64-opus: OPUS audio parser plugin"
@@ -26,11 +26,19 @@ optdepends=(
)
options=('!strip' '!buildflags' 'staticlibs')
-source=(${url}src/gst-plugins-bad/gst-plugins-bad-${pkgver}.tar.xz)
-sha256sums=('dabcd60c762165bb043eba753d599212514c94684e4db9a2e25484cb6508ebbf')
+source=(${url}src/gst-plugins-bad/gst-plugins-bad-${pkgver}.tar.xz
+ 0001-fix-DirectXMath.h-include-path.patch)
+sha256sums=('f1a183966ea9136a00f159ee42db4d1d106abef022d1b49e63fba2fcbe50c8f8'
+ '51f80198efeedd14424a2f2ea3d3395c0fec6c8c853017fd4fc459abd669f1ea')
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
+prepare() {
+ cd "${srcdir}/gst-plugins-bad-${pkgver}"
+ patch -Np1 -i "${srcdir}/0001-fix-DirectXMath.h-include-path.patch"
+}
+
+
build() {
cd "${srcdir}/gst-plugins-bad-${pkgver}"
sed -i "s|link_args : \[noseh_link_args, '-lopencv_tracking'\],|link_args : \[noseh_link_args\],|" ext/opencv/meson.build