summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authordaurnimator2020-11-27 01:07:34 +1100
committerdaurnimator2020-11-27 01:07:34 +1100
commiteaedc18f177298ecbc88b7fb4f5c01b7661af442 (patch)
tree9fae6a0a6520061a3008ac8a229f29d36e831fee
parentabaaf8e21b37607dbae07ef9a2cd41cef49ea7e0 (diff)
downloadaur-eaedc18f177298ecbc88b7fb4f5c01b7661af442.tar.gz
Split for Lua 5.4 release
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD13
2 files changed, 14 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 733af762c2af..3eda983160f8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -8,7 +8,7 @@ pkgbase = lua-binaryheap
md5sums = 8dc4ea3df17fc7c586693d6fb6f0a8a3
pkgname = lua-binaryheap
- pkgdesc = Binary heap implementation for Lua 5.3
+ pkgdesc = Binary heap implementation for Lua 5.4
pkgname = lua51-binaryheap
pkgdesc = Binary heap implementation for Lua 5.1
@@ -16,3 +16,6 @@ pkgname = lua51-binaryheap
pkgname = lua52-binaryheap
pkgdesc = Binary heap implementation for Lua 5.2
+pkgname = lua53-binaryheap
+ pkgdesc = Binary heap implementation for Lua 5.3
+
diff --git a/PKGBUILD b/PKGBUILD
index 3306767bb09e..364eb7933f16 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Daurnimator <quae@daurnimator.com>
-pkgname=('lua-binaryheap' 'lua51-binaryheap' 'lua52-binaryheap')
+pkgname=('lua-binaryheap' 'lua51-binaryheap' 'lua52-binaryheap' 'lua53-binaryheap')
pkgver=0.4
pkgrel=1
arch=('any')
@@ -10,10 +10,10 @@ source=("$pkgname-$pkgver.tar.gz::https://github.com/Tieske/binaryheap.lua/archi
md5sums=('8dc4ea3df17fc7c586693d6fb6f0a8a3')
package_lua-binaryheap() {
- pkgdesc='Binary heap implementation for Lua 5.3'
+ pkgdesc='Binary heap implementation for Lua 5.4'
cd "binaryheap.lua-version_0v4"
- install -Dm644 src/binaryheap.lua "$pkgdir/usr/share/lua/5.3/binaryheap.lua"
+ install -Dm644 src/binaryheap.lua "$pkgdir/usr/share/lua/5.4/binaryheap.lua"
}
package_lua51-binaryheap() {
@@ -29,3 +29,10 @@ package_lua52-binaryheap() {
cd "binaryheap.lua-version_0v4"
install -Dm644 src/binaryheap.lua "$pkgdir/usr/share/lua/5.2/binaryheap.lua"
}
+
+package_lua53-binaryheap() {
+ pkgdesc='Binary heap implementation for Lua 5.3'
+
+ cd "binaryheap.lua-version_0v4"
+ install -Dm644 src/binaryheap.lua "$pkgdir/usr/share/lua/5.3/binaryheap.lua"
+}