summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSimone Cimarelli2021-02-20 17:24:52 +0100
committerSimone Cimarelli2021-02-20 17:26:02 +0100
commiteb0085ead429dc2245a88135172ae7b2fa0259be (patch)
treee4e9e08399f89481bf363f5b0d91cbe7335af127
parenteb3d306164d7feccdaef5dbeb00f8ada7eee2d71 (diff)
downloadaur-eb0085ead429dc2245a88135172ae7b2fa0259be.tar.gz
Update to v0.4.0
-rw-r--r--.SRCINFO6
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD9
-rw-r--r--qrcode.patch12
4 files changed, 23 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9c9bd13b1beb..51efcb3baa1e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = drive-git
pkgdesc = Google Drive client for the command line (development version)
- pkgver = 0.3.9.1.r51.gb868c96
+ pkgver = 0.4.0.r4.gbede608
pkgrel = 1
url = https://github.com/odeke-em/drive
arch = i686
@@ -16,7 +16,9 @@ pkgbase = drive-git
provides = drive
conflicts = drive
source = drive::git+https://github.com/odeke-em/drive.git#branch=master
- md5sums = SKIP
+ source = qrcode.patch
+ sha256sums = SKIP
+ sha256sums = d984022881f618a572ea39f55d143f34c634015c5119dd2a7194353d0323734b
pkgname = drive-git
diff --git a/.gitignore b/.gitignore
index 05c6d4d4c97b..7334925ab911 100644
--- a/.gitignore
+++ b/.gitignore
@@ -2,3 +2,4 @@
!.gitignore
!.SRCINFO
!PKGBUILD
+!*.patch
diff --git a/PKGBUILD b/PKGBUILD
index 9d3aafe7616f..76a9c5aab1c9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,15 +2,17 @@
_basename=drive
pkgname=$_basename-git
-pkgver=0.3.9.1.r51.gb868c96
+pkgver=0.4.0.r4.gbede608
pkgrel=1
pkgdesc="Google Drive client for the command line (development version)"
arch=("i686" "pentium4" "x86_64" "arm" "armv6h" "armv7h" "aarch64")
url="https://github.com/odeke-em/$_basename"
license=("APACHE")
makedepends=("git" "go>=1.9")
-source=("$_basename::git+https://github.com/odeke-em/$_basename.git#branch=master")
-md5sums=("SKIP")
+source=("$_basename::git+https://github.com/odeke-em/$_basename.git#branch=master"
+ 'qrcode.patch')
+sha256sums=('SKIP'
+ 'd984022881f618a572ea39f55d143f34c634015c5119dd2a7194353d0323734b')
provides=("$_basename")
conflicts=("$_basename")
@@ -25,6 +27,7 @@ prepare() {
export GOPATH="$srcdir/go"
cd "go/src/github.com/odeke-em/$_basename"
go get -v -d ./...
+ patch -p1 -N -i "$srcdir/qrcode.patch" -d "$srcdir/$_basename"
}
build() {
diff --git a/qrcode.patch b/qrcode.patch
new file mode 100644
index 000000000000..535b6d37b1d9
--- /dev/null
+++ b/qrcode.patch
@@ -0,0 +1,12 @@
+diff -aur drive.orig/drive-server/main.go drive.new/drive-server/main.go
+--- drive.orig/drive-server/main.go 2021-02-20 17:10:39.616416192 +0100
++++ drive.new/drive-server/main.go 2021-02-20 17:13:34.942133037 +0100
+@@ -111,7 +111,7 @@
+ }
+
+ uri := pl.URI
+- pngImage, err := qrcode.Encode(uri, 256)
++ pngImage, err := qrcode.Encode(uri, qrcode.Medium, 256)
+ if err != nil {
+ fmt.Fprintf(res, "%s %v\n", uri, err)
+ return