summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohn-Michael Mulesa2021-09-09 15:34:02 +1000
committerJohn-Michael Mulesa2021-09-09 15:34:02 +1000
commiteb0a3284feac389ffed8a0bc1ce44131f97ae8ac (patch)
treebaae718f48f8390d625a05fc9b220b8369f0eb33
downloadaur-eb0a3284feac389ffed8a0bc1ce44131f97ae8ac.tar.gz
Initial commit.
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD46
-rw-r--r--ut3.desktop8
-rw-r--r--ut3.pngbin0 -> 72971 bytes
-rw-r--r--ut3.sh3
5 files changed, 75 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..740704cad414
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = ut3-wine-steam
+ pkgdesc = Unreal Tournament 3 Black using WINE with data via Steam
+ pkgver = 2.1
+ pkgrel = 1
+ url = https://store.steampowered.com/app/13210/Unreal_Tournament_3_Black/
+ arch = i686
+ arch = x86_64
+ license = custom
+ makedepends = steamcmd
+ depends = wine
+ source = ut3.desktop
+ source = ut3.sh
+ source = ut3.png
+ sha256sums = 7fa682a9a2c15facd1d1c6361754cddca1dd2c9913d0c90585ff694fa45d62d9
+ sha256sums = e6accb8e23cf06bdd4c70ac8ef095208423777da65b479177b43efe8e03cfb10
+ sha256sums = 1f9441dc8dbae60187883799125393c4333f22eb2eb33fea5bf4a6270bdaa055
+
+pkgname = ut3-wine-steam
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ccaf99ae58f4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# Maintainer: John-Michael Mulesa <jmulesa [at] gmail.com>
+
+pkgname=ut3-wine-steam
+_pkgname=ut3
+pkgver=2.1
+pkgrel=1
+arch=('i686' 'x86_64')
+makedepends=('steamcmd')
+depends=('wine')
+source=("${_pkgname}.desktop" "${_pkgname}.sh" "${_pkgname}.png")
+pkgdesc="Unreal Tournament 3 Black using WINE with data via Steam"
+license=('custom')
+url='https://store.steampowered.com/app/13210/Unreal_Tournament_3_Black/'
+sha256sums=('7fa682a9a2c15facd1d1c6361754cddca1dd2c9913d0c90585ff694fa45d62d9'
+ 'e6accb8e23cf06bdd4c70ac8ef095208423777da65b479177b43efe8e03cfb10'
+ '1f9441dc8dbae60187883799125393c4333f22eb2eb33fea5bf4a6270bdaa055')
+
+prepare() {
+ mkdir -p $srcdir/${_pkgname}
+
+ # Use steamcmd to get data.
+ printf "Enter your Steam username:"
+ read steam_username
+ steamcmd +@sSteamCmdForcePlatformType windows +@ShutdownOnFailedCommand 1 +force_install_dir $srcdir/${_pkgname} +login $steam_username "+app_update 13210 validate" +quit
+}
+
+package() {
+ mkdir -p $pkgdir/opt/${_pkgname}
+
+ # Move required files to pkgdir
+ cp -r $srcdir/${_pkgname}/* $pkgdir/opt/${_pkgname}/
+ rm -rf $pkgdir/opt/${_pkgname}/steamapps
+ rm $pkgdir/opt/${_pkgname}/installscript.vdf
+
+ # Install desktop file.
+ install -D -m 644 $srcdir/${_pkgname}.desktop \
+ $pkgdir/usr/share/applications/${_pkgname}.desktop
+
+ # Install icon file.
+ install -D -m 644 $srcdir/${_pkgname}.png \
+ $pkgdir/usr/share/pixmaps/${_pkgname}.png
+
+ # Install bash startup script.
+ install -D -m 755 $srcdir/${_pkgname}.sh \
+ $pkgdir/usr/bin/${_pkgname}
+}
diff --git a/ut3.desktop b/ut3.desktop
new file mode 100644
index 000000000000..6f7175e5b08f
--- /dev/null
+++ b/ut3.desktop
@@ -0,0 +1,8 @@
+[Desktop Entry]
+Name=Unreal Tournament 3
+Comment=Unreal Tournament 3 Black WINE
+Exec=/usr/bin/ut3
+Icon=ut3
+Terminal=false
+Type=Application
+Categories=Application;Game;
diff --git a/ut3.png b/ut3.png
new file mode 100644
index 000000000000..78263abfd5f9
--- /dev/null
+++ b/ut3.png
Binary files differ
diff --git a/ut3.sh b/ut3.sh
new file mode 100644
index 000000000000..ad9e9965671f
--- /dev/null
+++ b/ut3.sh
@@ -0,0 +1,3 @@
+#!/bin/bash
+cd /opt/ut3/Binaries
+/usr/bin/wine UT3.exe -nostartupmovies