summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2022-04-15 10:12:06 -0600
committerMark Wagie2022-04-15 10:12:06 -0600
commiteb539c062a6e5fb85506af3994fa9e1f6a27bcbe (patch)
tree3ce26478a844af6015fcfefd6eb478b7a1de9dac
parent09da6bac60893b6bd49cbc5f01b4887095ded000 (diff)
downloadaur-eb539c062a6e5fb85506af3994fa9e1f6a27bcbe.tar.gz
standards based build
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD10
2 files changed, 10 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cd7fd5449401..6328e68244fe 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,16 @@
pkgbase = python-liblarch-git
pkgdesc = Python library to easily handle data structure, with a GTK binding
- pkgver = 3.1.0.r9.gab053ac
- pkgrel = 1
+ pkgver = 3.2.0.r0.g628f588
+ pkgrel = 2
url = https://wiki.gnome.org/Projects/liblarch
arch = any
license = LGPL3
checkdepends = python-nose
makedepends = git
+ makedepends = python-build
+ makedepends = python-installer
makedepends = python-setuptools
+ makedepends = python-wheel
depends = gtk3
depends = python-gobject
depends = python-cairo
diff --git a/PKGBUILD b/PKGBUILD
index 5197aa5aaad4..af7339682f24 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,14 +2,14 @@
# Contributor: Francois Boulogne <fboulogne at april dot org>
pkgname=python-liblarch-git
_name=liblarch
-pkgver=3.1.0.r9.gab053ac
-pkgrel=1
+pkgver=3.2.0.r0.g628f588
+pkgrel=2
pkgdesc="Python library to easily handle data structure, with a GTK binding"
arch=('any')
url="https://wiki.gnome.org/Projects/liblarch"
license=('LGPL3')
depends=('gtk3' 'python-gobject' 'python-cairo')
-makedepends=('git' 'python-setuptools')
+makedepends=('git' 'python-build' 'python-installer' 'python-setuptools' 'python-wheel')
checkdepends=('python-nose')
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
@@ -23,7 +23,7 @@ pkgver() {
build() {
cd "$srcdir/$_name"
- python setup.py build
+ python -m build --wheel --no-isolation
}
check() {
@@ -33,5 +33,5 @@ check() {
package() {
cd "$srcdir/$_name"
- python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ python -m installer --destdir="$pkgdir" dist/*.whl
}