summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Martinez2021-10-02 13:57:37 -0500
committerLuis Martinez2021-10-02 13:57:37 -0500
commiteb6012b85e7d448bd7348f1ba1af0f3405b7bad0 (patch)
tree9a0a6290652986062dc301a35874779b6ecfbfe1
parentcd938d8d1809ef2628e51007d188fb9993c91904 (diff)
downloadaur-eb6012b85e7d448bd7348f1ba1af0f3405b7bad0.tar.gz
add man pages; switch to git tags
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD19
2 files changed, 15 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index daad1fcbda8b..c04d7f6cbc39 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-tabledata
pkgdesc = Python library to represent tabular data
pkgver = 1.3.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/thombashi/tabledata
arch = any
license = MIT
@@ -9,16 +9,17 @@ pkgbase = python-tabledata
checkdepends = python-pytest-runner
checkdepends = python-dateutil
checkdepends = python-pytz
+ makedepends = git
makedepends = python-setuptools
+ makedepends = python-sphinx
+ makedepends = python-sphinx_rtd_theme
depends = python>=3.6
depends = python-dataproperty>=0.53.0
depends = python-dataproperty<1
depends = python-typepy>=1.2.0
depends = python-typepy<2
- source = python-tabledata-1.3.0.tar.gz::https://files.pythonhosted.org/packages/source/t/tabledata/tabledata-1.3.0.tar.gz
- source = python-tabledata-1.3.0.tar.gz.asc::https://files.pythonhosted.org/packages/source/t/tabledata/tabledata-1.3.0.tar.gz.asc
+ source = python-tabledata::git+https://github.com/thombashi/tabledata
validpgpkeys = BCF9203E5E80B5607EAE6FDD98CDA9A5F0BFC367
- sha256sums = 54541b0c9e58f8fa38251ea0a60965dbaf95737027fa80e6ab56f98d7e4d61e9
sha256sums = SKIP
pkgname = python-tabledata
diff --git a/PKGBUILD b/PKGBUILD
index 70cb58fca940..9939157be19a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=python-tabledata
pkgver=1.3.0
-pkgrel=1
+pkgrel=2
pkgdesc='Python library to represent tabular data'
arch=('any')
url='https://github.com/thombashi/tabledata'
@@ -16,29 +16,30 @@ depends=(
'python-dataproperty<1'
'python-typepy>=1.2.0'
'python-typepy<2')
-makedepends=('python-setuptools')
+makedepends=('git' 'python-setuptools' 'python-sphinx' 'python-sphinx_rtd_theme')
checkdepends=('python-pytablewriter>=0.46' 'python-pytest-runner' 'python-dateutil' 'python-pytz')
-source=("$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/t/tabledata/tabledata-$pkgver.tar.gz"
- "$pkgname-$pkgver.tar.gz.asc::https://files.pythonhosted.org/packages/source/t/tabledata/tabledata-$pkgver.tar.gz.asc")
-sha256sums=('54541b0c9e58f8fa38251ea0a60965dbaf95737027fa80e6ab56f98d7e4d61e9'
- 'SKIP')
+source=("$pkgname::git+$url")
+sha256sums=('SKIP')
validpgpkeys=('BCF9203E5E80B5607EAE6FDD98CDA9A5F0BFC367')
build() {
- cd "tabledata-$pkgver"
+ cd "$pkgname"
python setup.py build
+ cd docs
+ PYTHONPATH=../ make man
}
check() {
- cd "tabledata-$pkgver"
+ cd "$pkgname"
python setup.py pytest
}
package() {
- cd "tabledata-$pkgver"
+ cd "$pkgname"
python setup.py install --root="$pkgdir" --optimize=1 --skip-build
install -Dm 644 README.rst -t "$pkgdir/usr/share/doc/$pkgname"
install -Dm 644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname"
+ install -Dm 644 docs/_build/man/tabledata.1 -t "$pkgdir/usr/share/man/man1/"
}
# vim: ts=2 sw=2 et: