summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrzej Giniewicz2016-04-10 21:40:01 +0200
committerAndrzej Giniewicz2016-04-10 21:40:01 +0200
commiteb64478b63d942956bae93f6e1a44e45b4cb2084 (patch)
tree4bd786b6239733b1ef5cef81663088328241c8f5
parent1d97f82055d017b1dfd31e541da960431b3d042e (diff)
downloadaur-eb64478b63d942956bae93f6e1a44e45b4cb2084.tar.gz
scala-ide: fix plugin location
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD31
-rw-r--r--scala-ide.desktop2
3 files changed, 20 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9e82f74a1beb..49d77798abf3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Mon Apr 4 10:46:09 UTC 2016
+# Sun Apr 10 19:38:29 UTC 2016
pkgbase = eclipse-scala-ide
pkgdesc = Scala IDE for Eclipse
pkgver = 4.4.0
- pkgrel = 1
+ pkgrel = 2
url = http://www.scala-ide.org/
arch = any
license = custom
@@ -14,7 +14,7 @@ pkgbase = eclipse-scala-ide
source = product.png
md5sums = 3e4f621aca2584ab8eac14815958529d
md5sums = 58b225f304aaf42c8b8738894a10cb96
- md5sums = 205ac79eeebb9cc43f9a0c836e60cf82
+ md5sums = faf8441d3576d87c227912b3491fdf29
md5sums = c95b1920928f10d2c982afd7f5827a2c
pkgname = eclipse-scala-ide
diff --git a/PKGBUILD b/PKGBUILD
index 9701736f9ef9..37457977a417 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=eclipse-scala-ide
pkgver=4.4.0
-pkgrel=1
+pkgrel=2
pkgdesc="Scala IDE for Eclipse"
arch=('any')
url="http://www.scala-ide.org/"
@@ -15,30 +15,31 @@ source=($pkgname-$pkgver.zip::"http://download.scala-ide.org/sdk/lithium/e44/sca
)
md5sums=('3e4f621aca2584ab8eac14815958529d'
'58b225f304aaf42c8b8738894a10cb96'
- '205ac79eeebb9cc43f9a0c836e60cf82'
+ 'faf8441d3576d87c227912b3491fdf29'
'c95b1920928f10d2c982afd7f5827a2c')
package() {
- install -D -m0644 "$srcdir"/LICENSE "$pkgdir"/usr/share/licenses/${pkgname}/LICENSE
- install -D -m0644 "$srcdir"/scala-ide.desktop "$pkgdir"/usr/share/applications/scala-ide.desktop
- install -D -m0644 "$srcdir"/product.png "$pkgdir"/usr/share/eclipse/dropins/scala-ide/icon.png
+ install -D -m0644 "${srcdir}"/LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -D -m0644 "${srcdir}"/scala-ide.desktop "${pkgdir}/usr/share/applications/scala-ide.desktop"
+ install -D -m0644 "${srcdir}"/product.png "${pkgdir}/usr/lib/eclipse/dropins/scala-ide/icon.png"
- _dest="${pkgdir}"/usr/share/eclipse/dropins/${pkgname/eclipse-}/eclipse
- cd "${srcdir}"/base
+ _dest="${pkgdir}/usr/lib/eclipse/dropins/${pkgname/eclipse-}/eclipse"
+ cd "${srcdir}/base"
# Features
- find features -type f | while read _feature ; do
- if [[ ${_feature} =~ (.*\.jar$) ]] ; then
- install -dm755 "${_dest}"/${_feature%*.jar}
- cd "${_dest}"/${_feature/.jar}
- jar xf "${srcdir}"/base/${_feature}
+ find features -type f | while read -r _feature ; do
+ if [[ "${_feature}" =~ (.*\.jar$) ]] ; then
+ install -dm755 "${_dest}/${_feature%*.jar}"
+ cd "${_dest}/${_feature/.jar}"
+ # extract features (otherwise they are not visible in about dialog)
+ jar xf "${srcdir}/base/${_feature}" || return 1
else
- install -Dm644 ${_feature} "${_dest}"/${_feature}
+ install -Dm644 "${_feature}" "${_dest}/${_feature}"
fi
done
# Plugins
- find plugins -type f | while read _plugin ; do
- install -Dm644 ${_plugin} "${_dest}"/${_plugin}
+ find plugins -type f | while read -r _plugin ; do
+ install -Dm644 "${_plugin}" "${_dest}/${_plugin}"
done
}
diff --git a/scala-ide.desktop b/scala-ide.desktop
index 65a059b0af3c..5cadcf9315ee 100644
--- a/scala-ide.desktop
+++ b/scala-ide.desktop
@@ -2,7 +2,7 @@
Type=Application
Name=Scala-IDE
GenericName=Scala IDE for Eclipse
-Icon=/usr/share/eclipse/dropins/scala-ide/icon.png
+Icon=/usr/lib/eclipse/dropins/scala-ide/icon.png
Exec=/usr/bin/eclipse
Categories=Development