summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoruli2023-04-18 12:47:43 +0200
committeruli2023-04-18 12:47:43 +0200
commiteb67f13855526528b63405fc9fa22bdaf129b3e1 (patch)
tree696510e71d2797cbac8e7581ea62a35727310656
parent3ce8e25b3db3b9de4a92dfac520a4d978e6f430c (diff)
downloadaur-eb67f13855526528b63405fc9fa22bdaf129b3e1.tar.gz
v5.8.0
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD15
-rw-r--r--wx_workaround.patch11
3 files changed, 10 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5e6ee0d1d392..21f4c75099cd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = opencpn
pkgdesc = Open Source Chart Plotting / Marine Navigation
- pkgver = 5.6.2
+ pkgver = 5.8.0
pkgrel = 1
url = http://opencpn.org
arch = x86_64
@@ -14,12 +14,12 @@ pkgbase = opencpn
depends = libsndfile
depends = libarchive
depends = libexif
+ depends = glew
depends = glu
depends = webkit2gtk
+ depends = wxsvg
optdepends = gpsd: GPS position support
- source = https://github.com/OpenCPN/OpenCPN/archive/Release_5.6.2.tar.gz
- source = wx_workaround.patch
- b2sums = a45e19d293d63262f2bb6bd0bd5d18723cadd0b93af8e64484b55d246cebbe623dccbb6a1d257eccd74fb9111953d9cdd4b44d6f3fb38c3a9f40fa253718f337
- b2sums = ac80978933a4893aa55b019547025e07e888b689378eba82322d1f36a8db5f64faf150c4084690d621e3d30e7fbbd5c94f47ec8582e6c1e174dcd60d7b79d176
+ source = opencpn-5.8.0.tar.gz::https://github.com/OpenCPN/OpenCPN/archive/Release_5.8.0.tar.gz
+ b2sums = 7a85216526fc9d79995e2d0aabb55c68cd7627106e30e0a755df494cd30345131b7e8e8eb9d71f3c2c2cec0e15664a4ae45fa43f4332568b83b23f3839bf85ac
pkgname = opencpn
diff --git a/PKGBUILD b/PKGBUILD
index 7f26ef630f44..5eadf7aabcc8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,28 +7,23 @@
# Submitter: Anders Lund <anders at alweb dot dk>
pkgname=opencpn
-pkgver=5.6.2
+pkgver=5.8.0
pkgrel=1
pkgdesc="Open Source Chart Plotting / Marine Navigation"
arch=('x86_64' 'aarch64')
license=("GPL2")
-depends=('wxgtk3' 'portaudio' 'tinyxml' 'libsndfile' 'libarchive' 'libexif' 'glu' 'webkit2gtk')
+depends=('wxgtk3' 'portaudio' 'tinyxml' 'libsndfile' 'libarchive' 'libexif' 'glew' 'glu' 'webkit2gtk' 'wxsvg')
optdepends=('gpsd: GPS position support')
makedepends=('cmake' 'lsb-release')
url="http://opencpn.org"
-source=("https://github.com/OpenCPN/OpenCPN/archive/Release_${pkgver}.tar.gz" "wx_workaround.patch")
-b2sums=('a45e19d293d63262f2bb6bd0bd5d18723cadd0b93af8e64484b55d246cebbe623dccbb6a1d257eccd74fb9111953d9cdd4b44d6f3fb38c3a9f40fa253718f337' 'dee0d7d6a62d13e35211f3e1e47beb30fa61755852435f53d8a540a1f3fd61fb57661890ec99fb258c11b152887858347d1f64e664f4401a252e62d563a0b68c')
-
-prepare() {
- cd OpenCPN-Release_${pkgver}
- patch --strip=1 --input=../wx_workaround.patch
-}
+source=("$pkgname-$pkgver.tar.gz::https://github.com/OpenCPN/OpenCPN/archive/Release_${pkgver}.tar.gz")
+b2sums=('7a85216526fc9d79995e2d0aabb55c68cd7627106e30e0a755df494cd30345131b7e8e8eb9d71f3c2c2cec0e15664a4ae45fa43f4332568b83b23f3839bf85ac')
build() {
cd OpenCPN-Release_${pkgver}
mkdir -p build
cd build
- cmake -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX=/usr ..
+ cmake -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX=/usr -DOCPN_BUILD_TEST=OFF -DOCPN_VERBOSE=OFF -DOCPN_USE_EXTERN_CURL=ON ..
make
}
diff --git a/wx_workaround.patch b/wx_workaround.patch
deleted file mode 100644
index 007d4b5e1994..000000000000
--- a/wx_workaround.patch
+++ /dev/null
@@ -1,11 +0,0 @@
-diff a/include/bbox.h b/include/bbox.h
---- a/include/bbox.h
-+++ b/include/bbox.h
-@@ -6,7 +6,9 @@
- #include "wx/wx.h"
- #endif
-
-+#undef wxDEPRECATED_MSG
-+#define wxDEPRECATED_MSG(param)
- #include "wx/matrix.h"
- #include "wx/geometry.h"