summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGreyson Christoforo2022-04-26 11:38:00 +0100
committerGreyson Christoforo2022-04-26 11:38:00 +0100
commiteb88fd0467c0460d47d4e7b4c697a6adfa4f04e2 (patch)
tree3201fc0ca24f31a34066465c8963f784c606cea2
downloadaur-eb88fd0467c0460d47d4e7b4c697a6adfa4f04e2.tar.gz
initial commit
-rw-r--r--.SRCINFO12
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD37
3 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7740445a2fe1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = python-cq_warehouse
+ pkgdesc = A cadquery parametric part collection
+ pkgver = 0.6.0
+ pkgrel = 1
+ url = https://github.com/gumyr/cq_warehouse
+ arch = x86_64
+ license = Apache
+ depends = python-cadquery
+ source = python-cq_warehouse-0.6.0.tar.gz::https://github.com/gumyr/cq_warehouse/archive/refs/tags/v0.6.0.tar.gz
+ sha256sums = 3f928eebde439b3c7c161059bb8a8442cf243c4f401916e4bda6ec97099768dc
+
+pkgname = python-cq_warehouse
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..27fd112126d4
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+src/
+pkg/
+*.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b229be6029a4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# $Id$
+# Maintainer: Grey Christoforo <first name at last name dot net>
+
+pkgname=python-cq_warehouse
+pkgver=0.6.0
+pkgrel=1
+pkgdesc="A cadquery parametric part collection"
+arch=(x86_64)
+url="https://github.com/gumyr/cq_warehouse"
+license=('Apache')
+depends=(
+python-cadquery
+)
+
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/gumyr/cq_warehouse/archive/refs/tags/v${pkgver}.tar.gz")
+sha256sums=('3f928eebde439b3c7c161059bb8a8442cf243c4f401916e4bda6ec97099768dc')
+
+prepare() {
+ cd cq_warehouse-${pkgver}
+}
+
+build() {
+ cd cq_warehouse-${pkgver}
+ python -m build --wheel --no-isolation
+}
+
+check() {
+ cd cq_warehouse-${pkgver}
+ python -m unittest -v # project currently configured incorrectly for this to work
+}
+
+package() {
+ cd cq_warehouse-${pkgver}
+ # python -m installer --destdir="${pkgdir}" dist/*.whl
+ python -m installer --destdir="${pkgdir}" dist/cq_warehouse-${pkgver}*.whl
+}
+