summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorShane2019-07-10 13:09:32 +0800
committerShane2019-07-10 13:09:32 +0800
commiteb9e942c3c9816a5c9270b5ab171c19d587947d1 (patch)
tree1cda98f7828aff2910cab8f65f2e9403bb165e8d
downloadaur-eb9e942c3c9816a5c9270b5ab171c19d587947d1.tar.gz
Another Redis Desktop Manager
-rw-r--r--.SRCINFO26
-rw-r--r--.gitignore8
-rw-r--r--PKGBUILD41
-rw-r--r--another-redis-desktop-manager.desktop12
-rw-r--r--another-redis-desktop-manager.pngbin0 -> 42207 bytes
5 files changed, 87 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..be2eafcd6517
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+pkgbase = another-redis-desktop-manager
+ pkgdesc = Another Redis Desktop Manager
+ pkgver = 1.2.4
+ pkgrel = 1
+ url = https://github.com/qishibo/AnotherRedisDesktopManager
+ arch = x86_64
+ license = MIT
+ depends = aria2
+ depends = libappindicator-sharp
+ depends = libappindicator-gtk3
+ depends = libappindicator-gtk2
+ depends = gconf
+ depends = libindicator-gtk3
+ depends = libindicator-gtk2
+ depends = libnotify
+ depends = libxss
+ depends = libxtst
+ source = https://github.com/qishibo/AnotherRedisDesktopManager/releases/download/v1.2.4/Another.Redis.Desktop.Manager.1.2.4.AppImage
+ source = another-redis-desktop-manager.desktop
+ source = another-redis-desktop-manager.png
+ md5sums = 9818915d396b59af1037b17fd1c3460f
+ md5sums = SKIP
+ md5sums = SKIP
+
+pkgname = another-redis-desktop-manager
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..70f090a44295
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,8 @@
+src
+pkg
+*.part.*
+*.deb
+*.rpm
+*.AppImage
+*.pkg.tar.xz
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..72760490cea2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Shane Lyx <shanelyx@outlook.com>
+pkgname=another-redis-desktop-manager
+pkgver=1.2.4
+pkgrel=1
+pkgdesc="Another Redis Desktop Manager"
+arch=("x86_64")
+url="https://github.com/qishibo/AnotherRedisDesktopManager"
+license=('MIT')
+depends=('aria2' 'libappindicator-sharp' 'libappindicator-gtk3' 'libappindicator-gtk2' 'gconf' 'libindicator-gtk3' 'libindicator-gtk2'
+ 'libnotify' 'libxss' 'libxtst')
+
+DLAGENTS=('https::/usr/bin/aria2c -x 5 -c --disable-ipv6=true --check-certificate=false -o %o %u')
+
+source=(
+ "https://github.com/qishibo/AnotherRedisDesktopManager/releases/download/v1.2.4/Another.Redis.Desktop.Manager.1.2.4.AppImage"
+ "another-redis-desktop-manager.desktop"
+ "another-redis-desktop-manager.png"
+)
+
+md5sums=(
+ "9818915d396b59af1037b17fd1c3460f"
+ "SKIP"
+ "SKIP"
+)
+
+package(){
+ cd ${srcdir}
+ 7z x Another.Redis.Desktop.Manager.1.2.4.AppImage -o"${pkgdir}/opt/Another.Redis.Desktop.Manager"
+ chmod -R 755 "${pkgdir}/opt"
+
+ # desktop
+ mkdir -p ${pkgdir}/usr/share/applications
+ install -Dm644 another-redis-desktop-manager.desktop ${pkgdir}/usr/share/applications/
+
+ # icon
+ mkdir -p ${pkgdir}/usr/share/icons/hicolor/512x512/apps
+ install -Dm644 another-redis-desktop-manager.png ${pkgdir}/usr/share/icons/hicolor/512x512/apps/
+}
+
+
+
diff --git a/another-redis-desktop-manager.desktop b/another-redis-desktop-manager.desktop
new file mode 100644
index 000000000000..7cfa5fce3e9b
--- /dev/null
+++ b/another-redis-desktop-manager.desktop
@@ -0,0 +1,12 @@
+[Desktop Entry]
+Categories=Development;Utility;
+Comment=A faster, better and more stable redis desktop manager.
+Exec=/opt/Another.Redis.Desktop.Manager/AppRun
+Icon=another-redis-desktop-manager
+Name=Another-Redis-Desktop-Manager
+StartupWMClass=Another.Redis.Desktop.Manager
+Terminal=false
+Type=Application
+X-AppImage-BuildId=1NiitrlhpN0PQdDacKLp9dWtu3U
+X-AppImage-Version=1.2.4
+X-Deepin-Vendor=user-custom
diff --git a/another-redis-desktop-manager.png b/another-redis-desktop-manager.png
new file mode 100644
index 000000000000..d9c696992b38
--- /dev/null
+++ b/another-redis-desktop-manager.png
Binary files differ