summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJan Baudisch2018-04-18 21:39:38 +0200
committerJan Baudisch2018-04-18 21:39:38 +0200
commitebc294a35fc914b220974e116733b2613c81ad2c (patch)
tree5b9270e91d4d10edda63439c8fbfc95dd03a2c06
downloadaur-ebc294a35fc914b220974e116733b2613c81ad2c.tar.gz
initial commit
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD28
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..142a3762218a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = wxwabbitemu-git
+ pkgdesc = A cross-platform TI-8x emulator based on Wabbitemu
+ pkgver = 48325ca
+ pkgrel = 1
+ url = https://github.com/alberthdev/wxwabbitemu
+ arch = x86_64
+ license = unknown
+ depends = wxgtk3
+ source = wxwabbitemu-git::git+https://github.com/alberthdev/wxwabbitemu.git
+ sha256sums = SKIP
+
+pkgname = wxwabbitemu-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5a47d8d9287b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Jan Baudisch <dev@baudisch.xyz>
+pkgname=wxwabbitemu-git
+pkgver=48325ca
+pkgrel=1
+pkgdesc="A cross-platform TI-8x emulator based on Wabbitemu"
+arch=("x86_64")
+url="https://github.com/alberthdev/wxwabbitemu"
+license=("unknown")
+depends=("wxgtk3")
+source=("$pkgname::git+https://github.com/alberthdev/wxwabbitemu.git")
+sha256sums=("SKIP")
+
+pkgver() {
+ cd "$pkgname"
+ git rev-parse --short HEAD
+}
+
+build() {
+ # linkage errors when built with optimizations
+ export CFLAGS="${CFLAGS//-O*}"
+
+ cd "$pkgname"
+ make
+}
+
+package() {
+ install -Dm755 "$pkgname/bin/wxWabbitemu" "$pkgdir/usr/bin/wxwabbitemu"
+}