summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAngel Perez2021-08-06 22:08:48 -0400
committerAngel Perez2021-08-06 22:08:48 -0400
commitebd26a27644230b849bbd020e6a4d9906124aa0e (patch)
tree9f45ef35a06d46af49d6c86e508f4592655dfe1d
parent1a29abcaf8017525d09d5b8b60bf7a2fb18895dc (diff)
downloadaur-ebd26a27644230b849bbd020e6a4d9906124aa0e.tar.gz
Solved errors in Ubuntu grub patches
-rwxr-xr-x.SRCINFO13
-rw-r--r--02-10_linux-detect-archlinux-initramfs.patch41
-rw-r--r--02-linux-detect-archlinux-initramfs.patch4
-rw-r--r--03-add-GRUB_COLOR_variables.patch14
-rw-r--r--05-sleep_shift.patch33
-rw-r--r--06-maybe_quiet.patch88
-rw-r--r--07-quick_boot.patch89
-rw-r--r--PKGBUILD12
8 files changed, 76 insertions, 218 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 27204ce2eae3..049c44fb4be8 100755
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = grub-silent
pkgdesc = GNU GRand Unified Bootloader (2) [without welcome and kernel messages]
pkgver = 2.06
- pkgrel = 1
+ pkgrel = 2
url = https://www.gnu.org/software/grub/
install = grub.install
arch = x86_64
@@ -56,12 +56,13 @@ pkgbase = grub-silent
sha256sums = b79ea44af91b93d17cd3fe80bdae6ed43770678a9a5ae192ccea803ebb657ee1
sha256sums = fb6b37db9b14fd03e4d26775d84b570fbe91d4ea5de3df4e31114d79a2dfa97e
sha256sums = d101e9d33fbc67f7aaf6fb1191ec1315e8e5572c1d0538b95746ee194b8860db
- sha256sums = b6e1c57dc9632ddf14e0acd96c5182cb4491994b67765cb11518d1356b603879
- sha256sums = f77417646a5480623f61006304bf68e3a733e77642978af949d4452f36e3203a
+ sha256sums = 21153ab7f020d9f819a70b9c879b29e9709996c5b0304816123c09b6849f95a3
+ sha256sums = 6fa180674094f9e1723f736d458f1fe0b5740ea7cf5db5064139defc17ce0e94
sha256sums = 39d7843dfe1e10ead912a81be370813b8621794a7967b3cc5e4d4188b5bf7264
- sha256sums = 4b189e00a8c97ec09903e9588e02fc78b4bb114ee4822fcce13811aca00c8884
- sha256sums = b7489c7facc4fb3dad4426c9c00079b64908640a2bec2409e22194daa3f72af4
- sha256sums = 1723340737b91a5bf503829bbe66b1c56683ef0e533f20d18b7098840aecb3a2
+ sha256sums = c4cb3aa5ed535c7f3a3f784a779ea0a02bfed0ac54f202387a18de04dda8297f
+ sha256sums = fe2871773868fdbb9523661fd67e38a60d3cf1eb51f6964beb839105dfa8ec3e
+ sha256sums = 7769a65321d1611217d6af47c1c3fe91ce2f97adcfd58c4e0d2e0bb06b39100e
sha256sums = 4f2e9d585b7b0ef8ce0d09e88391d1397b50883c7cb1516dc99785934abe15a2
pkgname = grub-silent
+
diff --git a/02-10_linux-detect-archlinux-initramfs.patch b/02-10_linux-detect-archlinux-initramfs.patch
deleted file mode 100644
index cea7706ad44c..000000000000
--- a/02-10_linux-detect-archlinux-initramfs.patch
+++ /dev/null
@@ -1,41 +0,0 @@
-diff --git a/util/grub.d/10_linux.in b/util/grub.d/10_linux.in
-index 892d34d..e69bef8 100644
---- a/util/grub.d/10_linux.in
-+++ b/util/grub.d/10_linux.in
-@@ -93,6 +93,8 @@ linux_entry ()
- case $type in
- recovery)
- title="$(gettext_printf "%s, with Linux %s (recovery mode)" "${os}" "${version}")" ;;
-+ fallback)
-+ title="$(gettext_printf "%s, with Linux %s (fallback initramfs)" "${os}" "${version}")" ;;
- *)
- title="$(gettext_printf "%s, with Linux %s" "${os}" "${version}")" ;;
- esac
-@@ -195,7 +197,7 @@ while [ "x$list" != "x" ] ; do
- basename=`basename $linux`
- dirname=`dirname $linux`
- rel_dirname=`make_system_path_relative_to_its_root $dirname`
-- version=`echo $basename | sed -e "s,^[^0-9]*-,,g"`
-+ version=`echo $basename | sed -e "s,vmlinuz-,,g"`
- alt_version=`echo $version | sed -e "s,\.old$,,g"`
- linux_root_device_thisversion="${LINUX_ROOT_DEVICE}"
-
-@@ -277,6 +279,18 @@ while [ "x$list" != "x" ] ; do
-
- linux_entry "${OS}" "${version}" advanced \
- "${GRUB_CMDLINE_LINUX} ${GRUB_CMDLINE_LINUX_DEFAULT}"
-+
-+ if test -e "${dirname}/initramfs-${version}-fallback.img" ; then
-+ initrd="initramfs-${version}-fallback.img"
-+
-+ if test -n "${initrd}" ; then
-+ gettext_printf "Found fallback initrd image(s) in %s:%s\n" "${dirname}" "${initrd_extra} ${initrd}" >&2
-+ fi
-+
-+ linux_entry "${OS}" "${version}" fallback \
-+ "${GRUB_CMDLINE_LINUX} ${GRUB_CMDLINE_LINUX_DEFAULT}"
-+ fi
-+
- if [ "x${GRUB_DISABLE_RECOVERY}" != "xtrue" ]; then
- linux_entry "${OS}" "${version}" recovery \
- "single ${GRUB_CMDLINE_LINUX}"
diff --git a/02-linux-detect-archlinux-initramfs.patch b/02-linux-detect-archlinux-initramfs.patch
index cea7706ad44c..b7fc8eb9cc72 100644
--- a/02-linux-detect-archlinux-initramfs.patch
+++ b/02-linux-detect-archlinux-initramfs.patch
@@ -1,5 +1,5 @@
diff --git a/util/grub.d/10_linux.in b/util/grub.d/10_linux.in
-index 892d34d..e69bef8 100644
+index 8d7b1a9..2cb9d31 100644
--- a/util/grub.d/10_linux.in
+++ b/util/grub.d/10_linux.in
@@ -93,6 +93,8 @@ linux_entry ()
@@ -20,7 +20,7 @@ index 892d34d..e69bef8 100644
alt_version=`echo $version | sed -e "s,\.old$,,g"`
linux_root_device_thisversion="${LINUX_ROOT_DEVICE}"
-@@ -277,6 +279,18 @@ while [ "x$list" != "x" ] ; do
+@@ -285,6 +287,18 @@ while [ "x$list" != "x" ] ; do
linux_entry "${OS}" "${version}" advanced \
"${GRUB_CMDLINE_LINUX} ${GRUB_CMDLINE_LINUX_DEFAULT}"
diff --git a/03-add-GRUB_COLOR_variables.patch b/03-add-GRUB_COLOR_variables.patch
index dad0ff925270..a505cd94a673 100644
--- a/03-add-GRUB_COLOR_variables.patch
+++ b/03-add-GRUB_COLOR_variables.patch
@@ -1,16 +1,16 @@
diff --git a/util/grub-mkconfig.in b/util/grub-mkconfig.in
-index 9f477ff..b0e6d45 100644
+index f8cbb8d..17269b3 100644
--- a/util/grub-mkconfig.in
+++ b/util/grub-mkconfig.in
-@@ -233,6 +233,8 @@ export GRUB_DEFAULT \
- GRUB_THEME \
- GRUB_GFXPAYLOAD_LINUX \
+@@ -205,6 +205,8 @@ export GRUB_DEVICE \
+ GRUB_DEVICE_BOOT \
+ GRUB_DEVICE_BOOT_UUID \
GRUB_DISABLE_OS_PROBER \
+ GRUB_COLOR_NORMAL \
+ GRUB_COLOR_HIGHLIGHT \
- GRUB_INIT_TUNE \
- GRUB_SAVEDEFAULT \
- GRUB_ENABLE_CRYPTODISK \
+ GRUB_FS \
+ GRUB_FONT \
+ GRUB_PRELOAD_MODULES \
diff --git a/util/grub.d/00_header.in b/util/grub.d/00_header.in
index 93a9023..c5955df 100644
--- a/util/grub.d/00_header.in
diff --git a/05-sleep_shift.patch b/05-sleep_shift.patch
index 973cb8702207..1e029188c3b1 100644
--- a/05-sleep_shift.patch
+++ b/05-sleep_shift.patch
@@ -1,23 +1,5 @@
-From 6d92ce5e4248eec87c831734bff72581721a1026 Mon Sep 17 00:00:00 2001
-From: Colin Watson <cjwatson@ubuntu.com>
-Date: Mon, 13 Jan 2014 12:13:23 +0000
-Subject: Allow Shift to interrupt 'sleep --interruptible'
-
-Upstream would like to consider this at more length. See
-http://lists.gnu.org/archive/html/grub-devel/2009-08/msg00718.html, and
-the rest of the thread for context.
-
-Forwarded: http://lists.gnu.org/archive/html/grub-devel/2009-08/msg00694.html
-Last-Update: 2013-12-04
-
-Patch-Name: sleep_shift.patch
----
- grub-core/commands/sleep.c | 27 ++++++++++++++++++++++++++-
- grub-core/normal/menu.c | 19 +++++++++++++++++++
- 2 files changed, 45 insertions(+), 1 deletion(-)
-
diff --git a/grub-core/commands/sleep.c b/grub-core/commands/sleep.c
-index e77e7900f..3906b1410 100644
+index a1370b7..be9f386 100644
--- a/grub-core/commands/sleep.c
+++ b/grub-core/commands/sleep.c
@@ -46,6 +46,31 @@ do_print (int n)
@@ -52,20 +34,11 @@ index e77e7900f..3906b1410 100644
/* Based on grub_millisleep() from kern/generic/millisleep.c. */
static int
grub_interruptible_millisleep (grub_uint32_t ms)
-@@ -55,7 +80,7 @@ grub_interruptible_millisleep (grub_uint32_t ms)
- start = grub_get_time_ms ();
-
- while (grub_get_time_ms () - start < ms)
-- if (grub_getkey_noblock () == GRUB_TERM_ESC)
-+ if (grub_check_keyboard ())
- return 1;
-
- return 0;
diff --git a/grub-core/normal/menu.c b/grub-core/normal/menu.c
-index 719e2fb1c..9d0ad4c95 100644
+index 8397886..c2943c6 100644
--- a/grub-core/normal/menu.c
+++ b/grub-core/normal/menu.c
-@@ -615,8 +615,27 @@ run_menu (grub_menu_t menu, int nested, int *auto_boot)
+@@ -614,8 +614,27 @@ run_menu (grub_menu_t menu, int nested, int *auto_boot)
saved_time = grub_get_time_ms ();
while (1)
{
diff --git a/06-maybe_quiet.patch b/06-maybe_quiet.patch
index 59bd82237f93..31795085556a 100644
--- a/06-maybe_quiet.patch
+++ b/06-maybe_quiet.patch
@@ -1,49 +1,3 @@
-From ec5b5793aa6befcc44bb8328a26ff34e24979b59 Mon Sep 17 00:00:00 2001
-From: Colin Watson <cjwatson@ubuntu.com>
-Date: Mon, 13 Jan 2014 12:13:26 +0000
-Subject: Add configure option to reduce visual clutter at boot time
-
-If this option is enabled, then do all of the following:
-
-Don't display introductory message about line editing unless we're
-actually offering a shell prompt. (This is believed to be a workaround
-for a different bug. We'll go with this for now, but will drop this in
-favour of a better fix upstream if somebody figures out what that is.)
-
-Don't clear the screen just before booting if we never drew the menu in
-the first place.
-
-Remove verbose messages printed before reading configuration. In some
-ways this is awkward because it makes debugging harder, but it's a
-requirement for a smooth-looking boot process; we may be able to do
-better in future. Upstream doesn't want this, though.
-
-Disable the cursor as well, for similar reasons of tidiness.
-
-Suppress kernel/initrd progress messages, except in recovery mode.
-
-Suppress "GRUB loading" message unless Shift is held down. Upstream
-doesn't want this, as it makes debugging harder. Ubuntu wants it to
-provide a cleaner boot experience.
-
-Bug-Ubuntu: https://bugs.launchpad.net/bugs/386922
-Bug-Ubuntu: https://bugs.launchpad.net/bugs/861048
-Forwarded: (partial) http://lists.gnu.org/archive/html/grub-devel/2009-09/msg00056.html
-Last-Update: 2014-01-03
-
-Patch-Name: maybe_quiet.patch
----
- config.h.in | 2 ++
- configure.ac | 16 ++++++++++++++++
- grub-core/boot/i386/pc/boot.S | 11 +++++++++++
- grub-core/boot/i386/pc/diskboot.S | 26 ++++++++++++++++++++++++++
- grub-core/kern/main.c | 17 +++++++++++++++++
- grub-core/kern/rescue_reader.c | 2 ++
- grub-core/normal/main.c | 11 +++++++++++
- grub-core/normal/menu.c | 17 +++++++++++++++--
- util/grub.d/10_linux.in | 15 +++++++++++----
- 9 files changed, 111 insertions(+), 6 deletions(-)
-
diff --git a/config.h.in b/config.h.in
index 9e8f991..d2c4ce8 100644
--- a/config.h.in
@@ -58,11 +12,12 @@ index 9e8f991..d2c4ce8 100644
/* We don't need those. */
#define MINILZO_CFG_SKIP_LZO_PTR 1
diff --git a/configure.ac b/configure.ac
+index 22663ba..d02fe6b 100644
--- a/configure.ac
+++ b/configure.ac
-@@ -1797,6 +1797,17 @@ else
- fi
- AC_SUBST([UBUNTU_RECOVERY])
+@@ -1904,6 +1904,17 @@ fi
+ AC_SUBST([LIBZFS])
+ AC_SUBST([LIBNVPAIR])
+AC_ARG_ENABLE([quiet-boot],
+ [AS_HELP_STRING([--enable-quiet-boot],
@@ -78,9 +33,9 @@ diff --git a/configure.ac b/configure.ac
LIBS=""
AC_SUBST([FONT_SOURCE])
-@@ -2048,5 +2059,10 @@ echo "Without liblzma (no support for XZ-compressed mips images) ($liblzma_excus
+@@ -2166,5 +2177,10 @@ echo "With stack smashing protector: Yes"
else
- echo "With liblzma from $LIBLZMA (support for XZ-compressed mips images)"
+ echo "With stack smashing protector: No"
fi
+if [ x"$enable_quiet_boot" = xyes ]; then
+echo With quiet boot: Yes
@@ -90,6 +45,7 @@ diff --git a/configure.ac b/configure.ac
echo "*******************************************************"
]
diff --git a/grub-core/boot/i386/pc/boot.S b/grub-core/boot/i386/pc/boot.S
+index 2bd0b2d..451c8be 100644
--- a/grub-core/boot/i386/pc/boot.S
+++ b/grub-core/boot/i386/pc/boot.S
@@ -19,6 +19,9 @@
@@ -121,6 +77,7 @@ diff --git a/grub-core/boot/i386/pc/boot.S b/grub-core/boot/i386/pc/boot.S
movw $disk_address_packet, %si
diff --git a/grub-core/boot/i386/pc/diskboot.S b/grub-core/boot/i386/pc/diskboot.S
+index c1addc0..c6fd50b 100644
--- a/grub-core/boot/i386/pc/diskboot.S
+++ b/grub-core/boot/i386/pc/diskboot.S
@@ -18,6 +18,9 @@
@@ -200,9 +157,10 @@ diff --git a/grub-core/boot/i386/pc/diskboot.S b/grub-core/boot/i386/pc/diskboot
notification_step: .asciz "."
diff --git a/grub-core/kern/main.c b/grub-core/kern/main.c
+index 73967e2..d753d81 100644
--- a/grub-core/kern/main.c
+++ b/grub-core/kern/main.c
-@@ -264,15 +264,25 @@ reclaim_module_space (void)
+@@ -265,15 +265,25 @@ reclaim_module_space (void)
void __attribute__ ((noreturn))
grub_main (void)
{
@@ -226,9 +184,9 @@ diff --git a/grub-core/kern/main.c b/grub-core/kern/main.c
grub_setcolorstate (GRUB_TERM_COLOR_STANDARD);
+#endif
- grub_load_config ();
-
-@@ -308,5 +318,12 @@ grub_main (void)
+ /* Init verifiers API. */
+ grub_verifiers_init ();
+@@ -312,5 +322,12 @@ grub_main (void)
grub_boot_time ("After execution of embedded config. Attempt to go to normal mode");
grub_load_normal_mode ();
@@ -242,6 +200,7 @@ diff --git a/grub-core/kern/main.c b/grub-core/kern/main.c
grub_rescue_run ();
}
diff --git a/grub-core/kern/rescue_reader.c b/grub-core/kern/rescue_reader.c
+index dcd7d44..03826cf 100644
--- a/grub-core/kern/rescue_reader.c
+++ b/grub-core/kern/rescue_reader.c
@@ -78,7 +78,9 @@ grub_rescue_read_line (char **line, int cont,
@@ -255,9 +214,10 @@ diff --git a/grub-core/kern/rescue_reader.c b/grub-core/kern/rescue_reader.c
while (1)
{
diff --git a/grub-core/normal/main.c b/grub-core/normal/main.c
+index c4ebe9e..f690a3f 100644
--- a/grub-core/normal/main.c
+++ b/grub-core/normal/main.c
-@@ -389,6 +389,15 @@ static grub_err_t
+@@ -407,6 +407,15 @@ static grub_err_t
grub_normal_read_line_real (char **line, int cont, int nested)
{
const char *prompt;
@@ -273,7 +233,7 @@ diff --git a/grub-core/normal/main.c b/grub-core/normal/main.c
if (cont)
/* TRANSLATORS: it's command line prompt. */
-@@ -441,7 +450,9 @@ grub_cmdline_run (int nested, int force_auth)
+@@ -459,7 +468,9 @@ grub_cmdline_run (int nested, int force_auth)
return;
}
@@ -284,6 +244,7 @@ diff --git a/grub-core/normal/main.c b/grub-core/normal/main.c
while (1)
{
diff --git a/grub-core/normal/menu.c b/grub-core/normal/menu.c
+index c2943c6..338f5a5 100644
--- a/grub-core/normal/menu.c
+++ b/grub-core/normal/menu.c
@@ -826,12 +826,18 @@ run_menu (grub_menu_t menu, int nested, int *auto_boot)
@@ -330,16 +291,18 @@ diff --git a/grub-core/normal/menu.c b/grub-core/normal/menu.c
if (auto_boot)
grub_menu_execute_with_fallback (menu, e, autobooted,
diff --git a/util/grub.d/10_linux.in b/util/grub.d/10_linux.in
+index 1839059..24acf01 100644
--- a/util/grub.d/10_linux.in
+++ b/util/grub.d/10_linux.in
-@@ -21,5 +21,6 @@ prefix="@prefix@"
+@@ -20,6 +20,7 @@ set -e
+ prefix="@prefix@"
exec_prefix="@exec_prefix@"
datarootdir="@datarootdir@"
+quiet_boot="@QUIET_BOOT@"
. "$pkgdatadir/grub-mkconfig_lib"
-@@ -148,9 +149,13 @@ linux_entry ()
+@@ -140,15 +141,21 @@ linux_entry ()
fi
printf '%s\n' "${prepare_boot_cache}" | sed "s/^/$submenu_indentation/"
fi
@@ -349,15 +312,12 @@ diff --git a/util/grub.d/10_linux.in b/util/grub.d/10_linux.in
+ message="$(gettext_printf "Loading Linux %s ..." ${version})"
+ sed "s/^/$submenu_indentation/" << EOF
echo '$(echo "$message" | grub_quote)'
-+EOF
++ EOF
+ fi
-+ sed "s/^/$submenu_indentation/" << EOF
++ sed "s/^/$submenu_indentation/" << EOF
linux ${rel_dirname}/${basename} root=${linux_root_device_thisversion} rw ${args}
EOF
if test -n "${initrd}" -o -n "${initrd_extra}" ; then
-@@ -163,8 +168,10 @@ EOF
- EOF
- if test -n "${initrd}" -o -n "${initrd_extra}" ; then
# TRANSLATORS: ramdisk isn't identifier. Should be translated.
- message="$(gettext_printf "Loading initial ramdisk ...")"
- printf ' %s\n' "echo '$(echo "$message" | grub_quote)'" | sed "s/^/$submenu_indentation/"
diff --git a/07-quick_boot.patch b/07-quick_boot.patch
index 3a593b238bc5..a8e1c8247549 100644
--- a/07-quick_boot.patch
+++ b/07-quick_boot.patch
@@ -1,43 +1,8 @@
-From db2c839f0201d67aace730049d6704006beccf4c Mon Sep 17 00:00:00 2001
-From: Colin Watson <cjwatson@ubuntu.com>
-Date: Mon, 13 Jan 2014 12:13:28 +0000
-Subject: Add configure option to bypass boot menu if possible
-
-If other operating systems are installed, then automatically unhide the
-menu. Otherwise, if GRUB_HIDDEN_TIMEOUT is 0, then use keystatus if
-available to check whether Shift is pressed. If it is, show the menu,
-otherwise boot immediately. If keystatus is not available, then fall
-back to a short delay interruptible with Escape.
-
-This may or may not remain Ubuntu-specific, although it's not obviously
-wanted upstream. It implements a requirement of
-https://wiki.ubuntu.com/DesktopExperienceTeam/KarmicBootExperienceDesignSpec#Bootloader.
-
-If the previous boot failed (defined as failing to get to the end of one
-of the normal runlevels), then show the boot menu regardless.
-
-Contributor : Angel Perez <drlorente97@gmail.com>
-Author: Richard Laager <rlaager@wiktel.com>
-Author: Robie Basak <robie.basak@ubuntu.com>
-Forwarded: no
-Last-Update: 2021-05-21
-
-Patch-Name: quick_boot.patch
----
- configure.ac | 11 +++++++
- docs/grub.texi | 14 +++++++++
- grub-core/normal/menu.c | 24 ++++++++++++++
- util/grub-mkconfig.in | 3 +-
- util/grub.d/00_header.in | 77 ++++++++++++++++++++++++++++++++++++++-------
- util/grub.d/10_linux.in | 4 +++
- util/grub.d/30_os-prober.in | 21 +++++++++++++
- 7 files changed, 141 insertions(+), 13 deletions(-)
-
diff --git a/configure.ac b/configure.ac
-index dd2fbd01c..e508f9c43 100644
+index d3ca0a1..cc2ef03 100644
--- a/configure.ac
+++ b/configure.ac
-@@ -1841,6 +1841,17 @@ else
+@@ -1915,6 +1915,17 @@ else
fi
AC_SUBST([QUIET_BOOT])
@@ -56,10 +21,10 @@ index dd2fbd01c..e508f9c43 100644
AC_SUBST([FONT_SOURCE])
diff --git a/docs/grub.texi b/docs/grub.texi
-index e935af33e..5b2a7bbb2 100644
+index f8b4b3b..0b58daf 100644
--- a/docs/grub.texi
+++ b/docs/grub.texi
-@@ -1490,6 +1490,20 @@ This option may be set to a list of GRUB module names separated by spaces.
+@@ -1563,6 +1563,20 @@ This option may be set to a list of GRUB module names separated by spaces.
Each module will be loaded as early as possible, at the start of
@file{grub.cfg}.
@@ -81,10 +46,10 @@ index e935af33e..5b2a7bbb2 100644
The following options are still accepted for compatibility with existing
diff --git a/grub-core/normal/menu.c b/grub-core/normal/menu.c
-index 1f3447ad3..906a480a2 100644
+index 338f5a5..101aa80 100644
--- a/grub-core/normal/menu.c
+++ b/grub-core/normal/menu.c
-@@ -604,6 +604,30 @@ run_menu (grub_menu_t menu, int nested, int *auto_boot)
+@@ -603,6 +603,30 @@ run_menu (grub_menu_t menu, int nested, int *auto_boot)
static struct grub_term_coordinate *pos;
int entry = -1;
@@ -116,10 +81,10 @@ index 1f3447ad3..906a480a2 100644
{
pos = grub_term_save_pos ();
diff --git a/util/grub-mkconfig.in b/util/grub-mkconfig.in
-index b4f0011b5..fac560464 100644
+index 17269b3..92e640c 100644
--- a/util/grub-mkconfig.in
+++ b/util/grub-mkconfig.in
-@@ -239,7 +239,8 @@ export GRUB_DEFAULT \
+@@ -253,7 +253,8 @@ export GRUB_DEFAULT \
GRUB_ENABLE_CRYPTODISK \
GRUB_BADRAM \
GRUB_OS_PROBER_SKIP_LIST \
@@ -130,7 +95,7 @@ index b4f0011b5..fac560464 100644
if test "x${grub_cfg}" != "x"; then
rm -f "${grub_cfg}.new"
diff --git a/util/grub.d/00_header.in b/util/grub.d/00_header.in
-index 93a90233e..674a76140 100644
+index c5955df..d660755 100644
--- a/util/grub.d/00_header.in
+++ b/util/grub.d/00_header.in
@@ -21,6 +21,8 @@ prefix="@prefix@"
@@ -201,7 +166,7 @@ index 93a90233e..674a76140 100644
function load_video {
EOF
if [ -n "${GRUB_VIDEO_BACKEND}" ]; then
-@@ -282,10 +328,16 @@ fi
+@@ -290,10 +336,16 @@ fi
make_timeout ()
{
@@ -219,7 +184,7 @@ index 93a90233e..674a76140 100644
# Handle the deprecated GRUB_HIDDEN_TIMEOUT scheme.
timeout="${1}"
if [ "x${2}" != "x0" ] ; then
-@@ -304,26 +356,27 @@ make_timeout ()
+@@ -312,26 +364,27 @@ make_timeout ()
style="menu"
fi
cat << EOF
@@ -259,18 +224,18 @@ index 93a90233e..674a76140 100644
EOF
}
diff --git a/util/grub.d/10_linux.in b/util/grub.d/10_linux.in
-index 67d57ecfd..0f8a16837 100644
+index e0c22fc..9c992c6 100644
--- a/util/grub.d/10_linux.in
+++ b/util/grub.d/10_linux.in
-@@ -22,6 +22,7 @@ exec_prefix="@exec_prefix@"
+@@ -21,6 +21,7 @@ prefix="@prefix@"
+ exec_prefix="@exec_prefix@"
datarootdir="@datarootdir@"
- ubuntu_recovery="@UBUNTU_RECOVERY@"
quiet_boot="@QUIET_BOOT@"
+quick_boot="@QUICK_BOOT@"
. "$pkgdatadir/grub-mkconfig_lib"
-@@ -119,6 +120,9 @@ linux_entry ()
+@@ -109,6 +110,9 @@ linux_entry ()
else
echo "menuentry '$(echo "$os" | grub_quote)' ${CLASS} \$menuentry_id_option 'gnulinux-simple-$boot_device_id' {" | sed "s/^/$submenu_indentation/"
fi
@@ -281,7 +246,7 @@ index 67d57ecfd..0f8a16837 100644
save_default_entry | grub_add_tab
fi
diff --git a/util/grub.d/30_os-prober.in b/util/grub.d/30_os-prober.in
-index 271044f59..da5f28876 100644
+index 5984e92..e694e33 100644
--- a/util/grub.d/30_os-prober.in
+++ b/util/grub.d/30_os-prober.in
@@ -20,12 +20,26 @@ set -e
@@ -309,9 +274,9 @@ index 271044f59..da5f28876 100644
+}
+
if [ "x${GRUB_DISABLE_OS_PROBER}" = "xtrue" ]; then
+ grub_warn "$(gettext_printf "os-prober will not be executed to detect other bootable partitions.\nSystems on them will not be added to the GRUB boot configuration.\nCheck GRUB_DISABLE_OS_PROBER documentation entry.")"
exit 0
- fi
-@@ -42,6 +56,7 @@ if [ -z "${OSPROBED}" ] ; then
+@@ -45,6 +59,7 @@ if [ -z "${OSPROBED}" ] ; then
fi
osx_entry() {
@@ -319,15 +284,15 @@ index 271044f59..da5f28876 100644
if [ x$2 = x32 ]; then
# TRANSLATORS: it refers to kernel architecture (32-bit)
bitstr="$(gettext "(32-bit)")"
-@@ -165,6 +180,7 @@ for OS in ${OSPROBED} ; do
- ;;
- esac
+@@ -149,6 +164,7 @@ for OS in ${OSPROBED} ; do
+ case ${BOOT} in
+ chain)
+ found_other_os=1
onstr="$(gettext_printf "(on %s)" "${DEVICE}")"
cat << EOF
menuentry '$(echo "${LONGNAME} $onstr" | grub_quote)' $CLASS --class os \$menuentry_id_option 'osprober-chain-$(grub_get_device_id "${DEVICE}")' {
-@@ -195,6 +211,7 @@ EOF
+@@ -179,6 +195,7 @@ EOF
;;
efi)
@@ -335,15 +300,15 @@ index 271044f59..da5f28876 100644
EFIPATH=${DEVICE#*@}
DEVICE=${DEVICE%@*}
onstr="$(gettext_printf "(on %s)" "${DEVICE}")"
-@@ -243,6 +260,7 @@ EOF
- [ "${prepare_boot_cache}" ] || continue
+@@ -222,6 +239,7 @@ EOF
+ LINITRD="${LINITRD#/boot}"
fi
+ found_other_os=1
onstr="$(gettext_printf "(on %s)" "${DEVICE}")"
- recovery_params="$(echo "${LPARAMS}" | grep 'single\|recovery')" || true
+ recovery_params="$(echo "${LPARAMS}" | grep single)" || true
counter=1
-@@ -311,6 +329,7 @@ EOF
+@@ -302,6 +320,7 @@ EOF
fi
;;
hurd)
@@ -351,7 +316,7 @@ index 271044f59..da5f28876 100644
onstr="$(gettext_printf "(on %s)" "${DEVICE}")"
cat << EOF
menuentry '$(echo "${LONGNAME} $onstr" | grub_quote)' --class hurd --class gnu --class os \$menuentry_id_option 'osprober-gnuhurd-/boot/gnumach.gz-false-$(grub_get_device_id "${DEVICE}")' {
-@@ -353,3 +372,5 @@ EOF
+@@ -344,3 +363,5 @@ EOF
;;
esac
done
diff --git a/PKGBUILD b/PKGBUILD
index 93bb4ab2c4e7..61135a9a218e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -24,7 +24,7 @@ _GRUB_EXTRAS_COMMIT="8a245d5c1800627af4cefa99162a89c7a46d8842"
pkgname="grub-silent"
pkgdesc="GNU GRand Unified Bootloader (2) [without welcome and kernel messages]"
pkgver=2.06
-pkgrel=1
+pkgrel=2
url="https://www.gnu.org/software/grub/"
arch=('x86_64' 'i686')
license=('GPL3')
@@ -66,12 +66,12 @@ source=("https://ftp.gnu.org/gnu/${pkgname%-*}/${pkgname%-*}-${pkgver}.tar.xz"
sha256sums=('b79ea44af91b93d17cd3fe80bdae6ed43770678a9a5ae192ccea803ebb657ee1'
'fb6b37db9b14fd03e4d26775d84b570fbe91d4ea5de3df4e31114d79a2dfa97e'
'd101e9d33fbc67f7aaf6fb1191ec1315e8e5572c1d0538b95746ee194b8860db'
- 'b6e1c57dc9632ddf14e0acd96c5182cb4491994b67765cb11518d1356b603879'
- 'f77417646a5480623f61006304bf68e3a733e77642978af949d4452f36e3203a'
+ '21153ab7f020d9f819a70b9c879b29e9709996c5b0304816123c09b6849f95a3'
+ '6fa180674094f9e1723f736d458f1fe0b5740ea7cf5db5064139defc17ce0e94'
'39d7843dfe1e10ead912a81be370813b8621794a7967b3cc5e4d4188b5bf7264'
- '4b189e00a8c97ec09903e9588e02fc78b4bb114ee4822fcce13811aca00c8884'
- 'b7489c7facc4fb3dad4426c9c00079b64908640a2bec2409e22194daa3f72af4'
- '1723340737b91a5bf503829bbe66b1c56683ef0e533f20d18b7098840aecb3a2'
+ 'c4cb3aa5ed535c7f3a3f784a779ea0a02bfed0ac54f202387a18de04dda8297f'
+ 'fe2871773868fdbb9523661fd67e38a60d3cf1eb51f6964beb839105dfa8ec3e'
+ '7769a65321d1611217d6af47c1c3fe91ce2f97adcfd58c4e0d2e0bb06b39100e'
'4f2e9d585b7b0ef8ce0d09e88391d1397b50883c7cb1516dc99785934abe15a2')
prepare() {