summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorpzl2015-08-08 11:53:44 -0400
committerpzl2015-08-08 11:53:44 -0400
commitebd307bef13f848794efc7611f8f458f7ca01fe2 (patch)
treeaeda0e56db63ae67a34e7ef1db5c8dc8f8ffa948
downloadaur-ebd307bef13f848794efc7611f8f458f7ca01fe2.tar.gz
move this package into aur4/git
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD27
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1a230d1690be
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = python2-cairosvg
+ pkgdesc = A Simple SVG Converter for Cairo
+ pkgver = 1.0.9
+ pkgrel = 1
+ url = http://cairosvg.org/
+ arch = any
+ license = LGPL3
+ depends = python2
+ depends = python2-cairo
+ optdepends = python2-lxml: To use lxml to parse SVG files
+ optdepends = python2-tinycss: Apply CSS not included in the style attribute of the tags
+ optdepends = python2-cssselect: Apply CSS not included in the style attribute of the tags
+ optdepends = python2-pillow: To handle embedded raster images other than PNG
+ source = http://pypi.python.org/packages/source/C/CairoSVG/CairoSVG-1.0.9.tar.gz
+ md5sums = 4a15e7cf8debd205f6a9cc4b17c2e411
+
+pkgname = python2-cairosvg
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7f3234c32a53
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: pzl <alsoelp@gmail.com>
+# Contributor: Dennis Fink <dennis.fink@c3l.lu>
+# Submitter: Simon Sapin <simon dot sapin at exyr dot org>
+pkgname=python2-cairosvg
+pkgver=1.0.9
+pkgrel=1
+pkgdesc="A Simple SVG Converter for Cairo"
+arch=('any')
+url="http://cairosvg.org/"
+license=('LGPL3')
+depends=('python2' 'python2-cairo')
+optdepends=('python2-lxml: To use lxml to parse SVG files'
+'python2-tinycss: Apply CSS not included in the style attribute of the tags'
+'python2-cssselect: Apply CSS not included in the style attribute of the tags'
+'python2-pillow: To handle embedded raster images other than PNG')
+source=("http://pypi.python.org/packages/source/C/CairoSVG/CairoSVG-${pkgver}.tar.gz")
+md5sums=('4a15e7cf8debd205f6a9cc4b17c2e411')
+
+build() {
+ cd "$srcdir/CairoSVG-$pkgver"
+ python2 setup.py build
+}
+
+package() {
+ cd "$srcdir/CairoSVG-$pkgver"
+ python2 setup.py install --root="$pkgdir/" --optimize=1
+}