summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJon Eyolfson2015-08-11 09:37:34 -0400
committerJon Eyolfson2015-08-11 09:37:34 -0400
commitebec7b19fcde95a4c41954292f64517814a7a378 (patch)
tree716805e9b213cacaaaac0f6e7753fd2a27ab82ae
downloadaur-ebec7b19fcde95a4c41954292f64517814a7a378.tar.gz
Initial import
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD28
-rw-r--r--emacs-undo-tree.install11
3 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f6207f737191
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = emacs-undo-tree
+ pkgdesc = Replace Emacs' undo system with an intuitive tree-based system.
+ pkgver = 0.6.4
+ pkgrel = 1
+ url = http://www.dr-qubit.org/emacs.php#undo-tree
+ install = emacs-undo-tree.install
+ arch = any
+ license = GPL
+ depends = emacs
+ provides = emacs-undo-tree
+ conflicts = emacs-undo-tree
+ source = http://www.dr-qubit.org/undo-tree/undo-tree-0.6.4.el
+ sha1sums = 117764e599bcacd3e364e071854f53aeec33ef09
+
+pkgname = emacs-undo-tree
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4fa955e62fca
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Contributor: listx <linusarver <at> gmail <dot> com>
+pkgname=emacs-undo-tree
+pkgver=0.6.4
+pkgrel=1
+pkgdesc="Replace Emacs' undo system with an intuitive tree-based system."
+arch=('any')
+url="http://www.dr-qubit.org/emacs.php#undo-tree"
+depends=('emacs')
+license=('GPL')
+provides=('emacs-undo-tree')
+conflicts=('emacs-undo-tree')
+install=$pkgname.install
+source=(http://www.dr-qubit.org/undo-tree/undo-tree-${pkgver}.el)
+sha1sums=('117764e599bcacd3e364e071854f53aeec33ef09')
+
+build() {
+ # rename to just undo-tree.el
+ mv undo-tree-${pkgver}.el undo-tree.el
+ # compile for speed
+ emacs -batch -f batch-byte-compile undo-tree.el
+}
+
+package() {
+ # create destination path
+ install -d $pkgdir/usr/share/emacs/site-lisp
+ # copy over file into path
+ cp $srcdir/undo-tree.{el,elc} $pkgdir/usr/share/emacs/site-lisp
+}
diff --git a/emacs-undo-tree.install b/emacs-undo-tree.install
new file mode 100644
index 000000000000..d79aff08507a
--- /dev/null
+++ b/emacs-undo-tree.install
@@ -0,0 +1,11 @@
+# Message displayed after a fresh install.
+post_install() {
+ echo "Add these lines to ~/.emacs:"
+ echo " (require 'undo-tree)"
+}
+
+# Message displayed afteer package removal.
+post_remove() {
+ echo "Remove these lines from ~/.emacs:"
+ echo " (require 'undo-tree)"
+}