summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorZeke Sonxx2017-06-29 22:35:29 -0400
committerZeke Sonxx2017-06-29 22:35:29 -0400
commitebeda9d62fb63e09308f40790a4f0a621aef7df7 (patch)
tree788d74883f2ff65e68360cf14a81c7001cdf96e3
downloadaur-ebeda9d62fb63e09308f40790a4f0a621aef7df7.tar.gz
Initial commit with r147
-rw-r--r--.SRCINFO21
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD46
-rw-r--r--blt4l.install7
4 files changed, 78 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ea287bd9327a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = blt4l-git
+ pkgdesc = Mod loader for Payday 2 (non-Steam runtime only)
+ pkgver = r147.95e1458
+ pkgrel = 1
+ url = https://github.com/blt4linux/blt4l
+ install = blt4l.install
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ makedepends = cmake
+ makedepends = libc++
+ depends = curl
+ depends = openssl
+ depends = zlib
+ conflicts = blt4l
+ source = blt4l::git+https://github.com/blt4linux/blt4l
+ md5sums = SKIP
+
+pkgname = blt4l-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..ba9a49a3b60a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+blt4l
+src
+pkg
+*.pkg.*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..71e25d54fdd5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# shellcheck shell=bash
+# shellcheck disable=SC2034,SC2148,SC2154
+# Maintainer: Zeke Sonxx <zeke@zekesonxx.com>
+
+pkgname=blt4l-git
+pkgver=r147.95e1458
+pkgrel=1
+pkgdesc="Mod loader for Payday 2 (non-Steam runtime only)"
+arch=('i686' 'x86_64')
+url="https://github.com/blt4linux/blt4l"
+license=('GPL3')
+groups=()
+depends=('curl' 'openssl' 'zlib')
+makedepends=('git' 'cmake' 'libc++')
+provides=()
+conflicts=("blt4l")
+replaces=()
+backup=()
+options=()
+install=blt4l.install
+source=("blt4l::git+https://github.com/blt4linux/blt4l")
+noextract=()
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/${pkgname%-git}" || exit
+ # Git, tags available
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd "$srcdir/blt4l" || exit
+ git submodule init
+ git submodule update
+}
+
+build() {
+ mkdir -p "$srcdir/build"
+ cd "$srcdir/build" || exit
+ cmake -DUSE_LIBCXX=ON "$srcdir/blt4l"
+ make
+}
+
+package() {
+ install -D -m644 "${srcdir}/build/libblt_loader.so" "${pkgdir}/usr/lib/blt4l/libblt_loader.so"
+}
diff --git a/blt4l.install b/blt4l.install
new file mode 100644
index 000000000000..592193828891
--- /dev/null
+++ b/blt4l.install
@@ -0,0 +1,7 @@
+post_install() {
+ echo "Your installation of blt4l is not yet done!
+You'll need to set launch options in Steam for Payday 2:
+LD_PRELOAD=\"\$LD_PRELOAD /usr/lib/blt4l/libblt_loader.so\" %command%
+And install the base Lua code, instructions here:
+https://github.com/blt4linux/blt4l"
+}