summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTimothée Ravier2013-11-03 19:42:41 +0100
committerTimothée Ravier2013-11-03 19:42:41 +0100
commitebf67fe87c9e996dac6039853545f8107153427d (patch)
tree078cc08bb990f8b957419bfd31db1369edc35c3f
downloadaur-ebf67fe87c9e996dac6039853545f8107153427d.tar.gz
General update: SELinux userspace & pkg renaming
-rw-r--r--.SRCINFO35
-rw-r--r--PKGBUILD68
-rw-r--r--deny1
-rw-r--r--pam.d10
-rw-r--r--service11
5 files changed, 125 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c1b69c3a0ecc
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,35 @@
+pkgbase = cronie-selinux
+ pkgdesc = Daemon that runs specified programs at scheduled times and related tools wth SELinux support
+ pkgver = 1.4.9
+ pkgrel = 5
+ url = https://fedorahosted.org/cronie/
+ arch = i686
+ arch = x86_64
+ groups = selinux
+ license = custom:BSD
+ depends = pam
+ depends = bash
+ depends = run-parts
+ depends = libselinux
+ optdepends = pm-utils: defer anacron on battery power
+ optdepends = smtp-server: send job output via email
+ optdepends = smtp-forwarder: forward job output to email server
+ provides = cron
+ provides = cronie=1.4.9-5
+ conflicts = cron
+ conflicts = cronie
+ backup = etc/cron.deny
+ backup = etc/pam.d/crond
+ backup = etc/cron.d/0hourly
+ backup = etc/anacrontab
+ source = https://fedorahosted.org/releases/c/r/cronie/cronie-1.4.9.tar.gz
+ source = service
+ source = pam.d
+ source = deny
+ sha1sums = 40405cb30b62bd60323e4daf5198f26f0e65c4c4
+ sha1sums = eb8ed1e22dbe9c02075fe4bbe925b6eeb9954649
+ sha1sums = 5eff7fb31f6bc0a924243ff046704726cf20c221
+ sha1sums = 0f279b8fb820340267d578dc85511c980715f91e
+
+pkgname = cronie-selinux
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ea4bd4cb2225
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,68 @@
+# Maintainer: Gaetan Bisson <bisson@archlinux.org>
+# Contributor: Kaiting Chen <kaiting.chen@kiwilight.com>
+# SELinux Maintainer: Timothée Ravier <tim@siosm.fr>
+# SELinux Contributor: Nicky726 <Nicky726@gmail.com>
+
+pkgname=cronie-selinux
+pkgver=1.4.9
+pkgrel=5
+pkgdesc='Daemon that runs specified programs at scheduled times and related tools wth SELinux support'
+url='https://fedorahosted.org/cronie/'
+license=('custom:BSD')
+arch=('i686' 'x86_64')
+depends=('pam' 'bash' 'run-parts' 'libselinux')
+optdepends=('pm-utils: defer anacron on battery power'
+ 'smtp-server: send job output via email'
+ 'smtp-forwarder: forward job output to email server')
+source=("https://fedorahosted.org/releases/c/r/${pkgname/-selinux}/${pkgname/-selinux}-${pkgver}.tar.gz"
+ 'service'
+ 'pam.d'
+ 'deny')
+sha1sums=('40405cb30b62bd60323e4daf5198f26f0e65c4c4'
+ 'eb8ed1e22dbe9c02075fe4bbe925b6eeb9954649'
+ '5eff7fb31f6bc0a924243ff046704726cf20c221'
+ '0f279b8fb820340267d578dc85511c980715f91e')
+
+backup=('etc/cron.deny'
+ 'etc/pam.d/crond'
+ 'etc/cron.d/0hourly'
+ 'etc/anacrontab')
+
+conflicts=('cron' "${pkgname/-selinux}")
+provides=('cron' "${pkgname/-selinux}=${pkgver}-${pkgrel}")
+groups=('selinux')
+
+build() {
+ cd ${pkgname/-selinux}-${pkgver}
+ ./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --sbindir=/usr/bin \
+ --enable-anacron \
+ --with-inotify \
+ --with-pam \
+ --with-selinux
+
+ make
+}
+
+package() {
+ cd ${pkgname/-selinux}-${pkgver}
+
+ make DESTDIR="${pkgdir}" install
+
+ chmod u+s "${pkgdir}"/usr/bin/crontab
+ install -d "${pkgdir}"/var/spool/{ana,}cron
+ install -d "${pkgdir}"/etc/cron.{d,hourly,daily,weekly,monthly}
+
+ install -Dm644 ../deny "${pkgdir}"/etc/cron.deny
+ install -Dm644 ../pam.d "${pkgdir}"/etc/pam.d/crond
+ install -Dm644 ../service "${pkgdir}"/usr/lib/systemd/system/cronie.service
+
+ install -Dm644 contrib/anacrontab "${pkgdir}"/etc/anacrontab
+ install -Dm644 contrib/0hourly "${pkgdir}"/etc/cron.d/0hourly
+ install -Dm755 contrib/0anacron "${pkgdir}"/etc/cron.hourly/0anacron
+
+ install -Dm644 COPYING "${pkgdir}"/usr/share/licenses/cronie/COPYING
+}
diff --git a/deny b/deny
new file mode 100644
index 000000000000..06e685cc8889
--- /dev/null
+++ b/deny
@@ -0,0 +1 @@
+# without this file, only users listed in /etc/cron.allow can use crontab
diff --git a/pam.d b/pam.d
new file mode 100644
index 000000000000..9a254ebc0d42
--- /dev/null
+++ b/pam.d
@@ -0,0 +1,10 @@
+auth required pam_unix.so
+auth required pam_env.so
+
+account required pam_access.so
+account required pam_unix.so
+account required pam_time.so
+
+session required pam_loginuid.so
+session required pam_limits.so
+session required pam_unix.so
diff --git a/service b/service
new file mode 100644
index 000000000000..84145251c60a
--- /dev/null
+++ b/service
@@ -0,0 +1,11 @@
+[Unit]
+Description=Periodic Command Scheduler
+
+[Service]
+ExecStart=/usr/bin/crond -n
+ExecReload=/usr/bin/kill -HUP $MAINPID
+KillMode=process
+Restart=always
+
+[Install]
+WantedBy=multi-user.target