summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJan Bader2015-06-27 01:52:40 +0200
committerJan Bader2015-06-27 01:54:52 +0200
commitec2f69cdad3dbbd284786601eb4f8439b1fa2846 (patch)
tree41991c67fd6619fce637c8c6155c67e912ba2206
downloadaur-ec2f69cdad3dbbd284786601eb4f8439b1fa2846.tar.gz
Initial
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD33
-rw-r--r--ynab411
3 files changed, 69 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..81508dd994f0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = ynab4
+ pkgdesc = You Need A Budget, installs with wine
+ pkgver = 4.3.729
+ pkgrel = 1
+ url = http://youneedabudget.com/
+ arch = x86_64
+ license = unknown
+ depends = wine
+ depends = lib32-lcms
+ depends = lib32-lcms2
+ depends = wine-mono
+ depends = wine_gecko
+ depends = lib32-gnutls
+ depends = lib32-mpg123
+ depends = lib32-ncurses
+ depends = winetricks
+ depends = samba
+ noextract = Setup.exe
+ source = ynab4
+ source = Setup.exe::http://www.youneedabudget.com/CDNOrigin/download/ynab4/liveCaptive/Win/YNAB%204_4.3.729_Setup.exe
+ md5sums = c981e554bb249a3ce4d374e868f4f765
+ md5sums = 0a5df8a115193fe68c4fb5e1cae55326
+
+pkgname = ynab4
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9d30e3944e76
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Jan Bader <c.arch@jan.javil.eu>
+pkgname="ynab4"
+pkgver="4.3.729"
+pkgrel=1
+epoch=
+pkgdesc="You Need A Budget, installs with wine"
+arch=("x86_64")
+url="http://youneedabudget.com/"
+license=('unknown')
+groups=()
+depends=('wine' 'lib32-lcms' 'lib32-lcms2' 'wine-mono' 'wine_gecko' 'lib32-gnutls' 'lib32-mpg123' 'lib32-ncurses' 'winetricks' 'samba')
+makedepends=()
+checkdepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=(ynab4 "Setup.exe::http://www.youneedabudget.com/CDNOrigin/download/$pkgname/liveCaptive/Win/YNAB%204_${pkgver}_Setup.exe")
+noextract=("Setup.exe")
+md5sums=("c981e554bb249a3ce4d374e868f4f765"
+ "0a5df8a115193fe68c4fb5e1cae55326")
+
+package() {
+ install -d -m755 "$pkgdir"/usr/share/ynab4
+ cp -ra "$srcdir"/Setup.exe "$pkgdir"/usr/share/ynab4
+
+ install -d -m755 "$pkgdir"/usr/bin
+ install -m755 ynab4 "$pkgdir"/usr/bin
+}
diff --git a/ynab4 b/ynab4
new file mode 100644
index 000000000000..c9046d145f58
--- /dev/null
+++ b/ynab4
@@ -0,0 +1,11 @@
+#!/bin/bash
+
+export WINEARCH=win64 WINEPREFIX="$HOME/.ynab4/wine"
+
+if [ ! -d "$HOME"/.ynab4 ] ; then
+ mkdir -p "$HOME"/.ynab4/wine || exit 1
+ wine /usr/share/ynab4/Setup.exe || exit1
+ winetricks corefonts || exit 1
+fi
+
+wine "$HOME"/.ynab4/wine/drive_c/Program\ Files\ \(x86\)/YNAB\ 4/YNAB\ 4.exe