summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsmls2015-07-09 16:46:42 +0200
committersmls2015-07-09 16:46:42 +0200
commitec4cd19d138ebc4ffbc855515247a4e56435fbd0 (patch)
treed65da7ffe1f4bc6e669140d297a45205637218e6
downloadaur-ec4cd19d138ebc4ffbc855515247a4e56435fbd0.tar.gz
Initial import
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD50
-rw-r--r--avirusnamedtom-hib.desktop10
3 files changed, 83 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..40041efed981
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = avirusnamedtom-hib
+ pkgdesc = A Virus Named TOM, a fast-paced action-puzzler (Humble Bundle version)
+ pkgver = 0+h20131019
+ pkgrel = 1
+ url = http://www.avirusnamedtom.com/
+ arch = i686
+ arch = x86_64
+ license = custom: commercial
+ makedepends = imagemagick
+ depends = sdl2
+ depends = openal
+ depends = gcc-libs
+ depends = libvorbis
+ depends = libtheora
+ options = !strip
+ options = !upx
+ source = hib://avnt-10192013-bin
+ source = avirusnamedtom-hib.desktop
+ md5sums = 4431412ea1ec5164ab63924161c8b4b4
+ md5sums = 1d68b4a3457c20486796c3e3f01dc88f
+
+pkgname = avirusnamedtom-hib
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3c16ac7e903e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,50 @@
+# Maintainer: Sam S. <smls75@gmail.com>
+
+pkgname=avirusnamedtom-hib
+pkgver=0+h20131019
+_hibver=10192013
+pkgrel=1
+pkgdesc='A Virus Named TOM, a fast-paced action-puzzler (Humble Bundle version)'
+url='http://www.avirusnamedtom.com/'
+arch=('i686' 'x86_64')
+license=('custom: commercial')
+depends=('sdl2' 'openal' 'gcc-libs' 'libvorbis' 'libtheora')
+makedepends=('imagemagick')
+options=('!strip' '!upx')
+PKGEXT='.pkg.tar.gz'
+DLAGENTS+=('hib::/usr/bin/echo "Could not find %u. Manually download it to \"$(pwd)\", or set up a hib:// DLAGENT in /etc/makepkg.conf."; exit 1')
+
+_archive="avnt-${_hibver}-bin"
+source=("hib://$_archive"
+ 'avirusnamedtom-hib.desktop')
+md5sums=('4431412ea1ec5164ab63924161c8b4b4'
+ '1d68b4a3457c20486796c3e3f01dc88f')
+
+build() {
+ convert "data/A Virus Named TOM.bmp" icon.png
+}
+
+package() {
+ cd "$srcdir"
+ [ $CARCH == "i686" ] && { _arch=x86 && _other=x86_64 && _libother=64 ;} \
+ || { _arch=x86_64 && _other=x86 && _libother= ;}
+ _target=/opt/AVirusNamedTOM
+
+ # Install game files
+ mkdir -p "$pkgdir/$_target"
+ cp -TRl data "$pkgdir/$_target"
+
+ # Remove unneeded files
+ rm -r "$pkgdir/$_target"/lib$_libother
+ rm "$pkgdir/$_target"/lib*/lib{SDL*,openal*,ogg*,vorbis*,theora{.so.0,dec.so.1}}
+ rm "$pkgdir/$_target"/{AVirusNamedTOM,CircuitGame.bin.$_other}
+
+ # Install icon & desktop entry
+ install -Dm644 icon.png "$pkgdir"/usr/share/pixmaps/avirusnamedtom.png
+ install -Dm644 $pkgname.desktop "$pkgdir"/usr/share/applications/$pkgname.desktop
+
+ # Install launch script
+ echo -e "#!/bin/sh\n" \
+ "cd $_target && exec ./CircuitGame.bin.$_arch \$*" > launcher.sh
+ install -Dm755 launcher.sh "$pkgdir"/usr/bin/avirusnamedtom
+}
diff --git a/avirusnamedtom-hib.desktop b/avirusnamedtom-hib.desktop
new file mode 100644
index 000000000000..405144e0f49f
--- /dev/null
+++ b/avirusnamedtom-hib.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Version=1.0
+Type=Application
+Categories=Game;
+Name=A Virus Named TOM
+Comment=Misfits Attic
+GenericName=Action-Puzzle Game
+Icon=avirusnamedtom
+Exec=/usr/bin/avirusnamedtom
+Terminal=false