summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoan Figueras2016-02-12 16:18:24 +0100
committerJoan Figueras2016-02-12 16:18:24 +0100
commitec500c08b4a229f8126a2c9a53fbe1826bd3716a (patch)
treefd04eddde016759b97eb54190660b3c12a84040c
parente0210f8a40e023ca23163c50c0a91f72107df808 (diff)
downloadaur-ec500c08b4a229f8126a2c9a53fbe1826bd3716a.tar.gz
Added i686 arch and added linux-headers as a dependency
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD39
2 files changed, 45 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2df427deba32..6c13c03667d0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,31 @@
+# Generated by mksrcinfo v8
+# Fri Feb 12 15:17:49 UTC 2016
pkgbase = cubieboard-livesuit
pkgdesc = LiveSuit is a tool to flash Images to the NAND of Allwinner devices, such as Cubieboard1, Cubieboard2, and Cubietruck. This package use the ZIP that comes from official Cubieboard download page.
pkgver = 306
- pkgrel = 1
+ pkgrel = 2
url = http://cubieboard.org
install = cubieboard-livesuit.install
+ arch = i686
arch = x86_64
license = GPL
makedepends = git
makedepends = dkms
depends = libpng12
depends = qt4
- source = cubieboard-livesuit::git+https://github.com/linux-sunxi/sunxi-livesuite.git
- source = http://dl.cubieboard.org/software/tools/livesuit/LiveSuitV306_For_Linux64.zip
- source = 50-awusb.rules
- sha256sums = SKIP
- sha256sums = 12c042080e6b49e3edff7052cbb9ff0a89badce12be04d1443b1c9d5163d9bf3
- sha256sums = 21e03a459c30fbf92bef5b086f8c93c6ac7071d97e7855dce7627e624969081f
+ depends = linux-headers
+ source_i686 = cubieboard-livesuit::git+https://github.com/linux-sunxi/sunxi-livesuite.git
+ source_i686 = http://dl.cubieboard.org/software/tools/livesuit/LiveSuitV306_For_Linux32.zip
+ source_i686 = 50-awusb.rules
+ sha256sums_i686 = SKIP
+ sha256sums_i686 = 91553f7dc0a8dc467a6f584b8faea73ddbd6fa6ba39fb3701d208d519a7173be
+ sha256sums_i686 = 21e03a459c30fbf92bef5b086f8c93c6ac7071d97e7855dce7627e624969081f
+ source_x86_64 = cubieboard-livesuit::git+https://github.com/linux-sunxi/sunxi-livesuite.git
+ source_x86_64 = http://dl.cubieboard.org/software/tools/livesuit/LiveSuitV306_For_Linux64.zip
+ source_x86_64 = 50-awusb.rules
+ sha256sums_x86_64 = SKIP
+ sha256sums_x86_64 = 12c042080e6b49e3edff7052cbb9ff0a89badce12be04d1443b1c9d5163d9bf3
+ sha256sums_x86_64 = 21e03a459c30fbf92bef5b086f8c93c6ac7071d97e7855dce7627e624969081f
pkgname = cubieboard-livesuit
diff --git a/PKGBUILD b/PKGBUILD
index 63c516fcab6d..2067d596fabe 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,27 +3,39 @@
pkgname=cubieboard-livesuit
pkgver=306
-pkgrel=1
+pkgrel=2
pkgdesc="LiveSuit is a tool to flash Images to the NAND of Allwinner devices, such as Cubieboard1, Cubieboard2, and Cubietruck. This package use the ZIP that comes from official Cubieboard download page."
-arch=('x86_64')
+arch=('i686' 'x86_64')
url="http://cubieboard.org"
license=('GPL')
-depends=('libpng12' 'qt4')
+depends=('libpng12' 'qt4' 'linux-headers')
makedepends=('git' 'dkms')
conflicts=()
install=${pkgname}.install
-source=("${pkgname}"::'git+https://github.com/linux-sunxi/sunxi-livesuite.git'
+source_x86_64=("${pkgname}"::'git+https://github.com/linux-sunxi/sunxi-livesuite.git'
"http://dl.cubieboard.org/software/tools/livesuit/LiveSuitV${pkgver}_For_Linux64.zip"
"50-awusb.rules")
-sha256sums=('SKIP'
- '12c042080e6b49e3edff7052cbb9ff0a89badce12be04d1443b1c9d5163d9bf3'
- '21e03a459c30fbf92bef5b086f8c93c6ac7071d97e7855dce7627e624969081f')
+
+source_i686=("${pkgname}"::'git+https://github.com/linux-sunxi/sunxi-livesuite.git'
+ "http://dl.cubieboard.org/software/tools/livesuit/LiveSuitV${pkgver}_For_Linux32.zip"
+ "50-awusb.rules")
+
+sha256sums_i686=('SKIP'
+ '91553f7dc0a8dc467a6f584b8faea73ddbd6fa6ba39fb3701d208d519a7173be'
+ '21e03a459c30fbf92bef5b086f8c93c6ac7071d97e7855dce7627e624969081f')
+sha256sums_x86_64=('SKIP'
+ '12c042080e6b49e3edff7052cbb9ff0a89badce12be04d1443b1c9d5163d9bf3'
+ '21e03a459c30fbf92bef5b086f8c93c6ac7071d97e7855dce7627e624969081f')
build() {
# LiveSuit
- cd ${srcdir}/LiveSuit_For_Linux64
+ if [ "$CARCH" = "x86_64" ]; then
+ cd ${srcdir}/LiveSuit_For_Linux64
+ elif [ "$CARCH" = "i686" ]; then
+ cd ${srcdir}/LiveSuit_For_Linux32
+ fi
tail -n +60 LiveSuit.run > LiveSuit.tar.bz2
- tar xjvf LiveSuit.tar.bz2
+ tar xjvf LiveSuit.tar.bz2
# Kernel module awusb
cd ${srcdir}/${pkgname}/awusb
@@ -32,8 +44,12 @@ build() {
package() {
# LiveSuit
- cd ${srcdir}/LiveSuit_For_Linux64
- mkdir -p "${pkgdir}/opt/${pkgname}"
+ if [ "$CARCH" = "x86_64" ]; then
+ cd ${srcdir}/LiveSuit_For_Linux64
+ elif [ "$CARCH" = "i686" ]; then
+ cd ${srcdir}/LiveSuit_For_Linux32
+ fi
+ mkdir -p "${pkgdir}/opt/${pkgname}"
cp -r LiveSuit/* ${pkgdir}/opt/${pkgname}/
# Kernel module awusb
@@ -41,3 +57,4 @@ package() {
cp ${srcdir}/${pkgname}/awusb/awusb.ko ${pkgdir}/usr/lib/modules/`uname -r`/kernel/
cp ${srcdir}/50-awusb.rules ${pkgdir}/etc/udev/rules.d/
}
+