summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfrealgagu2020-07-14 19:18:52 -0500
committerfrealgagu2020-07-14 19:18:52 -0500
commitec5d4b39af174578845420c0d7c3f0512d0007ae (patch)
treeca1dbee25ebafa9a37d54a11ae1239851f6796e8
parent92185b19ff63d6afb8e5a7e0b44dfec8cc177fe3 (diff)
downloadaur-ec5d4b39af174578845420c0d7c3f0512d0007ae.tar.gz
Adding group flutterusers at post_install. Changing dependency from lib32-libglvnd to libglvnd.
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD4
-rw-r--r--flutter.install20
3 files changed, 12 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index dccec059bff4..db0fc5966749 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = flutter-git
pkgdesc = A new mobile app SDK to help developers and designers build modern mobile apps for iOS and Android.
- pkgver = 1.19.0.5.0.pre.r39.9037ccd355
+ pkgver = 1.20.0.7.0.pre.r96.a1a5a8f635
pkgrel = 1
url = https://flutter.io
install = flutter.install
@@ -9,11 +9,10 @@ pkgbase = flutter-git
license = BSD
license = CCPL
makedepends = python
- depends = bash
depends = git
depends = glu
depends = java-environment
- depends = lib32-libglvnd
+ depends = libglvnd
depends = unzip
optdepends = android-sdk
optdepends = android-studio
diff --git a/PKGBUILD b/PKGBUILD
index 50279d7ba330..f25793b108ff 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,13 @@
# Maintainer: Fredy GarcĂ­a <frealgagu at gmail dot com>
pkgname=flutter-git
-pkgver=1.19.0.5.0.pre.r39.9037ccd355
+pkgver=1.20.0.7.0.pre.r96.a1a5a8f635
pkgrel=1
pkgdesc="A new mobile app SDK to help developers and designers build modern mobile apps for iOS and Android."
arch=("x86_64")
url="https://${pkgname%-git}.io"
license=("custom" "BSD" "CCPL")
-depends=("bash" "git" "glu" "java-environment" "lib32-libglvnd" "unzip")
+depends=("git" "glu" "java-environment" "libglvnd" "unzip")
optdepends=("android-sdk" "android-studio" "dart" "intellij-idea-community-edition" "intellij-idea-ultimate-edition" "perl" "python")
makedepends=("python")
provides=("${pkgname%-git}")
diff --git a/flutter.install b/flutter.install
index 38b040390344..8e5693109561 100644
--- a/flutter.install
+++ b/flutter.install
@@ -1,20 +1,15 @@
post_install() {
+ groupadd -f flutterusers
+ chgrp -R flutterusers /opt/flutter
+ chmod -R g+w /opt/flutter
printf "$(tput setaf 4)Flutter was installed on $(tput setaf 2)/opt/flutter$(tput sgr0)\n"
printf "$(tput setaf 4)$(tput sgr0)\n"
- printf "$(tput setaf 4)You need to source $(tput setaf 2)/etc/profile$(tput setaf 4) or relogin to add flutter to your path.$(tput sgr0)\n"
+ printf "$(tput setaf 4)If you intend to use it as a regular user, add your user into the group flutterusers:$(tput sgr0)\n"
+ printf "$(tput setaf 2)gpasswd -a <user> flutterusers$(tput sgr0)\n"
printf "$(tput setaf 4)$(tput sgr0)\n"
- printf "$(tput setaf 4)This folder has root permissions, so keep in mind to run flutter as root,$(tput sgr0)\n"
- printf "$(tput setaf 4)otherwise you will not be able to modify anything in this directory.$(tput sgr0)\n"
+ printf "$(tput setaf 4)You need to source $(tput setaf 2)/etc/profile$(tput setaf 4) or relogin to add flutter to your path.$(tput sgr0)\n"
printf "$(tput setaf 4)$(tput sgr0)\n"
- printf "$(tput setaf 4)If you intend to use it as a regular user, create the Flutter users group:$(tput sgr0)\n"
- printf "$(tput setaf 2)groupadd flutterusers$(tput sgr0)\n"
- printf "$(tput setaf 4)Add your user into this group:$(tput sgr0)\n"
- printf "$(tput setaf 2)gpasswd -a <user> flutterusers$(tput sgr0)\n"
- printf "$(tput setaf 4)Change folder's group.$(tput sgr0)\n"
- printf "$(tput setaf 2)chown -R :flutterusers /opt/flutter$(tput sgr0)\n"
- printf "$(tput setaf 4)Change permissions of the folder so the user that was just added to the group will be able to write in it:$(tput sgr0)\n"
- printf "$(tput setaf 2)chmod -R g+w /opt/flutter$(tput sgr0)\n"
- printf "$(tput setaf 4)Re-login your terminal in to the newly created group:$(tput sgr0)\n"
+ printf "$(tput setaf 4)Re-login your terminal in to the group flutterusers:$(tput sgr0)\n"
printf "$(tput setaf 2)newgrp flutterusers$(tput sgr0)\n"
}
@@ -23,6 +18,7 @@ post_upgrade() {
}
post_remove() {
+ groupdel flutterusers
printf "$(tput setaf 4)If you had added/modified files or permissions in folder /opt/flutter is possible you need to delete it manually.$(tput sgr0)\n"
printf "$(tput setaf 2)rm -rf /opt/flutter$(tput sgr0)\n"
}