summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBernd Müller2023-09-26 04:31:46 +0200
committerGitHub2023-09-25 21:31:46 -0500
commitec5d64d853e009df9de2126e3894efc831a29107 (patch)
treeb242c080661873ff51a3c72b2742ff00a775667a
parent9d6922c2190d3427bac0d427097a64e8c0ed32d2 (diff)
downloadaur-ec5d64d853e009df9de2126e3894efc831a29107.tar.gz
[gazebo] fix DSO missing from command line and missing zmq (#75)
* fix DSO missing from command line and missing zmq
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD5
2 files changed, 5 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 94e19b7ffb72..f5e319c0dd7c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = gazebo
pkgdesc = A multi-robot simulator for outdoor environments
pkgver = 11.13.0
- pkgrel = 1
+ pkgrel = 2
url = https://classic.gazebosim.org/
install = gazebo.install
arch = i686
@@ -31,6 +31,7 @@ pkgbase = gazebo
depends = ignition-msgs-5
depends = tinyxml2
depends = qwt
+ depends = cppzmq
optdepends = bullet: Bullet support
optdepends = cegui: Design custom graphical interfaces
optdepends = ffmpeg4.4: Playback movies on textured surfaces
diff --git a/PKGBUILD b/PKGBUILD
index 99d2215af5a5..16009ddb0cd4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,14 +10,14 @@
pkgname=gazebo
pkgver=11.13.0
-pkgrel=1
+pkgrel=2
pkgdesc="A multi-robot simulator for outdoor environments"
arch=('i686' 'x86_64')
url="https://classic.gazebosim.org/"
license=('Apache')
depends=('boost' 'curl' 'freeglut' 'freeimage' 'tbb' 'libccd' 'libltdl' 'graphviz'
'libtar' 'libxml2' 'ogre-1.9' 'protobuf' 'sdformat-9' 'ignition-math-6' 'ignition-transport-8'
- 'ignition-cmake-2' 'ignition-common-3' 'ignition-fuel_tools-4' 'ignition-msgs-5' 'tinyxml2' 'qwt')
+ 'ignition-cmake-2' 'ignition-common-3' 'ignition-fuel_tools-4' 'ignition-msgs-5' 'tinyxml2' 'qwt' 'cppzmq')
optdepends=('bullet: Bullet support'
'cegui: Design custom graphical interfaces'
'ffmpeg4.4: Playback movies on textured surfaces'
@@ -40,6 +40,7 @@ build() {
mkdir -p build && cd build
export PKG_CONFIG_PATH=/usr/lib/ffmpeg4.4/pkgconfig
+ export LDFLAGS="-Wl,--copy-dt-needed-entries"
cmake .. -DCMAKE_BUILD_TYPE="Release" \
-DCMAKE_INSTALL_PREFIX="/usr" \
-DCMAKE_INSTALL_LIBDIR="lib"