summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKyle Keen2020-05-14 21:20:57 -0400
committerKyle Keen2020-05-14 21:20:57 -0400
commitec62bff1cdd71cf03097ae195caa79df39867d6d (patch)
tree3b2a1398c97b9edfdf8e191131c348c56fb033b5
parent2c434dd00fff656ef01b576683fb84bd01ce93e9 (diff)
downloadaur-ec62bff1cdd71cf03097ae195caa79df39867d6d.tar.gz
1.12 update
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD11
2 files changed, 13 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 08a902329a9a..72d3614f3ae4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Wed Aug 14 09:28:27 UTC 2019
+# Fri May 15 01:20:53 UTC 2020
pkgbase = micropython
pkgdesc = Python3 for microcontrollers, with stdlib. (unix version)
- pkgver = 1.11
+ pkgver = 1.12
pkgrel = 1
url = http://micropython.org/
arch = i686
@@ -15,15 +15,15 @@ pkgbase = micropython
depends = libffi
depends = mbedtls
options = !emptydirs
- source = mpy-1.11.tgz::https://github.com/micropython/micropython/archive/v1.11.tar.gz
+ source = mpy-1.12.tgz::https://github.com/micropython/micropython/archive/v1.12.tar.gz
source = mlib-1.9.3.tgz::https://github.com/micropython/micropython-lib/archive/v1.9.3.tar.gz
source = axtls-1.8.2.tgz::https://github.com/pfalcon/axtls/archive/v1.8.2.tar.gz
- source = ffi-3.2.1.tgz::https://github.com/libffi/libffi/archive/v3.2.1.tar.gz
+ source = ffi-3.3.tgz::https://github.com/libffi/libffi/archive/v3.3.tar.gz
source = bdb.tgz::https://github.com/pfalcon/berkeley-db-1.xx/archive/embedded.tar.gz
- md5sums = ccd9dfd01738a85f2e8bd84ac465960c
+ md5sums = 60bf0916bcbca11d484fe3ccd862a610
md5sums = 1752ce13e851a671a07ce3f7a807b21c
md5sums = e11da4ef04499030d1eff69b474f34f0
- md5sums = 9066486bcab807f7ddaaf2596348c1db
+ md5sums = f25aefb928eed09e858878382e10641f
md5sums = SKIP
pkgname = micropython
diff --git a/PKGBUILD b/PKGBUILD
index a29dbe63bf1c..82ceb567042f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,11 @@
# Maintainer: Kyle Keen <keenerd@gmail.com>
pkgbase=micropython
pkgname=(micropython micropython-lib)
-pkgver=1.11
+pkgver=1.12
_libver=1.9.3
# stupid submodules
_axver=1.8.2
-_ffiver=3.2.1
+_ffiver=3.3
pkgrel=1
pkgdesc="Python3 for microcontrollers, with stdlib. (unix version)"
arch=('i686' 'x86_64')
@@ -21,12 +21,13 @@ source=("mpy-$pkgver.tgz::https://github.com/micropython/micropython/archive/v$p
"bdb.tgz::https://github.com/pfalcon/berkeley-db-1.xx/archive/embedded.tar.gz") # submodule with no releases!
# What about the lwip submodule? The repo is GONE. You didn't need an IP stack anyway.
# Maybe http://download.savannah.gnu.org/releases/lwip/lwip-2.0.0.zip is it?
-md5sums=('ccd9dfd01738a85f2e8bd84ac465960c'
+md5sums=('60bf0916bcbca11d484fe3ccd862a610'
'1752ce13e851a671a07ce3f7a807b21c'
'e11da4ef04499030d1eff69b474f34f0'
- '9066486bcab807f7ddaaf2596348c1db'
+ 'f25aefb928eed09e858878382e10641f'
'SKIP')
+
# todo:
# fix 'imported as namespace package' warnings from stdlib
@@ -52,6 +53,8 @@ prepare() {
}
build() {
+ cd "$srcdir/micropython-$pkgver/mpy-cross"
+ make
cd "$srcdir/micropython-$pkgver/ports/unix"
#make libffi
#make V=1 deplibs